Bug 91218 - FILEOPEN: File opens with modified flag already set
Summary: FILEOPEN: File opens with modified flag already set
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: ModifiedStatus
  Show dependency treegraph
 
Reported: 2015-05-11 13:07 UTC by rlk
Modified: 2020-11-20 16:26 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
File opened has modified flag already set (109.49 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-05-11 13:07 UTC, rlk
Details
Simpler spreadsheet demonstrating the same problem (83.73 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-05-11 15:14 UTC, rlk
Details
Simpler spreadsheet demonstrating the same problem (77.67 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-05-11 15:21 UTC, rlk
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rlk 2015-05-11 13:07:38 UTC
Created attachment 115491 [details]
File opened has modified flag already set

When attached file is opened, the modified flag is already set (but Undo is grayed out).  Removing the chart on the Charts sheet eliminates this.
Comment 1 rlk 2015-05-11 15:14:55 UTC
Created attachment 115497 [details]
Simpler spreadsheet demonstrating the same problem
Comment 2 rlk 2015-05-11 15:21:41 UTC
Created attachment 115498 [details]
Simpler spreadsheet demonstrating the same problem
Comment 3 raal 2015-05-11 16:37:27 UTC
I can confirm with Version: 5.0.0.0.alpha1+
Build ID: ceb6f473837261f2a6e43e028ce9da3daccc2f6c
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-05-11_13:16:38
Comment 4 rlk 2015-05-11 17:03:21 UTC
This is present in earlier versions (4.1 and 4.2 at least) as well.
Comment 5 QA Administrators 2016-09-20 09:41:35 UTC Comment hidden (obsolete)
Comment 6 rlk 2016-09-20 12:33:44 UTC
Still present in LO 5.2.1, openSUSE Leap 42.1.
Comment 7 Xisco Faulí 2017-09-29 08:51:22 UTC Comment hidden (obsolete)
Comment 8 rlk 2017-09-29 12:48:10 UTC
Bug still present in LibreOffice 5.3.6.1, openSUSE 42.3 64-bit RPMs.
Comment 9 QA Administrators 2018-09-30 02:47:19 UTC Comment hidden (obsolete)
Comment 10 rlk 2018-09-30 03:11:03 UTC
Bug still present in LibreOffice 6.0.5.2 (OpenSUSE Leap 15.0 RPMs).

Version: 6.0.5.2
Build ID: 00m0(Build:2)
CPU threads: 8; OS: Linux 4.12; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: CL
Comment 11 QA Administrators 2019-10-01 03:02:18 UTC Comment hidden (obsolete)
Comment 12 Aron Budea 2020-11-20 16:26:47 UTC
Still in 7.1.0.0.alpha1+ (548d77d0c06f7088dd3eb408797aa1fc1d7eb277) / Ubuntu. And already in 3.3.0.