Bug 91234 - Weird initial display and non-working word-wrap with automatic row height for xls file
Summary: Weird initial display and non-working word-wrap with automatic row height for...
Status: RESOLVED DUPLICATE of bug 32950
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.2.8.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-12 09:58 UTC by Felix Wolfsteller
Modified: 2017-05-02 01:01 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
XLS file that shows weird initial view and missing auto-line-height/word wrap (5.50 KB, application/vnd.ms-excel)
2015-05-12 09:58 UTC, Felix Wolfsteller
Details
Python xlwt script to generate problematic xls file (2.04 KB, text/x-python)
2015-05-12 10:00 UTC, Felix Wolfsteller
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Wolfsteller 2015-05-12 09:58:53 UTC
Created attachment 115513 [details]
XLS file that shows weird initial view and missing auto-line-height/word wrap

When opening a .xls file, the initial display is somewhat garbeled. The first line does not employ word wrap initially (resizing the window or modifying data does fix this, although then sometime the row numbering does not properly refresh).

Furthermore, the word wrap and automatic line height in the last row, second column does not apply. The document shows fine (initial word wrap and automatic line height) with Excel.

Tested on Ubuntu 14.04 with libreoffice 1:4.2.8-0ubuntu2 (default sources).

The file was created using xlwt, find reconstruction instructions in wrap_line_height.py .

Possibly related to
https://bugs.documentfoundation.org/show_bug.cgi?id=32950
or
https://bugs.documentfoundation.org/show_bug.cgi?id=34717
. Feel free to redirect me to one of these.
Comment 1 Felix Wolfsteller 2015-05-12 10:00:14 UTC
Created attachment 115514 [details]
Python xlwt script to generate problematic xls file
Comment 2 Buovjaga 2015-05-15 17:12:19 UTC
Confirmed.

It is a bit better in 5.0. No hidden cell contents, but the word wrap is still a problem.

You might want to try 5.0 yourself and confirm the improvement: http://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@46-TDF/
https://wiki.documentfoundation.org/Installing_in_parallel/Linux

Win 7 Pro 64-bit, Version: 4.4.3.2
Build ID: 88805f81e9fe61362df02b9941de8e38a9b5fd16
Locale: fi_FI

Version: 5.0.0.0.alpha1+
Build ID: 9de1d53a2ce3ee7036b4688b373db7b2235af4d9
TinderBox: Win-x86@39, Branch:master, Time: 2015-05-14_00:07:12
Locale: fi-FI (fi_FI)
Comment 3 QA Administrators 2016-09-20 09:42:15 UTC Comment hidden (obsolete)
Comment 4 m.a.riosv 2017-05-02 01:01:57 UTC

*** This bug has been marked as a duplicate of bug 32950 ***