Download it now!
Bug 91245 - LO Line Style Gets Compressed / Corrupted After Copy-Paste from Draw to Writer
Summary: LO Line Style Gets Compressed / Corrupted After Copy-Paste from Draw to Writer
Status: RESOLVED DUPLICATE of bug 41422
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-12 20:45 UTC by bugzilla
Modified: 2015-05-18 09:10 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Draw and Writer documents illustrating line-style copy problem. (18.36 KB, application/x-7z-compressed)
2015-05-12 20:45 UTC, bugzilla
Details
Corrected version, Writer & Draw Line-style problem examples (18.46 KB, application/x-7z-compressed)
2015-05-12 21:14 UTC, bugzilla
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bugzilla 2015-05-12 20:45:59 UTC
Created attachment 115531 [details]
Draw and Writer documents illustrating line-style copy problem.

I've found that copy/pasting an object between Draw and Writer introduces distortion of the line-styles.  I noticed this after making a complex diagram in Draw, then copying into Writer. It may seem a small defect, however I'm using line-styles do denote specific electrical signal types and inconsistency with dash/dot appearance is misleading.

Last minute testing shows that object line-styles move correctly between Draw and Impress, so it seems Writer is the odd one?

FINDINGS:
Draw --> Impress. No issues, object line-styles retain correct proportions and name attribute. Could copy back and forth all day with no issues.

Draw --> Writer 
Results in a visual "compression" of the object line-style.  The overall object dimensions are not affected, but the dash/dot sizing is altered. The line-style name is retained with the object.

Writer --> Draw 
Appears ok visually, however the line-style name is stripped off.


STEPS TO REPRODUCE:
a. Create an object in Draw e.g. 1mm thick line, apply a line-style e.g. "Dashed", note the default has "Fit to Line Width" enabled.   
b. Copy the object to Writer using Paste.
c. Observe visible compression of the line-style.

I've included a Draw & Writer document to illustrate the problem.


OBSERVATIONS:
My understanding is that Draw, Writer, Impress etc. share the same "standard.sod" line-style config file, so should produce the same line-style results.

However, Writer creates line-style dash/dot length and space values which are consistently 1.76 times larger than that of Draw & Impress.  Also, Writer seems to alter Draw's dash and space values and makes them the same thus changing the original mark/space ratio.
Comment 1 bugzilla 2015-05-12 21:14:20 UTC
Created attachment 115532 [details]
Corrected version, Writer & Draw Line-style problem examples
Comment 2 Buovjaga 2015-05-18 09:10:02 UTC
(In reply to bugzilla from comment #1)
> Created attachment 115532 [details]
> Corrected version, Writer & Draw Line-style problem examples

I confirm, but I managed to find a duplicate and a workaround: paste special - draw8.

Win 7 Pro 64-bit, Version: 4.4.3.2
Build ID: 88805f81e9fe61362df02b9941de8e38a9b5fd16
Locale: fi_FI

*** This bug has been marked as a duplicate of bug 41422 ***