Download it now!
Bug 91250 - FILEOPEN: Decimal Place Formatting issue with imported OOXML charts
Summary: FILEOPEN: Decimal Place Formatting issue with imported OOXML charts
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
5.0.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Balázs Varga
URL:
Whiteboard: target:7.1.0 target:7.0.0.1
Keywords: filter:ooxml
Depends on:
Blocks: OOXML-Chart
  Show dependency treegraph
 
Reported: 2015-05-13 05:18 UTC by Luke
Modified: 2020-06-16 11:09 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Comparison of Calc 5.0 vs OneDrive (269.78 KB, image/png)
2015-05-13 05:19 UTC, Luke
Details
Screenshot of the document in Word and Writer (100.54 KB, image/png)
2020-06-03 13:53 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2015-05-13 05:18:29 UTC
I've noticed the OOXML importer sometimes uses the wrong decimal truncation settings on axis labels and data labels. For example instead of a label of 61.143 the imported document uses 61.143000000000001.

Steps to reproduce:
1. Open attachment 85112 [details] in Calc
2. Open attachment 85112 [details] in Excel or OneDrive
3. Compare

I should be able to fix this by Format Axis->Numbers->Decimal places : 3 
But that does not work on this file. 

The pie charts in attachment 66947 [details], also seems to suffer from this type of issue.
Comment 1 Luke 2015-05-13 05:19:47 UTC
Created attachment 115537 [details]
Comparison of Calc 5.0 vs OneDrive
Comment 2 A (Andy) 2015-05-13 22:30:58 UTC
Reproducible with LO 4.4.3.2, Win 8.1

@Luke: I assume you mean to open the attachment in WRITER and Word.
Comment 3 QA Administrators 2017-01-03 19:42:34 UTC Comment hidden (obsolete)
Comment 4 Luke 2017-01-04 01:13:36 UTC
In Version: 5.4.0.0.alpha0+ (x64)
Build ID: bf80bbb7b75febc2769d6b64e6981224982f8fe2

attachment 66947 [details] is still wrong
attachment 85112 [details] is better but still wrong with 2 decimal places instead of [1,4]  
The control are still broke Format Axis->Numbers->Decimal places : 3 has no impact on chart.
Comment 5 QA Administrators 2018-01-05 03:42:22 UTC Comment hidden (obsolete)
Comment 6 Luke 2018-01-05 23:13:07 UTC
Still repro in Version: 6.1.0.0.alpha0+
Build ID: f1d1854ffe2c1bc456855573b3ed4ad9852f4571

attachment 85112 [details] is still wrong using 2 decimal places instead of [1,4] ( general number) that Word uses.
  
This cannot be fixed manually as the control are still broke Format Axis->Numbers->Decimal places : 3 has no impact on chart.

attachment 66947 [details] is also still wrong
Comment 7 QA Administrators 2019-01-06 04:20:03 UTC Comment hidden (obsolete)
Comment 8 Luke 2019-01-06 06:15:16 UTC
Still repro in Version: 6.3.0.0.alpha0+ (x64)
Build ID: 3a1cab17a71a9e9f52046a9a24e60f70a704a10a

attachment 85112 [details] is still wrong using 2 decimal places instead of [1,4] ( general number) that Word uses.
  
This cannot be fixed manually as the control are still broke Format Axis->Numbers->Decimal places : 3 has no impact on chart.
Comment 9 NISZ LibreOffice Team 2020-06-03 13:53:23 UTC
Created attachment 161575 [details]
Screenshot of the document in Word and Writer

Root of this problem seems to be the data table: only two decimal digits are imported even if there are more present in the file.
Comment 10 NISZ LibreOffice Team 2020-06-05 08:12:07 UTC
A similar problem was recently fixed for X/Y values in bug #130969 - here however the Category name is a numeric value with 2+ decimals.
Comment 11 Commit Notification 2020-06-10 09:40:06 UTC
Balazs Varga committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/f66fbd4fb5fd557d6065aeea987b3dafdc30a430

tdf#91250 Chart DOCX Import: Fix decimal place formatting issue

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2020-06-16 11:08:46 UTC
Balazs Varga committed a patch related to this issue.
It has been pushed to "libreoffice-7-0":

https://git.libreoffice.org/core/commit/8cde18843c155531c3a735e1e825f54aa671a47e

tdf#91250 Chart DOCX Import: Fix decimal place formatting issue

It will be available in 7.0.0.1.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Xisco Faulí 2020-06-16 11:09:47 UTC
Verified in

Version: 7.1.0.0.alpha0+
Build ID: 11d21b3c1f7754b5d13ae9ea88da562ec74366ff
CPU threads: 4; OS: Linux 4.19; UI render: default; VCL: x11
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

@Balazs Varga, thanks for fixing this issue!!