Bug Hunting Session
Bug 91270 - UI: Crash on exit after Manage Changes
Summary: UI: Crash on exit after Manage Changes
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:5.1.0 target:5.0.4
Keywords: bibisected, bisected, haveBacktrace, regression
Depends on:
Blocks: Track-Changes
  Show dependency treegraph
 
Reported: 2015-05-13 19:29 UTC by Gordo
Modified: 2017-04-18 08:34 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
backtrace (8.79 KB, text/plain)
2015-05-13 19:29 UTC, Gordo
Details
backtrace 5.1.0.0 (11.15 KB, text/plain)
2015-08-12 14:32 UTC, Gordo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gordo 2015-05-13 19:29:14 UTC
Created attachment 115575 [details]
backtrace

1. New Text Document.
2. Type "test".
3. Edit -> Track Changes -> Record Changes on.
4. Delete "test".
5. Edit -> Track Changes -> Manage Changes and Close.
6. Exit application.
Result:
Crash.

Version: 5.0.0.0.alpha1+
Build ID: 5b3a30f40a7ce476922649b734f6ede1c2fdef4b
TinderBox: Win-x86@42, Branch:master, Time: 2015-05-13_01:51:22
Comment 1 Timur 2015-05-14 11:54:39 UTC
reproduced in Windows 7 64-bit
Comment 2 A (Andy) 2015-05-14 12:18:52 UTC
For me not reproducible with LO 4.4.3.2, Win 8.1
Comment 3 Julien Nabet 2015-05-15 19:56:19 UTC
On pc Debian x86-64 with master sources updated today (9b0f3e84efb8cab0b04990507249ac9dea56e102), I don't reproduce this.

Either it's already fixed or it's perhaps a Windows only bug.
Comment 4 Gordo 2015-08-12 14:32:20 UTC
Created attachment 117862 [details]
backtrace 5.1.0.0

A more informative backtrace.

Windows Vista 64
Version: 5.1.0.0.alpha1+
Build ID: 7bdc6be9c23517eec02ce7139edd7003abbee1f8
TinderBox: Win-x86@39, Branch:master, Time: 2015-08-11_03:32:55
Comment 5 Julien Nabet 2015-08-15 07:10:54 UTC
Thank you for the bt Gordo. I increase the importance of this bugtracker since it's a crash
Comment 6 raal 2015-10-21 13:27:26 UTC
This seems to have begun at the below commit.
Adding Cc: to kendy@collabora.com ; Could you possibly take a look at this one? Thanks

18eadac2de74a05068b493b7ddf455bab9cab2a2 is the first bad commit
commit 18eadac2de74a05068b493b7ddf455bab9cab2a2
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Fri May 15 15:52:38 2015 -0500

    source sha:5f363ce8bc563f64271744026cf0e16830cf9b06

    source sha:5f363ce8bc563f64271744026cf0e16830cf9b06
author	Jan Holesovsky <kendy@collabora.com>	2015-01-02 01:32:25 (GMT)
committer	Jan Holesovsky <kendy@collabora.com>	2015-01-04 01:15:04 (GMT)
commit	5f363ce8bc563f64271744026cf0e16830cf9b06 (patch)
changes sidebar: Use images instead of texts for types of changes in Writer.
Comment 7 Commit Notification 2015-10-28 20:16:12 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a66bd32b78a8e88f24690452a96bf3f248bfa004

tdf#91270 fix crash on exit (Windows)

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2015-10-28 20:17:49 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f535211ce4687cc311a6ad6fa0ddc1054a791c4f&h=libreoffice-5-0

tdf#91270 fix crash on exit (Windows)

It will be available in 5.0.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Robinson Tryon (qubit) 2015-12-17 09:09:16 UTC Comment hidden (obsolete)