Bug 91349 - Animated gif converted to static gif in SVG export
Summary: Animated gif converted to static gif in SVG export
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Impress-Images Images-Animated 119899
  Show dependency treegraph
 
Reported: 2015-05-18 00:43 UTC by Ofir
Modified: 2019-03-21 11:54 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Presentation with animated gif (18.97 KB, application/vnd.oasis.opendocument.presentation)
2015-05-18 00:43 UTC, Ofir
Details
SVG export with static gif instead of animated gif (22.13 KB, image/svg+xml)
2015-05-18 00:44 UTC, Ofir
Details
SVG with the gif manually replaced with the original animated gif (27.82 KB, image/svg+xml)
2015-05-18 00:45 UTC, Ofir
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ofir 2015-05-18 00:43:12 UTC
The attached ODP has animated gif.
When exporting to SVG, the gif is converted to a static gif.

Tested with LO 5.0.0.0.alpha1+ 2015-05-15 and LO 4.4.2.2.
Ubuntu 15.04.
Windows 7.
Comment 1 Ofir 2015-05-18 00:43:45 UTC
Created attachment 115686 [details]
Presentation with animated gif
Comment 2 Ofir 2015-05-18 00:44:17 UTC
Created attachment 115687 [details]
SVG export with static gif instead of animated gif
Comment 3 Ofir 2015-05-18 00:45:03 UTC
Created attachment 115688 [details]
SVG with the gif manually replaced with the original animated gif
Comment 4 Buovjaga 2015-05-19 11:30:15 UTC
(In reply to Ofir from comment #1)
> Created attachment 115686 [details]
> Presentation with animated gif

Reproduced.

Win 7 Pro 64-bit Version: 5.0.0.0.alpha1+
Build ID: 158b50763962f66515062300e265839828463efa
TinderBox: Win-x86@39, Branch:master, Time: 2015-05-19_00:28:31
Locale: fi-FI (fi_FI)

Ubuntu 15.04 64-bit 
OpenOffice.org 3.3.0
OOO330m20 (Build:9567)
Comment 5 QA Administrators 2016-11-08 11:15:56 UTC Comment hidden (obsolete)
Comment 6 Ofir 2016-11-09 06:29:01 UTC
Still reproducible

Version: 5.2.3.3
Build ID: d54a8868f08a7b39642414cf2c8ef2f228f780cf
CPU Threads: 8; OS Version: Windows 6.1; UI Render: default; 
Locale: en-US (en_US); Calc: CL
Comment 7 QA Administrators 2017-11-10 08:03:07 UTC Comment hidden (obsolete)
Comment 8 Ofir 2017-11-10 12:08:03 UTC
Still reproducible with LO 6.0.0.0.alpha1.
Comment 9 QA Administrators 2018-11-11 03:46:24 UTC Comment hidden (obsolete)
Comment 10 Regina Henschel 2018-11-11 13:12:59 UTC
The error still exists in Version: 6.2.0.0.alpha1+ (x64)
Build ID: bf4fc97131147d25b18d088023262c977f0b2787
CPU threads: 8; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-11-10_01:58:33
Locale: en-US (en_US); UI-Language: en-US
Calc: CL

BTW, export to XHTML generates the correct gif-image.