Bug 91351 - EMF+ rendering problem on OS X
Summary: EMF+ rendering problem on OS X
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
4.0 all versions
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:emf
Depends on:
Blocks: EMF-WMF
  Show dependency treegraph
 
Reported: 2015-05-18 08:33 UTC by Andras Timar
Modified: 2017-04-25 07:58 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Writer file with inserted EMF image (43.28 KB, application/vnd.oasis.opendocument.text)
2015-11-03 08:59 UTC, Joe
Details
Screenshot from macOS El Captain, LibreOffice 5.3.2.2 (422.74 KB, image/png)
2017-04-25 07:58 UTC, Bartosz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andras Timar 2015-05-18 08:33:56 UTC
Open https://bugs.documentfoundation.org/attachment.cgi?id=115547 in LibreOffice on OS X. Notice that the image is not rendered correctly. The reference rendering is  https://bugs.documentfoundation.org/attachment.cgi?id=115548 while we see https://bugs.documentfoundation.org/attachment.cgi?id=115551 on Mac. 

Rendering is OK with EMF_PLUS_DISABLE=1, not perfect of course, because the EMF+ image has more details.
Comment 1 Alex Thurgood 2015-05-18 09:25:48 UTC
Confirmed on

Version: 5.0.0.0.alpha1+
Build ID: aead21f7528047fe5c31c39ac6bec14b55f80293
Locale : fr-FR (fr.UTF-8)
Comment 2 Joe 2015-11-03 08:59:37 UTC
Created attachment 120220 [details]
Writer file with inserted EMF image

The EMF image inside does not render at all under Mac OS X. Shows up fine under GNU/Linux and Windows.
Comment 3 QA Administrators 2016-11-08 11:59:13 UTC Comment hidden (obsolete)
Comment 4 Bartosz 2017-04-25 07:57:36 UTC
The issue was already resolved for MacOS. I tested it with LibreOffice 5.3
Comment 5 Bartosz 2017-04-25 07:58:44 UTC
Created attachment 132823 [details]
Screenshot from macOS El Captain, LibreOffice 5.3.2.2