Bug 91363 - AUTOCORRECTION: unable to stop correction of fractions
Summary: AUTOCORRECTION: unable to stop correction of fractions
Status: RESOLVED DUPLICATE of bug 71974
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-18 17:00 UTC by Paolo Benvenuto
Modified: 2016-03-05 14:41 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
The option to turn off replacement table (116.11 KB, image/png)
2015-12-08 13:29 UTC, AaronPeterson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paolo Benvenuto 2015-05-18 17:00:13 UTC
Calc transforms fractions (1/2, 1/4, 3/4) to unicode special characters without the possibility to disable it.

I haven't those items in the autocorrection table, and there isn't any "autocorrect fractions" or equivalent checkbox in the autocorrect options
Comment 1 m.a.riosv 2015-05-18 21:32:48 UTC
Hi @Paolo, thanks for reporting.

1/2 it's a formula, so you need to begin it with an equal = or a sign + -, in other case it is treated as text. Also depending on the locale can be treated as date.
Comment 2 Paolo Benvenuto 2015-05-19 06:14:53 UTC
it's not a matter of formula, the autocorrections happens even if I enter "sunday 1/4)"
Comment 3 Cor Nouws 2015-06-02 21:49:45 UTC
@Paolo: Isn't this something to limit with date acceptance patterns. See Tools>Options>Language settings>Languages.. ?
Comment 4 Paolo Benvenuto 2015-06-03 19:16:15 UTC
It's not a matter of dates; if it were so it would happen that 3/4 become 03/04/2015 or something similar. 

The bug is about 3/4 becoming ¾.
Comment 5 AaronPeterson 2015-12-08 13:29:03 UTC
Created attachment 121140 [details]
The option to turn off replacement table

me too.

This misfeature is controlled by a checkbox in the auto completion, and it can be disabled, but it should be disabled by default.
Comment 6 tommy27 2016-03-05 14:41:51 UTC
this is a duplicate of Bug 71974 and it's caused by autocorrect collisions.

a workaround to resolve this issue is described here:
https://bugs.documentfoundation.org/show_bug.cgi?id=71974#c4

*** This bug has been marked as a duplicate of bug 71974 ***