Bug 91376 - l10n - paragraph style name 'Quotations' not translated
Summary: l10n - paragraph style name 'Quotations' not translated
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.3.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 91616 93903 93908 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-05-19 07:35 UTC by Marc PHILIPPE
Modified: 2021-11-13 11:59 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot LibO 44410 (42.98 KB, image/jpeg)
2015-05-28 12:23 UTC, baffclan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marc PHILIPPE 2015-05-19 07:35:43 UTC
* LO 4.4.3.2
* French / German / Italian UI

In the list of predefined paragraph styles, 'Quotations' is not translated
in the forementioned languages.

By the way, it is questionable why 'Quotations' is in plural,
since every other style name is in singular.

Although 'Quotation' might be ambiguous (words vs. price),
I suppose that 'Quote of words' is meant,
so the translations should be:
* FR: Quotation -> Citation   (plural: Citations)
* DE: Quotation -> Zitat      (plural: Zitate)
* IT: Quotation -> Citazione  (plural: Citazioni)

FYI:
* in the Dutch UI, 'Quotations' is translated in plural: 'Citaten'
  (singular: Citaat);
* see also bug 81465 ('Quotations' in the Russian UI, fixed in LO 4.3.2.2).
Comment 1 Buovjaga 2015-05-19 11:03:42 UTC
Confirmed.

Win 7 Pro 64-bit, Version: 4.4.3.2
Build ID: 88805f81e9fe61362df02b9941de8e38a9b5fd16
Locale: fi_FI
Comment 2 Julien Nabet 2015-05-25 15:26:01 UTC
*** Bug 91616 has been marked as a duplicate of this bug. ***
Comment 3 Martin Srebotnjak 2015-05-25 17:53:18 UTC
In 5.0b1 I can confirm for Slovenian that this string is localizable and already localized in the build ;)
Shall I select WORKSFORME?
Comment 4 Buovjaga 2015-05-26 07:39:56 UTC
Oh, I guess we can mark as WFM, then! Thanks.
Comment 5 baffclan 2015-05-26 10:27:15 UTC
Reproduce on Windows 7 Pro X64

Version: 5.1.0.0.alpha1+
Build ID: 692c886f937c525d6bfcb541917a5114b085efa9
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-05-25_23:24:51
Locale: ja-JP (ja_JP)

See bug 91616 / attachment 116022 [details]
Comment 6 Buovjaga 2015-05-26 10:45:34 UTC
miles: do you have a screenshot for us?
Comment 7 baffclan 2015-05-28 12:23:04 UTC
Created attachment 116103 [details]
Screenshot LibO 44410

バージョン: 4.4.4.1.0+
Build ID: 24c5f9979e61fde7b098af60756a4890e5713390
ロケール: ja_JP
Comment 8 Buovjaga 2015-05-28 12:25:04 UTC
Well I'll set back to NEW.
Comment 9 sophie 2015-05-28 13:04:04 UTC
There is one occurrence of this string in .po files
French / LibreOffice 4.4 – UI / sw/source/ui/utlui.po String 84109260
Context:
poolfmt.src STR_POOLCOLL_HTML_BLOCKQUOTE string.text
KeyID: BLScF
Comment 10 Julien Nabet 2015-09-04 23:20:16 UTC
*** Bug 93908 has been marked as a duplicate of this bug. ***
Comment 11 Julien Nabet 2015-09-05 19:34:23 UTC
*** Bug 93903 has been marked as a duplicate of this bug. ***
Comment 12 Takeshi Abe 2016-03-15 09:55:38 UTC
Andras's comments on tdf#81465 have answered the cause of this issue.
Even with STR_POOLCOLL_HTML_BLOCKQUOTE translated in Pootle,
pocheck detects and rejects duplicate translations of STR_POOLCOLL_* messages
before converting .po files.

So, translators have to make sure that no collision of these translation happens, especially with STR_POOLCOLL_TOX_CITATION.
Comment 13 QA Administrators 2017-05-22 13:18:59 UTC Comment hidden (obsolete)
Comment 14 OfficeUser 2017-05-23 06:53:14 UTC
I still can reproduce this bug using:

Version: 5.3.3.2
Build-ID: 1:5.3.3~rc2-0ubuntu0.14.04.1~lo0
CPU-Threads: 8; BS-Version: Linux 4.4; UI-Render: Standard; VCL: gtk2; Layout-Engine: alt; 
Gebietsschema: de-DE (de_DE.UTF-8); Calc: group
Comment 15 baffclan 2017-12-05 12:53:27 UTC
Quotations in master has KeyID(xiVb7), it can translate.
Comment 16 Buovjaga 2017-12-05 12:59:41 UTC
(In reply to baffclan from comment #15)
> Quotations in master has KeyID(xiVb7), it can translate.

Thanks, let's close.