Bug Hunting Session
Bug 91379 - UI: Breeze icons appear in Sifr theme
Summary: UI: Breeze icons appear in Sifr theme
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.0.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Yousuf Philips (jay) (retired)
URL:
Whiteboard: target:5.1.0 target:5.0.3
Keywords:
Depends on:
Blocks: Icon-Theme-Breeze
  Show dependency treegraph
 
Reported: 2015-05-19 11:41 UTC by Gordo
Modified: 2017-04-13 13:10 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (19.01 KB, image/png)
2015-05-19 15:55 UTC, Gordo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gordo 2015-05-19 11:41:36 UTC
In Writer, some Breeze icons appear in menus, toolbars, Navigator, and Styles and Formatting.

Version: 5.0.0.0.alpha1+
Build ID: 60fb87cf6cfcbdb1a7ece00e8a2e9d1112903ed0
TinderBox: Win-x86@39, Branch:master, Time: 2015-05-18_14:12:34
Comment 2 Gordo 2015-05-19 15:55:17 UTC
Created attachment 115723 [details]
screenshot

Could you please look again.

My understanding of that commit is that if there is no unique icon for that theme then use an icon from another theme or is it doing it for the whole set.

Compare "Tables", "Comments" and "Draw objects" in Navigator with Sifr theme between 4.4.3.2 and 5.0.  These icons clearly have a Sifr style in 4.4.3.2 but in 5.0 they are Breeze.
Comment 3 Yousuf Philips (jay) (retired) 2015-06-26 14:57:28 UTC
There seems to be a problem here as icon fix didnt fix this problem.

Version: 5.1.0.0.alpha1+
Build ID: ee3d40b30816a8fc6d4e8f984659c8dfac19ec3b
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-26_00:21:32
Comment 4 Jan Holesovsky 2015-07-01 17:22:27 UTC
These icons appear in sw/imglst/nc200* .

No idea what happened to the Sifr ones in the older version, but in master, there is only sw/imglst/nc20007.png which is the hyperlink one.
Comment 5 Yousuf Philips (jay) (retired) 2015-09-29 16:46:58 UTC
So the problem is that in 4.4 sifr was falling back on tango and tango's links.txt has the necessary duplicate link entries for these sw/imglst/nc200* images but breeze doesnt.

I'll put a patch in today.
Comment 6 Yousuf Philips (jay) (retired) 2015-09-30 15:21:13 UTC
Patch is in. https://gerrit.libreoffice.org/#/c/19034/
Comment 7 Commit Notification 2015-10-01 09:34:20 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0945bef3796f751f498ed8a2222d20d9d1292371

tdf#91379 SIFR: Add entries to links.txt so icons appear in navigator

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2015-10-06 16:35:41 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f58f6d4396d517697a698c0e98e759146ae51f0d&h=libreoffice-5-0

tdf#91379 SIFR: Add entries to links.txt so icons appear in navigator

It will be available in 5.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.