Download it now!
Bug 91432 - Breeze theme - no printer symbol with large icons UI
Summary: Breeze theme - no printer symbol with large icons UI
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.0.0.0.beta1
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: andreas_k
URL:
Whiteboard: target:5.1.0 target:5.0.0.0.beta2
Keywords:
Depends on:
Blocks: Icon-Theme-Breeze 87234
  Show dependency treegraph
 
Reported: 2015-05-21 15:40 UTC by Thomas Krumbein
Modified: 2017-04-13 13:10 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
picture 1 - no printter symbol (693.06 KB, image/png)
2015-05-21 15:40 UTC, Thomas Krumbein
Details
picture 2 - on mouse over inverse icon visible (464.15 KB, image/png)
2015-05-21 15:41 UTC, Thomas Krumbein
Details
screenshot (111.82 KB, image/png)
2015-05-22 20:31 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Krumbein 2015-05-21 15:40:48 UTC
Created attachment 115770 [details]
picture 1 - no printter symbol

Using breeze icon set no printer symbol is visible in Writer (5.0.0.0 beta1).
See attached picture 1.

On Mouse over the inverse Icon is shown. See picture 2.
Comment 1 Thomas Krumbein 2015-05-21 15:41:39 UTC
Created attachment 115771 [details]
picture 2 - on mouse over inverse icon visible
Comment 2 tommy27 2015-05-22 02:01:36 UTC
I don't reproduce it on Win8x64 using 5.0.0.0.alpha1+
Build ID: 6664859e1e8b3f8b7db8c931b8d0335510c20ce0
TinderBox: Win-x86@42, Branch:master, Time: 2015-05-16_03:16:31
Locale: en-US (it_IT)
Comment 3 Thomas Krumbein 2015-05-22 05:25:45 UTC
Sorry tommy27,

we are testing 5.0.0.0.beta version!!

But - you are right: in version 5.0 alpha the icon was visible.

So - someone changed something:) 

btw: Icon is missing in all modules - not only writer.
Comment 4 tommy27 2015-05-22 05:34:30 UTC
I know you were testing the beta1 which I don't have installed yet, so I think it was valuable information to know that in alpha1 things worked well.

so it's a recent regression
Comment 5 tommy27 2015-05-22 12:19:43 UTC
the issue is related to the icon size settings in the UI.

now I have installed beta1 and I see the print icon missing with "large" icons selected from "Tools/Options/View/User" interface whilst the icon is correctly shown if you set icon size to "small"

I set status to NEW and I change the summary 
from: Breeze icon set - no printer symbol
to:   Breeze theme - no printer symbol with large icons UI

regarding alpha1 I had the "small" size icon set and it worked well but I did not try the "large" setting... so I cannot really tell if the issue was already present or not in alpha1
Comment 6 Yousuf Philips (jay) (retired) 2015-05-22 20:31:27 UTC
Created attachment 115858 [details]
screenshot

Shows fine for me with large and small icons on Linux Mint 17 Mate.

Version: 5.1.0.0.alpha1+
Build ID: 1c9302565aefb5a54b1b7f1478dd6dac724d30ea
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2015-05-21_00:47:28
Comment 7 tommy27 2015-05-23 06:26:00 UTC
@Jay
so it must be a Windows specific bug since I see the same findings as Thomas just with the Breeze theme and the large icons UI setup.

tested under Win8x64 using 5.0.0.0.beta1
Build ID: 0a16c3dda4150008d9be6f24cbd15ac198d116d3
Versione locale: en-US (it_IT)
Comment 8 tommy27 2015-05-23 06:40:44 UTC
moreover the same issue affects all LibO suite components and is not limited to Writer.
Comment 9 Yousuf Philips (jay) (retired) 2015-05-23 09:55:09 UTC
Confirmed on Windows 7 that it affects both print and print document directly, as well in impress it affects start from current slide.
Comment 10 andreas_k 2015-05-28 21:36:22 UTC
there is a problem with the png coler type. will change the icons.
Comment 11 andreas_k 2015-06-05 23:16:06 UTC
fix the problem with 16114 (https://gerrit.libreoffice.org/#/c/16114/)
Comment 12 Commit Notification 2015-06-06 13:58:56 UTC
andreas_ka committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=13a630e20aeb62709c74d3f62ae8a1fee2506c31&h=libreoffice-5-0

Breeze: fix tdf#91432 and add Calc InsertXBeforeAfter icons

It will be available in 5.0.0.0.beta2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.