Bug 91445 - Battery indicator for the presenter console
Summary: Battery indicator for the presenter console
Status: RESOLVED DUPLICATE of bug 33495
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.4.2.2 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-22 04:27 UTC by Bastián Díaz
Modified: 2015-10-08 14:31 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bastián Díaz 2015-05-22 04:27:30 UTC
You could be other indicators, but it depends on what the user can do. I think it's very important to have a battery indicator on the presenter console to see at a glance if you need to connect the mobile device (laptop or tablet) to the power adapter.

Many times I am confident in the ability of the battery in my laptop and I'm so focused on the exhibition I forget to connect my computer (or is not possible). Therefore I think it would be the best solution (OS independent).

Thanks
Comment 1 Adolfo Jayme 2015-05-22 16:43:59 UTC
Thanks for filing your enhancement request. It could be a great improvement indeed.

This one needs UI design.
Comment 2 Bastián Díaz 2015-05-23 03:57:55 UTC
(In reply to Adolfo Jayme from comment #1)
> Thanks for filing your enhancement request. It could be a great improvement
> indeed.
> 
> This one needs UI design.

This proposal stems from my experience, but it would be interesting to know if another indicator system may need to use the presenter console in Impress.

The idea is not to replicate the system status of OS in presenter console, but if you can use it and interact with the system without interrupting the presentation (always an awkward moment).

Example:

Volume: Vídeos and sound in Slides
WiFi/network:Online videos are not possible at present (impress remote?)
Bluetooth: Connection accessories (impress remote?)

Importantly, the idea is not to manage the system states through presenter console, however, have a quick look of these elements.

Thanks
Comment 3 Heiko Tietze 2015-05-23 18:20:23 UTC
Good idea. But isn't the taskbar visible in case I run a dual screen presentation with the presenter console? On the other hand the indicator should be shown as an overlay in case of single screen presentation. Perhaps only below a threshold like 15min left.
Comment 4 Bastián Díaz 2015-05-24 04:34:05 UTC
(In reply to Heiko Tietze from comment #3)
> Good idea. But isn't the taskbar visible in case I run a dual screen
> presentation with the presenter console?

It's not possible. The taskbar is not visible using the presenter console with two monitors. Also, having an indicator on the presenter console, is an independent solution of the operating system (Linux, OS X, Windows)

> On the other hand the indicator
> should be shown as an overlay in case of single screen presentation. Perhaps
> only below a threshold like 15min left.

I do not understand. With one monitor you can not use the presenter console.
In this case there is only minimize the presentation or let the operating system indicated through a notification the critical battery level.
Comment 5 Bastián Díaz 2015-10-07 17:52:02 UTC
Hello again.

I did some research the subject, and I think it would be a waste of time for developers to replicate part of the system area on the Impress presenter console, however, the current way of functioning remains the problem.

I think a more efficient way to resolve this issue and others, is able to handle the presenter console as a window (minimize, maximize, fullscreen).
Other office solutions allow you into their solutions, and in this particular case, by maintaining a presenter console maximized presentation would handle system options such as volume, brightness, energy, bluetooth/presenter remote etc.

If you so choose, you can close this bug report or change the title in case of no exist previous reports with the same improvement.

Cheers
Comment 6 Adolfo Jayme 2015-10-07 18:53:54 UTC
(In reply to Bastián Díaz from comment #5)
> I think a more efficient way to resolve this issue and others, is able to
> handle the presenter console as a window (minimize, maximize, fullscreen).

I believe there was another bug report requesting this. Let me dig a bit…

Oh yeah, it’s bug 33495. Should we close this as duplicate?
Comment 7 Bastián Díaz 2015-10-07 19:30:41 UTC
(In reply to Adolfo Jayme from comment #6)
> 
> I believe there was another bug report requesting this. Let me dig a bit…
> 
> Oh yeah, it’s bug 33495. Should we close this as duplicate?

Yes please.

I think it's better, thanks.
Comment 8 Adolfo Jayme 2015-10-08 14:31:22 UTC

*** This bug has been marked as a duplicate of bug 33495 ***