Bug Hunting Session
Bug 91446 - Starting a new file crashes the other opened files
Summary: Starting a new file crashes the other opened files
Status: RESOLVED DUPLICATE of bug 91404
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.0.0.0.beta1
Hardware: All All
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2015-05-22 06:48 UTC by k-j
Modified: 2015-05-23 06:13 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Backtrace (7.65 KB, text/plain)
2015-05-22 09:01 UTC, Timur
Details
strace in 64-bit Linux Mint Cinnamon 17.1 (53.85 KB, text/plain)
2015-05-22 10:53 UTC, Edmund Laugasson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description k-j 2015-05-22 06:48:16 UTC
1. Starting a new Draw file (doing nothing else)
2. Starting a new Writer file (doing nothing else)
3. Starting a new Calc file

=> The first two files crash while opening the third file.

WIN10 Pro Preview Build 10122
LibO 5.0.0. beta1
Comment 1 Stephan van den Akker 2015-05-22 07:24:58 UTC
Bug is not present in 

Version: 5.1.0.0.alpha1+
Build ID: 2c798538041310294ac7900b110620a8eece9150
Locale: en-GB (en_GB.UTF-8)

Fresh clean compile on:

Linux 3.11.10-29-desktop
openSUSE 13.1 (Bottle) (x86_64)

Will try again after a checkout of 5.0.0...
Comment 2 k-j 2015-05-22 07:33:40 UTC
Addition:
The first file was started with StartCenter the second and third with toolbar. Starting with menu "file - new" won't show the bug.
Comment 3 Buovjaga 2015-05-22 07:46:07 UTC
(In reply to k-j from comment #2)
> Addition:
> The first file was started with StartCenter the second and third with
> toolbar. Starting with menu "file - new" won't show the bug.

Not reproduced.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: d9ba19147d6261469407a50bad4c9a04927fb166
TinderBox: Win-x86@39, Branch:master, Time: 2015-05-21_10:31:00
Locale: fi-FI (fi_FI)

Versio: 5.0.0.0.beta1
Käännöksen ID: 0a16c3dda4150008d9be6f24cbd15ac198d116d3
Maa-asetus: fi-FI (fi_FI)
Comment 4 k-j 2015-05-22 07:55:11 UTC
(In reply to k-j from comment #0)
> 1. Starting a new Draw file (doing nothing else)
> 2. Starting a new Writer file (doing nothing else)
> 3. Starting a new Calc file
> 
> => The first two files crash while opening the third file.
> 
> WIN10 Pro Preview Build 10122
> LibO 5.0.0. beta1

LibO 5.0.0 64bit
Comment 5 Edmund Laugasson 2015-05-22 08:35:37 UTC
Using 64-bit Linux Mint Cinnamon 17.1 with 4.0.4-040004-generic kernel
Version: 5.0.0.0.beta1
Build ID: 0a16c3dda4150008d9be6f24cbd15ac198d116d3
Locale: et-EE (et_EE.UTF-8)

Starting Draw document and after that starting Writer will crash already whole LibreOffice.

I can reproduce that bug and confirm the 2nd comment - starting new document from menu File->New->.... will not crash the program.

But starting first document from Startcenter and next one from toolbar will crash the LibreOffice regardless of which order to start Writer, Calc, Impress etc.
Comment 6 Buovjaga 2015-05-22 08:38:12 UTC
Ok, let's set to NEW.
Comment 7 Timur 2015-05-22 09:01:16 UTC
Created attachment 115807 [details]
Backtrace

(In reply to k-j from comment #2)
> A new Draw file was started with StartCenter the second Writer file and third with Calc file toolbar. Starting with menu "file - new" won't show the bug.

Reproduced with LO 5.0 beta1 in Windows 7.

FAILURE_BUCKET_ID:  INVALID_POINTER_READ_c0000005_mergedlo.dll!Rectangle::IsEmpty
BUCKET_ID:  APPLICATION_FAULT_INVALID_POINTER_READ_mergedlo!Rectangle::IsEmpty+0
Comment 8 Carlos Rodriguez 2015-05-22 09:06:06 UTC
Version: 5.0.0.0.beta1
Build ID: 0a16c3dda4150008d9be6f24cbd15ac198d116d3
Locale: es-ES (es_ES.UTF-8)

First time executing LibO 5.0 dev reproduces this bug.

Second time not.
Comment 9 Arnaud LE CAM 2015-05-22 09:06:39 UTC
Can't reproduce

Version: 5.0.0.0.beta1
Build ID: 0a16c3dda4150008d9be6f24cbd15ac198d116d3
Locale : fr-FR (fr_FR.UTF-8)

Linux 3.16.0-38-generic (x86_64)
Xubuntu 14.10
Comment 10 Buovjaga 2015-05-22 09:09:55 UTC
Reverting wrong hardware & OS change.
Comment 11 Edmund Laugasson 2015-05-22 10:53:28 UTC
Created attachment 115815 [details]
strace in 64-bit Linux Mint Cinnamon 17.1

Using 64-bit Linux Mint Cinnamon 17.1 with 4.0.4-040004-generic kernel
Version: 5.0.0.0.beta1
Build ID: 0a16c3dda4150008d9be6f24cbd15ac198d116d3
Locale: et-EE (et_EE.UTF-8)
Comment 12 Jean-Baptiste Faure 2015-05-23 06:13:34 UTC
Comment #2 --> duplicate of bug 91404.

Best regards. JBF

*** This bug has been marked as a duplicate of bug 91404 ***