Bug 91476 - FILEOPEN : XLSX sparkline is not imported in LO
Summary: FILEOPEN : XLSX sparkline is not imported in LO
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:7.4.0
Keywords: filter:xlsx
: 120622 (view as bug list)
Depends on:
Blocks: XLSX xlsx-aggressive-competitors Sparklines
  Show dependency treegraph
 
Reported: 2015-05-22 12:44 UTC by darshan.gandhi
Modified: 2022-09-09 10:24 UTC (History)
13 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sparkline is not being supported in LO (238.91 KB, image/png)
2015-05-22 12:44 UTC, darshan.gandhi
Details
Sparkline_LO Import (274.26 KB, image/png)
2015-05-25 07:10 UTC, darshan.gandhi
Details
Sparkline_OriginalFile (12.51 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2015-05-25 07:10 UTC, darshan.gandhi
Details
another sample (10.44 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2019-10-25 09:58 UTC, Xisco Faulí
Details
Simple example of sparklines (9.14 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2022-04-13 06:40 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description darshan.gandhi 2015-05-22 12:44:17 UTC Comment hidden (me-too)
Comment 1 darshan.gandhi 2015-05-22 12:46:00 UTC
Comment on attachment 115824 [details]
Sparkline is not being supported in LO

Tested on below version of LO.
OS: Windows 7:64Bit
Version: 5.0.0.0.beta1
Build ID: 0a16c3dda4150008d9be6f24cbd15ac198d116d3
Locale: en-US (en_US)
Comment 2 raal 2015-05-23 06:52:13 UTC Comment hidden (obsolete)
Comment 3 darshan.gandhi 2015-05-25 07:10:15 UTC
Created attachment 116003 [details]
Sparkline_LO Import
Comment 4 darshan.gandhi 2015-05-25 07:10:45 UTC
Created attachment 116004 [details]
Sparkline_OriginalFile
Comment 5 raal 2015-05-25 07:46:22 UTC
Setting as new enhancement.
Comment 6 Timur 2018-10-16 08:24:21 UTC
*** Bug 120622 has been marked as a duplicate of this bug. ***
Comment 7 Timur 2018-10-16 08:29:27 UTC
Other example: attachment 145739 [details] from Bug 120622, screenshot MSO  attachment 145736 [details]
Comment 8 Xisco Faulí 2019-10-25 09:58:57 UTC
Created attachment 155301 [details]
another sample
Comment 9 Julien Nabet 2019-12-17 20:49:10 UTC
Xisco: trying to open your sample, it needs an external datasheet (from /tmp/TestWorkbookEn.xlsx)
Comment 10 Michael Meeks 2022-01-17 20:42:39 UTC
Shouldn't be too much of a shocker to implement this:

https://support.microsoft.com/en-us/office/analyze-trends-in-data-using-sparklines-be6579cf-a8e3-471a-a459-873614413ce1

Possibly in the easy-hack category if someone would like some code pointers.
Comment 11 Buovjaga 2022-03-08 15:21:35 UTC
First part is done: https://tomazvajngerl.blogspot.com/2022/03/sparklines-in-calc.html
Comment 12 Roman Kuznetsov 2022-04-12 20:08:13 UTC
Tomaž, in

Version: 7.4.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 4d27d087de2922f918a76437a1385dc4a287afc3
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: Skia/Raster; VCL: win
Locale: ru-RU (ru_RU); UI: en-US
Calc: CL Jumbo

I still don't see the sparklines in the example from attach
Comment 13 Roman Kuznetsov 2022-04-13 06:40:38 UTC
Created attachment 179500 [details]
Simple example of sparklines
Comment 14 Roman Kuznetsov 2022-04-13 06:46:14 UTC
Ok, when I created a simple sparkline example in Excel I could open it fine in LibreOffice

Let's close this one as FIXED

The patches are by link https://gerrit.libreoffice.org/q/owner:quikee%2540gmail.com+branch:master+sparkline

Thank you for implementing Tomaž !!!