Download it now!
Bug 91485 - UI:Cursors other than the default work but are not displayed
Summary: UI:Cursors other than the default work but are not displayed
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.0.0.0.beta1
Hardware: All Windows (All)
: highest major
Assignee: Not Assigned
URL:
Whiteboard: target:5.1.0 target:5.0.0.2
Keywords: regression
: 91108 91513 91555 91740 92267 92278 92280 92290 92331 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-05-22 15:55 UTC by pierre-yves samyn
Modified: 2016-10-25 19:23 UTC (History)
18 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot expected cursor (1.87 KB, image/png)
2015-05-22 15:55 UTC, pierre-yves samyn
Details
Screenshot cursor disappeared (1.53 KB, image/png)
2015-05-22 15:56 UTC, pierre-yves samyn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pierre-yves samyn 2015-05-22 15:55:18 UTC
Created attachment 115837 [details]
Screenshot expected cursor

Hi

The table's select tool (cursor) works but is not displayed.

Steps to reproduce:
1. File> New> Text document
2. Table> Insert table> Insert

Expected & actual result: table 2 rows/col. created

3. Move the mouse cursor into the top left of the table

Expected result: tip "Select whole table" and cursor transformation (see attached screenshot)

Actual result: tip "Select whole table" displayed but the cursor disappears.

Note that the selection works correctly if you click.

Same for the line selection by moving the cursor to the left of the table

Platform: windows 7/64 & Version: 5.0.0.0.beta1
Build ID: 0a16c3dda4150008d9be6f24cbd15ac198d116d3
Locale: fr-FR (fr_FR)

Regards
Pierre-Yves
Comment 1 pierre-yves samyn 2015-05-22 15:56:52 UTC
Created attachment 115838 [details]
Screenshot cursor disappeared
Comment 2 Jean-Baptiste Faure 2015-05-23 07:13:02 UTC
Hi Pierre-Yves,

Not reproducible for me with Version: 5.0.0.0.beta1+
Build ID: 7f49a466e85b5f5866e6af28d84ed06697e49d20
Ubuntu_15.04_x86-64
Locale : fr-FR (fr_FR.UTF-8)

Perhaps a Windows-only problem.

Best regards. JBF
Comment 3 pierre-yves samyn 2015-05-23 10:34:41 UTC
Hi

More tests, more precisions: problem is not only with the table's select tool. 
I reproduce with cursors other than the default e.g. the "drawing" cursor:

Select a shape in the "Basic Shapes", move the cursor in the document: there is no cursor (but you can draw).

So I change summary from:
The table's select tool (cursor) works but is not displayed
To: 
Cursors other than the default work but are not displayed


The problem is *not* reproduced same PC with 
Version: 5.0.0.0.alpha1+
Build ID: 6664859e1e8b3f8b7db8c931b8d0335510c20ce0
TinderBox: Win-x86@42, Branch:master, Time: 2015-05-16_03:16:31
Locale: fr-FR (fr_FR)

Regards
Pierre-Yves
Comment 4 pierre-yves samyn 2015-05-23 12:59:13 UTC
Not only a Writer problem. Change component to UI
Comment 5 pierre-yves samyn 2015-05-23 13:00:39 UTC
*** Bug 91513 has been marked as a duplicate of this bug. ***
Comment 6 pierre-yves samyn 2015-05-24 06:06:39 UTC
Confirmed by duplicate bug 91555
I set status to New
Comment 7 pierre-yves samyn 2015-05-24 06:07:57 UTC
*** Bug 91555 has been marked as a duplicate of this bug. ***
Comment 8 pierre-yves samyn 2015-05-30 05:00:08 UTC
*** Bug 91108 has been marked as a duplicate of this bug. ***
Comment 9 k-j 2015-06-10 18:22:23 UTC
Can confirm it under
WIN 8.1 64bit
LibO
Version: 5.0.0.0.beta3 (x64)
Build-ID: 96345c15d8ab19c49014f055fe41ba8e1f421e5c
Gebietsschema: de-DE (de_DE)
Comment 10 Thomas Krumbein 2015-06-22 15:09:40 UTC
Still not solved in RC1

confirmed.

Version: 5.0.0.1 (x64)
Build-ID: 9a0b23dd0ab9652e0965484934309f2d49a7758e
Gebietsschema: de-DE (de_DE)
Comment 11 Maxim Monastirsky 2015-06-23 07:58:11 UTC
*** Bug 92267 has been marked as a duplicate of this bug. ***
Comment 12 Maxim Monastirsky 2015-06-23 08:04:36 UTC
*** Bug 91740 has been marked as a duplicate of this bug. ***
Comment 13 Pedro 2015-06-23 08:55:53 UTC
Since bug #91470 is considered a Duplicate and the bug had priority set to High Major, I changed the status on this bug accordingly. Additionally I added the keyword regression since this is a Major loss of functionality. Finally as this has been replicated in Windows x86, I set Hardware to all
Comment 14 Pedro 2015-06-23 08:57:56 UTC
I typed the wrong bug number. I obviously meant Bug #91740. Sorry about the double post.
Comment 15 Maxim Monastirsky 2015-06-23 11:41:32 UTC
Can it be related to the removal of some built-in cursors made in Bug 53148?

https://wiki.documentfoundation.org/ReleaseNotes/5.0#Mouse_cursor_improvements_in_Windows
Comment 16 Buovjaga 2015-06-23 14:34:53 UTC
After discussion on IRC, I will raise priority to highest.
Comment 17 Maxim Monastirsky 2015-06-23 14:44:14 UTC
*** Bug 92278 has been marked as a duplicate of this bug. ***
Comment 18 Maxim Monastirsky 2015-06-23 15:32:29 UTC
*** Bug 92280 has been marked as a duplicate of this bug. ***
Comment 19 Rimas Kudelis (only watching bugs where I'm in CC list) 2015-06-23 20:37:56 UTC
(In reply to Maxim Monastirsky from comment #15)
> Can it be related to the removal of some built-in cursors made in Bug 53148?
> 
> https://wiki.documentfoundation.org/ReleaseNotes/5.
> 0#Mouse_cursor_improvements_in_Windows

I don't think so. The stock cursors are the one that actually work.

Is there a way to replace a cursor in Windows version of LibO without recompiling?
Comment 20 Maxim Monastirsky 2015-06-24 07:45:24 UTC
*** Bug 92290 has been marked as a duplicate of this bug. ***
Comment 21 Maxim Monastirsky 2015-06-24 07:55:28 UTC
(In reply to Rimas Kudelis from comment #19)
> Is there a way to replace a cursor in Windows version of LibO without
> recompiling?
IIRC the built-in cursors are packaged as Windows resources to one of the exe/dlls. So you can try with any Windows resource editor. (VS used the have one, maybe it still has. There are also some freeware editors available I think.)
Comment 22 Rimas Kudelis (only watching bugs where I'm in CC list) 2015-06-24 09:37:07 UTC
(In reply to Maxim Monastirsky from comment #21)
> (In reply to Rimas Kudelis from comment #19)
> > Is there a way to replace a cursor in Windows version of LibO without
> > recompiling?
> IIRC the built-in cursors are packaged as Windows resources to one of the
> exe/dlls. So you can try with any Windows resource editor. (VS used the have
> one, maybe it still has. There are also some freeware editors available I
> think.)


Interestingly, LibO 4.4.3 has a file called vcllo.dll, which contains all the cursors. LibO 5.0RC1 doesn't have that file, because it compiles with --enable-mergedlibs. This version has a mergedlo.dll file instead, but that file does not seem to contain any cursors or icons.

I couldn't find a Windows LibO5 build without mergedlibs, but I would suspect that that might be the problem.
Comment 23 Commit Notification 2015-06-25 14:13:27 UTC
Christian Lohmaier committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=df7595a5f5871f8343e4ee3869ad153e3ae4a7f3

tdf#91485 fix cursors not displayed on Windows with mergedlibs

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 24 Commit Notification 2015-06-25 14:39:03 UTC
Christian Lohmaier committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e7748f4c05cef200eb9f9fa5aecb9806091de7a1&h=libreoffice-5-0

tdf#91485 fix cursors not displayed on Windows with mergedlibs

It will be available in 5.0.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 25 Maxim Monastirsky 2015-06-25 14:40:48 UTC
*** Bug 92331 has been marked as a duplicate of this bug. ***
Comment 26 Buovjaga 2015-06-29 11:07:58 UTC
Fix verified. For 5.0 RC2 verified in https://bugs.documentfoundation.org/show_bug.cgi?id=91740#c11

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 4fff776a08dd92121ab507a1ab506ac945abaedb
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-28_00:25:54
Locale: fi-FI (fi_FI)
Comment 27 ribotb 2015-06-29 12:17:46 UTC
It seems that is OK in RC2. I tried in Writer ans Base with some tools.
Version: 5.0.0.2
Build ID: a26d58f11b99b6aeddf7f7884effea188cc6e512
Locale : fr-FR (fr_FR)
Win 7 x86

Bernard