Bug 91495 - Style preview in "Styles and Formatting" sidebar should be optional
Summary: Style preview in "Styles and Formatting" sidebar should be optional
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.0.0.0.alpha0+ Master
Hardware: Other All
: low enhancement
Assignee: Tomaz Vajngerl
QA Contact:
URL:
Whiteboard: target:5.1.0 target:5.0.0
Keywords: regression
: 98278 (view as bug list)
Depends on:
Blocks: Styles-Preview
  Show dependency treegraph
 
Reported: 2015-05-22 19:24 UTC by Stanislav Horacek
Modified: 2017-05-10 14:17 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
screen shot showing how to turn on/off preview (91.79 KB, image/png)
2016-02-29 17:25 UTC, Cor Nouws
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stanislav Horacek 2015-05-22 19:24:52 UTC
Style previews in sidebar's "Styles and Formatting" (introduced in 5.0) are nice, but they should be made optional since they can significantly decrease effectiveness of working with styles.

In my setup, I need to choose between dozens of custom styles (which I know pretty well and don't need preview of them). The previews take much more vertical space than the previous plain style names (e.g. 14 vs. 25 style names on my screen) which leads to more scrolling and slower choosing of styles.

Any solution would be very appreciated (I think even an item in Expert Config would be better than nothing).
Comment 1 Cor Nouws 2015-05-22 20:53:19 UTC
I agree (and have the idea there was already some writing on this, but cannot find where..)
Comment 2 Tomaz Vajngerl 2015-05-23 00:26:06 UTC
Yes, yes, there will be a way to turn this on and off. :)
Comment 3 David 2015-06-24 22:45:03 UTC
Even though this issue may not technically affect the function of the program, I've upgraded the importance because this is a serious UI regression in a soon to be released version.  Version 5 has now gone into a release candidate status and there is still no way that I see to disable the style preview function.  If something like this, which does not actually "fix" a real problem, can not be completed by the time of the release then it never should have been done in the first place.  This is a major UI regression for those of us who use styles extensively.
Comment 4 Iandol 2015-06-27 11:13:43 UTC
Note that style preview is broken for some styles so some way to turn this feature OFF would also be a workaround for this bug:

https://bugs.documentfoundation.org/show_bug.cgi?id=92380
Comment 5 David 2015-06-30 14:20:57 UTC
This is now an RC2 and still has not been fixed!  A UI regression of this nature should not have been allowed to get this far.
Comment 6 Cor Nouws 2015-07-14 21:32:20 UTC
(In reply to David from comment #5)
> This is now an RC2 and still has not been fixed!  A UI regression of this
> nature should not have been allowed to get this far.

I agree that it's not perfect at the moment.
On the other hand: there are quite some issues in a x.y.0 and x.y.1 release that are at least as annoying. After all (also when choosing a selection of the styles, not all) work can go on, apart from some corner cases that need special attention from the user.
So if I look at this from the positive side: let's trust it will be fixed in time for one of the early releases.

I hope you can live with this and that it doesn't disturb your sleep ;)

Cheers,
Cor
Comment 7 Commit Notification 2015-07-17 01:03:03 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=210f42a318cbac62de835ccacbc1fc0e36f713f6

tdf#91495 add property to turn off stlye previews

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Adolfo Jayme 2015-07-17 04:36:31 UTC
This Critical? Madness.
Comment 9 V Stuart Foote 2015-07-17 14:25:43 UTC
On Widnows 7 sp1, 64-bit en-US with
Version: 5.1.0.0.alpha1+ (x64)
Build ID: 14257152b19c08618a107c6eb0f684de11483da8
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-07-17_03:23:36
Locale: en-US (en_US)

Using Tools -> Options -> Advanced: Expert Configuration to search for
"StylesAndFormatting" and setting false correctly disables all rendering in the Sidebar's Styles and Formatting Content Panel. Close module and reopen (no need to exit). 

Without style applied the selection labels all look to be rendered in the LO system default at a fixed font size and pitch. Applies the same to Paragraph, Character, Frame, Page and List tabs all of which just list their selections unstyled.

A little jarring visually, in that only the Hierarchical listing collapses the list to single spacing--all other selections are multi-line spacing (or maybe have too much padding).  Might be more appealing if all the now unstyled lists can be collapsed to single line spacing.

Also, the Formatting toolbar "Apply Style" dropdown, continues to render its list of defined styles, which might also annoy folks for Styles that do not show complete fidelity.
Comment 10 Cor Nouws 2015-07-17 14:53:11 UTC
@stuart:

Thanks for your detailed testing!

(In reply to V Stuart Foote from comment #9)

> Also, the Formatting toolbar "Apply Style" dropdown, continues to render its
> list of defined styles, which might also annoy folks for Styles that do not
> show complete fidelity.

That feature already exists for much longer. So if people would be annoyed by that, I expect that to be expressed by a separate issue.

@tomaz: 

thanks for the option!
Is it possible to push to 5.0.0 too (with tripple review prolly)?
Comment 11 Tomaz Vajngerl 2015-07-18 04:04:38 UTC
Yes, I'll backport this ASAP
Comment 12 Commit Notification 2015-07-18 08:22:37 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9f75bad228ca1f410b7a450084b02ad13745110e

tdf#91495 don't change tree entry height when preview is disabled

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Tomaz Vajngerl 2015-07-18 08:35:27 UTC
for branch libreoffice 5-0-0:
https://gerrit.libreoffice.org/17177
https://gerrit.libreoffice.org/17178

for branch libreoffice 5-0-0:
https://gerrit.libreoffice.org/17179
https://gerrit.libreoffice.org/17180
Comment 14 Tomaz Vajngerl 2015-07-18 08:36:26 UTC
Upps... I mean:

for branch libreoffice 5-0:
https://gerrit.libreoffice.org/17177
https://gerrit.libreoffice.org/17178
 
for branch libreoffice 5-0-0:
https://gerrit.libreoffice.org/17179
https://gerrit.libreoffice.org/17180
Comment 15 Commit Notification 2015-07-20 09:09:17 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6c7451681a5c5408a73fc25595c228f7922fbd29&h=libreoffice-5-0

tdf#91495 add property to turn off stlye previews

It will be available in 5.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 16 Commit Notification 2015-07-20 09:09:21 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a5712755e6af5318d264d7e2f5efb28e747b110f&h=libreoffice-5-0

tdf#91495 don't change tree entry height when preview is disabled

It will be available in 5.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 17 V Stuart Foote 2015-07-20 16:38:28 UTC
@Tomaž, *

Yep, on master that's got the spacing tamed when the Style previews are disabled from Expert Configuration. And thanks for the back ports.

Thanks!

=-ref-=
> http://cgit.freedesktop.org/libreoffice/core/commit/
> ?id=9f75bad228ca1f410b7a450084b02ad13745110e
> 
> tdf#91495 don't change tree entry height when preview is disabled
Comment 18 Commit Notification 2015-07-22 06:06:20 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "libreoffice-5-0-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5e42fa59ff1e4f46c05b1c438dd3757dbb7a14d6&h=libreoffice-5-0-0

tdf#91495 add property to turn off stlye previews

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 19 Commit Notification 2015-07-22 06:08:00 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "libreoffice-5-0-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8e957ae85f3cd9a6805296702bae41d30e6f0cef&h=libreoffice-5-0-0

tdf#91495 don't change tree entry height when preview is disabled

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 20 Jean-Baptiste Faure 2015-07-30 05:07:21 UTC
Verified fixed in LO 5.0.1.0+ built at home under Ubuntu 15.04 x86-64 with gcc 5.1.

Thank you very much.

Best regards. JBF
Comment 21 Cor Nouws 2016-02-29 17:25:06 UTC
Created attachment 123081 [details]
screen shot showing how to turn on/off preview
Comment 22 Cor Nouws 2016-02-29 17:26:37 UTC
*** Bug 98278 has been marked as a duplicate of this bug. ***