Bug Hunting Session
Bug 91507 - LibO crash when you create multiple new documents from different components
Summary: LibO crash when you create multiple new documents from different components
Status: RESOLVED DUPLICATE of bug 91404
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.0.0.0.beta1
Hardware: Other Windows (All)
: medium blocker
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-23 07:26 UTC by tommy27
Modified: 2015-05-23 10:05 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tommy27 2015-05-23 07:26:42 UTC
tested under Win8 x64 using LibO 5.0.0.0.beta1
Build ID: 0a16c3dda4150008d9be6f24cbd15ac198d116d3
Versione locale: en-US (it_IT)

----------------------
TEST 1
----------------------
a- start LibO 5.0 beta1
b- click on new Writer document in start screen
c- click on new Draw document in the "new file" toolbar dropdown menu

--> the Writer document crashes once the Draw document is created

----------------------
TEST 2
----------------------
a- start LibO 5.0 beta1
b- click on new Writer document in start screen
c- click on new Calc document in start screen
d- click on new Draw or Impress document in the "new file" toolbar dropdown menu

--> the Writer and Calc document crash once the Draw or Impress document is created

----------------------
TEST 3
----------------------
a- start LibO 5.0 beta1
b- click on new Draw document in start screen
c- click on new Calc or Writer document in start screen

--> the Draw document crash once the Calc or Writer document is created


so it seems creating multiple new documents from different suite components causes crash

if you instead create multiple new documents of the same component (i.e. 4 new Draw documents of 4 new Writer documents) there's no crash
Comment 1 raal 2015-05-23 07:51:14 UTC
Duplicate of bug 91404?
Comment 2 Jean-Baptiste Faure 2015-05-23 08:02:52 UTC
Hi Tommy,

How do you proceed to open 2 document from the startcenter (your tests 2 and 3)?
Once I have opened a file from the startcenter, the sartcenter is not accessible anymore.

For the test n°1, it is a duplicate of bug 91404.

Best regards. JBF
Comment 3 Buovjaga 2015-05-23 08:05:33 UTC
Definitely looks like a dupe.
tommy: you can verify the fix with a newer master build.
Apparently there are no daily win builds for 5.0 branch: http://dev-builds.libreoffice.org/daily/libreoffice-5-0/
Comment 4 Jean-Baptiste Faure 2015-05-23 08:08:51 UTC
(In reply to Beluga from comment #3)
> Definitely looks like a dupe.
> tommy: you can verify the fix with a newer master build.
> Apparently there are no daily win builds for 5.0 branch:
> http://dev-builds.libreoffice.org/daily/libreoffice-5-0/

The fix for bug 91404 in LO 5.0 is from this morning, you must wait for a daily build or build yourself.

Best regards. JBF
Comment 5 tommy27 2015-05-23 09:52:38 UTC
(In reply to Jean-Baptiste Faure from comment #2)
> Hi Tommy,
> 
> How do you proceed to open 2 document from the startcenter (your tests 2 and
> 3)?
> Once I have opened a file from the startcenter, the sartcenter is not
> accessible anymore.
> 
> For the test n°1, it is a duplicate of bug 91404.
> 
> Best regards. JBF

sorry, I wrote wrong infos. the second document is not opened from the start center but still from the toolbar

anyway I think you are right this is a dupe of 91404

*** This bug has been marked as a duplicate of bug 91404 ***
Comment 6 tommy27 2015-05-23 10:05:13 UTC
yes, FIXED in LibO 5.1.0.0.alpha1+
Build ID: 83eb114394879cbfd073322a51c47d02553c1fcf
TinderBox: Win-x86@39, Branch:master, Time: 2015-05-22_06:33:51
Locale: en-US (it_IT)