Bug Hunting Session
Bug 91508 - Sidebar: remove the closing button
Summary: Sidebar: remove the closing button
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.0.0.0.alpha0+ Master
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 90866 (view as bug list)
Depends on:
Blocks: Sidebar-UI-UX
  Show dependency treegraph
 
Reported: 2015-05-23 07:56 UTC by Jean-Baptiste Faure
Modified: 2017-12-13 20:19 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Baptiste Faure 2015-05-23 07:56:20 UTC
The closing button of the sidebar is useless because it is easier to close the sidebar using the button of the current opened tab.
I suggest to remove this small useless button.

Best regards. JBF
Comment 1 Jean-Baptiste Faure 2015-05-23 07:57:47 UTC
*** Bug 90866 has been marked as a duplicate of this bug. ***
Comment 2 Zangune 2015-05-23 10:44:13 UTC
Jean-Baptiste Faure, I read this ticket and the 90866 (marked as duplicate) several times, but still I can't understand why you believe this button is useless.

How can I close the sidebar without this button?

As far I can see, I have to use the dropdown menu on the left and choose "Close sidebar", but this will add an extra click and it is not so obvious as a close button.
In 90866 Patrick Gillespie suggested to replace the x button with an arrow if the close sidebar x button causes confusion with the close document x button, this seems to be a better solution than removing the close sidebar x button and forcing the user to do an extra click just to close the sidebar.
I would like to highlight the affected version field (that should be the earliest version of the software in which the bug can be reproduced) is not the same here and in 90866, maybe it needs to be changed.
Can you help me understanding this please?
Did I miss something?
Comment 3 vermontpoet 2015-05-23 13:07:24 UTC
(In reply to Zangune from comment #2)

> How can I close the sidebar without this button?

Just click on any of the sidebar buttons. In other words, if you clicked on the styles button, just click it again to close it.
Comment 4 Jean-Baptiste Faure 2015-05-23 13:43:11 UTC
(In reply to Zangune from comment #2)
> Jean-Baptiste Faure, I read this ticket and the 90866 (marked as duplicate)
> several times, but still I can't understand why you believe this button is
> useless.
> 
> How can I close the sidebar without this button?

See comment #3

> I would like to highlight the affected version field (that should be the
> earliest version of the software in which the bug can be reproduced)

It is not a bug, it is an enhancement request and I can not ask for an enhancement for 4.4 branch.
I preferred to close bug 90866 as duplicate to keep the link with this one. Reporter of bug 90866 agreed that the sidebar close button was useless.

Best regards. JBF
Comment 5 Zangune 2015-05-23 14:48:17 UTC
Thanks to both.
I believe the "click again to close" behaviour is less intuitive than "click on the close sidebar x button" and that the close document x button is too far to be confused, so I still believe that the best thing to do is either doing nothing or replacing the close sidebar x button with an arrow button.
Comment 6 vermontpoet 2015-05-23 14:54:33 UTC
(In reply to Zangune from comment #5)

"...the close document x button is too far to be confused..."

Um... obviously not. Since confusing the two buttons is what prompted the other bug report.
Comment 7 Buovjaga 2015-05-25 14:10:52 UTC
It's design team question time.
Comment 8 Yousuf Philips (jay) (retired) 2015-05-31 08:38:56 UTC
I would believe more people would click on the small 'x' than click again on the button to close. Also when you undock the sidebar, that small 'x' maybe the 'x' of the window.
Comment 9 Robinson Tryon (qubit) 2015-06-04 14:17:44 UTC
(In reply to Beluga from comment #7)
> It's design team question time.

UX-Advise:
Status -> NEW
Comment 10 V Stuart Foote 2015-06-04 14:45:27 UTC
IMO the new modal action of Tab buttons on the SideBar's TabBar to open or close the Deck duplicate the "X" close button of the Deck. It can and should be removed.

@Adolpho?
Comment 11 Adolfo Jayme 2015-06-04 16:16:48 UTC
(In reply to V Stuart Foote from comment #10)
> IMO the new modal action of Tab buttons on the SideBar's TabBar to open or
> close the Deck duplicate the "X" close button of the Deck. It can and should
> be removed.
> 
> @Adolpho?

I agree that it could be removed, but then you need to consider that there are cases in which duplication is not bad (which isn’t per se…). If Sidebar’s close button is to be removed, then we need to make it obvious for all users that they can still collapse the Sidebar by toggling one of the tab buttons in the rightmost area. And that isn’t really obvious, because those buttons do not look like toggles. In the end I have the same feeling as Jay: the current close button will be missed by many if removed altogether without working on fixing the visual issues that currently block understanding of the toggling functionality.

Just my 2 ¢
Comment 12 Robinson Tryon (qubit) 2016-08-25 05:38:57 UTC Comment hidden (obsolete)
Comment 13 Thomas Lendo 2017-12-13 19:25:14 UTC
-1 from me because users are used to use an X to close a dialog. As others said, the toggle function of the tabs isn't obvious for most users. (Personally I haven't used the X, only the toggle tabs.)
Comment 14 Heiko Tietze 2017-12-13 20:19:26 UTC
(In reply to Thomas Lendo from comment #13)
> -1 from me...

...and the rest of the design team. The idea has been discussed and rejected as the close button is defined in the HIG and has a slightly different functionality (keeps tabbar open).