Download it now!
Bug 91518 - FEATURE REQUEST: change comments using appropriate style
Summary: FEATURE REQUEST: change comments using appropriate style
Status: RESOLVED DUPLICATE of bug 87057
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.0.0.beta1
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-23 11:46 UTC by Edmund Laugasson
Modified: 2015-06-08 10:13 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Edmund Laugasson 2015-05-23 11:46:28 UTC
Using 64-bit Linux Mint Cinnamon 17.1 with 4.0.4-040004-generic kernel
LibreOffice version: 5.0.0.0.beta1
Build ID: 0a16c3dda4150008d9be6f24cbd15ac198d116d3
Locale: et-EE (et_EE.UTF-8)

There is also problem, that when formatting all comments and changing font then all comments will have white background again (bug 91515 https://bugs.documentfoundation.org/show_bug.cgi?id=91515) - so this CTRL+M workaround does not work. Here comes the feature request - make possible to configure all comments together with own style. Currently there seems to be no way to change the exact style of comments.

Strange behaviour is that when closing and reopening the file - previous comment blue background changed to yellow. This was the former .docx file, which has been saved into .odt to avoid problems of importing-exporting. Used Calibri font was previously added to Linux system.
Also when tried to change all comments simultaneously - it did not work - only that comment were changed from where the change was initiated.
Comment 1 Edmund Laugasson 2015-05-23 12:53:01 UTC
There is also an idea to change comment box size, color, border size and color, possibly even shadow existance/color/tilt etc. When shadow is not so important then other text and box attributes are. As there is already 

To have better view for eye it sometimes (especially when there are long comments) would be good to have all comment boxes with same size. This would be e.g. one configuration option - whether to use dynamic comment box size or fixed size (height) to all or selected comment boxes.

Or another approach - there could be create some kind of intelligent algorithm to change comment size in smart way - longer comments will have larger boxes and shorter comments are smaller in height. 

One idea to make reading comments (especially long ones) easier - use CTRL+ALT+scroll (or +/- instead of scroll) on top fo comment to zoom it larger. As the CTRL+ALT+C is for comment inserting then using zoom keys will zoom in/out the active comment or comment what is under mouse cursor.

Similar zooming feature is used by TreeSheets - http://strlen.com/treesheets/
Comment 2 Edmund Laugasson 2015-05-23 13:56:18 UTC
This could be solved as paragraph style so there would be possible format comments through all the document.
Comment 3 Edmund Laugasson 2015-05-23 14:16:01 UTC
To be more precise:

FOR TEXT - this could be solved as paragraph style so there would be possible format comments through all the document

FOR COMMENT BOX - this could be solved as frame style or create new style group if this will not suit for comment box
Comment 4 Buovjaga 2015-06-08 10:13:36 UTC

*** This bug has been marked as a duplicate of bug 87057 ***