Download it now!
Bug 91614 - Inserting of SVG containing text put on a path has incorrect offset for text
Summary: Inserting of SVG containing text put on a path has incorrect offset for text
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: SVG-Import
  Show dependency treegraph
 
Reported: 2015-05-25 13:14 UTC by zaqzaqtgbyhnujm
Modified: 2019-01-18 10:26 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Import of SVG containing text put on a path is not correct (2.99 KB, image/svg+xml)
2015-05-25 13:14 UTC, zaqzaqtgbyhnujm
Details
LibreOffice Writer file with SVG graphic inserted (21.97 KB, application/vnd.oasis.opendocument.text)
2015-05-25 13:16 UTC, zaqzaqtgbyhnujm
Details
LibbreOffice Impress with the SVG picture inserted (24.81 KB, application/vnd.oasis.opendocument.presentation)
2016-01-15 19:14 UTC, zaqzaqtgbyhnujm
Details
SVG graphic inserted in LibreOffice 5.3.0.0.beta1 to show the error is still present (54.54 KB, application/vnd.oasis.opendocument.text)
2016-11-27 21:16 UTC, zaqzaqtgbyhnujm
Details
Comparison SVG in Inkscape vs LO 6.3 (140.77 KB, image/png)
2019-01-18 10:26 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description zaqzaqtgbyhnujm 2015-05-25 13:14:59 UTC
Created attachment 116019 [details]
Import of SVG containing text put on a path is not correct

When inserting a SVG graphics file in Writer containing a so called text put on a path the position of the text is wrong.

The SVG file is created with Inkscape.

The SVG file is displayed correctly in Firefox, Google Chrome and Internet Explorer.

The error is seen on Windows 8.1 with LibreOffice 4.4.3.2
Comment 1 zaqzaqtgbyhnujm 2015-05-25 13:16:25 UTC
Created attachment 116020 [details]
LibreOffice Writer file with SVG graphic inserted

The LibreOffice Writer file with SVG graphic inserted clearly shows the error
Comment 2 zaqzaqtgbyhnujm 2015-06-05 18:33:45 UTC
When inserting a SVG graphics file in Writer containing a so called text put on a path the position of the text is wrong.

The SVG file is created with Inkscape.

The SVG file is displayed correctly in Firefox, Google Chrome and Internet Explorer.

The error is seen on Windows 8.1 with LibreOffice 4.4.3.2

The error is also present on Windows 8.1 with LibreOffice Version: 5.0.0.0.beta1
Comment 3 Buovjaga 2015-06-10 15:44:20 UTC
Confirmed, text is not at the middle of the path, but sliding downhill.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 698b344fdf42cc9738d5e91cd27876ce1ff39daf
TinderBox: Win-x86@39, Branch:master, Time: 2015-06-10_02:24:19
Locale: fi-FI (fi_FI)
Comment 4 zaqzaqtgbyhnujm 2016-01-15 19:12:34 UTC
The error is still present in LibreOffice 5.1.0 RC2. The operating system used is Windows 8.1 64bit version. Danish localization for both OS and LibreOffice. 

The first attached file is a SVG file. It will display correctly in Firefox or Google Chrome.

The next attached file is a LibreOffice Writer file with the first attached SVG file inserted as a picture. Opening this file clearly shows what the error is. The text should be centered on the line. But the text is not centered on the line.

I have attached a LibreOffice Impress page made with 5.1.0 RC2. It clearly shows that the error is still present.
Comment 5 zaqzaqtgbyhnujm 2016-01-15 19:14:20 UTC
Created attachment 121960 [details]
LibbreOffice Impress with the SVG picture inserted
Comment 6 zaqzaqtgbyhnujm 2016-11-27 21:16:50 UTC
Created attachment 129054 [details]
SVG graphic inserted in LibreOffice 5.3.0.0.beta1 to show the error is still present

Am I doing something wrong in my description of the error since nobody is trying to correct the error I have described?

The error has now been present for at least for 1½ year.

The error is present in LibreOffice 5.3.0.0.beta1

The error is also present in LibreOffice 5.2.
Comment 7 Buovjaga 2016-11-27 21:30:18 UTC
(In reply to zaqzaqtgbyhnujm from comment #6)
> Am I doing something wrong in my description of the error since nobody is
> trying to correct the error I have described?

There are over ten thousand reports (bugs & features) for LibO: https://bugs.documentfoundation.org/reports.cgi?product_id=109&datasets=NEW
I think you get the point.
Comment 8 QA Administrators 2017-11-28 08:39:25 UTC Comment hidden (obsolete)
Comment 9 Roman Kuznetsov 2019-01-18 10:25:45 UTC
still repro in

Version: 6.3.0.0.alpha0+
Build ID: 6b4ea2d8ddd681fec98773d7e0bbec9657a1fc08
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded
Comment 10 Roman Kuznetsov 2019-01-18 10:26:46 UTC
Created attachment 148420 [details]
Comparison SVG in Inkscape vs LO 6.3