Download it now!
Bug 91649 - blank base "do you want to save the changes" window
Summary: blank base "do you want to save the changes" window
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
5.0.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: RenderContext
  Show dependency treegraph
 
Reported: 2015-05-26 20:02 UTC by Caolán McNamara
Modified: 2015-05-28 14:26 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Caolán McNamara 2015-05-26 20:02:27 UTC
base, tables->create table in design view->aa for field name, close window, a dialog appears, but its completely black.

reverting 95ccc26ba71259be29fde8ba6b6f52ffbe5bd3c7

"    call ApplySettings sooner when painting
    
    Change-Id: I2ddd6a6b4ccfccc55f394d8a6851843ef2479fe3"

makes it work again
Comment 1 Commit Notification 2015-05-28 09:57:50 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=737a0de6fd06070d5eb11c6dd43bb51f9cc272da

tdf#91649 call ApplySettings at a more correct place

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 2 Tomaz Vajngerl 2015-05-28 10:03:49 UTC
I couldn't reproduce this but I reverted the ApplySettings call to the previous place (well the code now is different). Did this fix the issue for you?
Comment 3 Caolán McNamara 2015-05-28 14:26:53 UTC
yup, that works perfectly for me now