Bug 91657 - .docx export: Hidden text is shown on Word when it shouldn't
Summary: .docx export: Hidden text is shown on Word when it shouldn't
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.3.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Effects DOCX-Character
  Show dependency treegraph
 
Reported: 2015-05-27 04:50 UTC by João Paulo
Modified: 2017-11-04 09:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
test FODT file with normal text and hidden text (25.70 KB, application/xml)
2015-06-05 08:17 UTC, João Paulo
Details
the "test FODT.fodt" saved as Word 2007/2010/2013 XML (first .docx option on the dropdown list) (4.11 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-06-05 08:24 UTC, João Paulo
Details
the "test FODT.fodt" saved as Office Open XML (last .docx option on the dropdown list) (4.14 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-06-05 08:30 UTC, João Paulo
Details
Word right after opening the DOCX file (it happens with the OOXML file also) (82.74 KB, image/png)
2015-06-05 08:36 UTC, João Paulo
Details
Word a few seconds after opening both DOCX and OOXML files (92.20 KB, image/png)
2015-06-05 08:37 UTC, João Paulo
Details
Word 2010 shows the "Hidden text" (as selected) is formatted as "Hidden" ("Oculto") (127.09 KB, image/png)
2015-06-05 08:45 UTC, João Paulo
Details
The DOCX.docx as saved by Word 2010 (4.11 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-06-05 08:47 UTC, João Paulo
Details
The OOXML.docx as saved by Word 2010 (4.14 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-06-05 08:48 UTC, João Paulo
Details
"test DOCX.docx" upconverted by Word 2010 (13.49 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-06-05 09:06 UTC, João Paulo
Details
"test OOXML.docx" upconverted by Word 2010 (13.93 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-06-05 09:07 UTC, João Paulo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description João Paulo 2015-05-27 04:50:49 UTC
Running LibreOffice 4.4.3.2 on Windows Vista 64 bit, but I don't know if this error is on earlier versions because I noticed it only now.

When exporting a document to .docx format (be it Word XML or Office Open XML), any text formatted as hidden is shown on Word 2010 as if it wasn't hidden. Also, it appears as if formatted with a yellow background (only on the lines, not o the paragraph).
Comment 1 Cor Nouws 2015-05-27 07:31:30 UTC
please attach your sample document, and preferably with a screenshot of the result in Word. Thanks :)
Comment 2 João Paulo 2015-06-05 08:17:35 UTC
Created attachment 116297 [details]
test FODT file with normal text and hidden text
Comment 3 João Paulo 2015-06-05 08:24:06 UTC
Created attachment 116298 [details]
the "test FODT.fodt" saved as Word 2007/2010/2013 XML (first .docx option on the dropdown list)

This document has the following paragraphs:

Normal text
Hidden text

the second paragraph shouldn't appear by default (it was formatted as hidden text). It should appear only when the ¶ button on Word is pressed.
Comment 4 João Paulo 2015-06-05 08:26:46 UTC
Sorry, the file saved as Word 2007/2010/2013 XML works normally (attachment 116298 [details] https://bugs.documentfoundation.org/attachment.cgi?id=116298).
Comment 5 João Paulo 2015-06-05 08:30:40 UTC
Created attachment 116299 [details]
the "test FODT.fodt" saved as Office Open XML (last .docx option on the dropdown list)

This file has has the following paragraphs:

Normal text
Hidden text

The hidden text shouldn't appear by default.
Comment 6 João Paulo 2015-06-05 08:35:18 UTC
Something odd happens: Word opens both files (DOCX and OOXML) without showing the hidden text at first; a few seconds later the hidden text appears. See the screenshots.
Comment 7 João Paulo 2015-06-05 08:36:01 UTC
Created attachment 116300 [details]
Word right after opening the DOCX file (it happens with the OOXML file also)
Comment 8 João Paulo 2015-06-05 08:37:34 UTC
Created attachment 116301 [details]
Word a few seconds after opening both DOCX and OOXML files
Comment 9 João Paulo 2015-06-05 08:44:09 UTC
Interesting is the fact that the "hidden text" line is formatted as hidden text, but Word doesn't respect it. I created a screenshot of Word showing it ("Oculto" is "Hidden" in Portuguese).

After saving the files, Word 2010 opens them normally, i.e., not showing the hidden text except when using the pilcrow (¶) button. I created a screenshot and saved both DOCX and OOXML by Word 2010 so you can compare the differences between what LibreOffice and Word saving files.
Comment 10 João Paulo 2015-06-05 08:45:08 UTC
Created attachment 116302 [details]
Word 2010 shows the "Hidden text" (as selected) is formatted as "Hidden" ("Oculto")
Comment 11 João Paulo 2015-06-05 08:47:58 UTC
Created attachment 116303 [details]
The DOCX.docx as saved by Word 2010
Comment 12 João Paulo 2015-06-05 08:48:37 UTC
Created attachment 116304 [details]
The OOXML.docx as saved by Word 2010
Comment 13 João Paulo 2015-06-05 09:06:08 UTC
And... Something really crazy happens:

Word 2010 still keeps opening all the attached files *showing* the "Hidden text" paragraph, *but*... If you just close the files without closing Word 2010, and then you reopen the files, Word will behave correctly.

I noticed Word 2010 opens both files as in "Compatibility Mode" ("Modo de Compatibilidade" on the screenshots attached), so I upconverted them and resaved to test what happens. It still had the same strange behavior, just the files got bigger in size (see attachments).
Comment 14 João Paulo 2015-06-05 09:06:53 UTC
Created attachment 116305 [details]
"test DOCX.docx" upconverted by Word 2010
Comment 15 João Paulo 2015-06-05 09:07:29 UTC
Created attachment 116306 [details]
"test OOXML.docx" upconverted by Word 2010
Comment 16 João Paulo 2015-06-05 09:34:38 UTC
Guys... I am so embarrassed... It seems it is not a LibreOffice bug, neither a Word bug, but an ABBY FineReader 9 Sprint COM Add-in bug!

This COM Add-in is installed with ABBY FineReader 9 Sprint and always toggles the Options, Show, Hidden text option, and only this option, on Word every time, thus not making the pilcrow (¶) button on Word appear as pressed.

After deactivating this Word supplement Add-in, things got normal again.

Marking this bug as Resolved / NotOurBug.