Bug 91680 - Active option to print comments in margin, does reserve space on the paper also when the document contains zero comments
Summary: Active option to print comments in margin, does reserve space on the paper al...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Gabor Kelemen
URL:
Whiteboard: target:6.1.0 target:6.0.3
Keywords:
: 91708 103374 108360 (view as bug list)
Depends on:
Blocks: Print-Dialog
  Show dependency treegraph
 
Reported: 2015-05-28 00:43 UTC by gpbarentsen
Modified: 2018-08-28 16:30 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
A one-page document without comments which will not print in full-page mode. (29.19 KB, application/vnd.oasis.opendocument.text)
2015-05-28 05:10 UTC, gpbarentsen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gpbarentsen 2015-05-28 00:43:20 UTC
In Writer 4.4.3.2, I inserted several comments to a research document.  I printed out a draft with comments in the margins (no problem).  After editing the document I deleted individual comments and then Removed All Comments from the document, which reverted the document to full-page display (no right-hand comment margin).

However, when I select File/Print to print the edited document, the preview pane remains shrunk with the comments margin - it also continues to print in this shrunken mode WITH the comments margin, even though there are no more comments in the document.  This bug persists even if you close and reopen both the document and LibreOffice Writer.  The document will no longer print in full-page mode.
Comment 1 gpbarentsen 2015-05-28 05:10:04 UTC
Created attachment 116095 [details]
A one-page document without comments which will not print in full-page mode.

This is the first page of the document I was editing when I discovered this bug.  It has no comments, yet I can only print it with the right-hand comment margin (i.e. not in full-page mode).
Comment 2 Cor Nouws 2015-05-28 10:02:20 UTC
Hi gpbarentsen,

Thanks for the report. 
No printer at hand here. But the print preview of your document looks fine.

Did you try what the effect is of setting/unsetting Tools > Options > Writer > Printing ... print comments in margin?
If I choose that, I see the print preview with the margins changed.
I see the same effect with a clean document. So it looks as if the setting reserves space for comments, whether present or not..
If so, it could be worth an enhancement to change the behaviour (maybe, ask the developer).

Regards,
Cor
Comment 3 gpbarentsen 2015-05-28 21:10:52 UTC
Hi Cor,
Thanks for your reply.  The Print Preview does indeed look fine, but (as per bug #91688) Print Preview doesn't display comments anyway.

But your fix DOES solve the problem and restore full-page printing, and it does seem that enabling comments in margins reserves that space, comments or not (which seems somewhat counterintuitive).  I will look, but who might I ask to see about possibly enabling this as a toggle-able option (e.g. "Print in comment-margin mode even without comments?")?

Thanks!
Comment 4 gpbarentsen 2015-05-28 21:34:12 UTC
Hi Cor,
I submitted an enhancement request here so you don't need to address my previous question.  Thanks!
Comment 5 Cor Nouws 2015-05-28 21:36:46 UTC
(In reply to gpbarentsen from comment #3)

> But your fix DOES solve the problem and restore full-page printing,

good :)

> ... but who might I
> ask to see about possibly enabling this as a toggle-able option (e.g. "Print
> in comment-margin mode even without comments?")?

Let's simply turn this report in an enhancement.
What do you think of the summary now?

Thanks,
Cor
Comment 6 Cor Nouws 2015-05-28 21:37:24 UTC
(In reply to gpbarentsen from comment #4)
> Hi Cor,
> I submitted an enhancement request here so you don't need to address my
> previous question.  Thanks!

Ah - working in parallel :)
So we can close one of the two. No problem!

Cheers
Comment 7 Cor Nouws 2015-05-29 07:36:08 UTC
*** Bug 91708 has been marked as a duplicate of this bug. ***
Comment 8 peterpan 2016-10-24 15:19:49 UTC
This bug is still present in 5.2.2.2 release. 

One the optin in setting is set to none, the page prints properly. However even with this option enabled, the with proper behaviour the LOO shoud recognize whether comment/revisions are present or not.
Comment 9 Cor Nouws 2016-10-24 15:40:32 UTC
version is always oldest version known with the issue. In this case unspecified. Thanks!
Comment 10 Cor Nouws 2016-10-26 10:58:35 UTC
*** Bug 103374 has been marked as a duplicate of this bug. ***
Comment 11 Cor Nouws 2017-06-06 13:29:07 UTC
*** Bug 108360 has been marked as a duplicate of this bug. ***
Comment 12 Dieter Praas 2017-09-09 08:38:43 UTC
*** Bug 112294 has been marked as a duplicate of this bug. ***
Comment 13 Commit Notification 2018-03-01 10:28:12 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c77e01d63b4bd4805c4a499e4e0cab917d0eb403

tdf#91680 Reserve space in margin for comments only if there are comments

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2018-03-07 12:22:18 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=176356a3c802151967c26dc78f58244fcab9693a&h=libreoffice-6-0

tdf#91680 Reserve space in margin for comments only if there are comments

It will be available in 6.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.