Bug 91684 - filter: RTF importer scales shapes incorrectly
Summary: filter: RTF importer scales shapes incorrectly
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Miklos Vajna
QA Contact:
URL:
Whiteboard: target:5.3.0 target:5.2.0.1
Keywords: filter:rtf
Depends on:
Blocks:
 
Reported: 2015-05-28 04:28 UTC by Luke
Modified: 2016-12-06 11:08 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
RTF incorrectly imported (57.95 KB, application/msword)
2015-05-28 04:28 UTC, Luke
Details
DOCX correctly imported (15.93 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-05-28 04:28 UTC, Luke
Details
Simplified document that focuses on group shape scaling only, not flipping. (5.22 KB, application/rtf)
2016-06-10 20:18 UTC, Miklos Vajna
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2015-05-28 04:28:30 UTC
Created attachment 116090 [details]
RTF incorrectly imported

Steps to reproduce:
1. Open SquareA.rtf in Writer
2. Open SquareA.docx in Writer
3. Compare

The docx file is correct, while the rtf draws the squares too big
Comment 1 Luke 2015-05-28 04:28:52 UTC
Created attachment 116091 [details]
DOCX correctly imported
Comment 2 Buovjaga 2015-06-08 13:59:20 UTC
Confirmed.

Does the rtf come from MS Office?

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: be8512f99bc9ab18e55aabe01cc0ab1e6baea9e6
TinderBox: Win-x86@39, Branch:master, Time: 2015-06-08_05:58:40
Locale: fi-FI (fi_FI)
Comment 3 Luke 2015-06-08 17:27:44 UTC
Beluga,
Yes, both files were created in Office 2013
Comment 4 Miklos Vajna 2016-06-10 20:18:51 UTC
Created attachment 125593 [details]
Simplified document that focuses on group shape scaling only, not flipping.

There are two independent problems here: the scaling of the children of the group shapes is incorrect, and then there is a problem with the flipping as well. Here is a test doc that excludes the flipping problems.
Comment 5 Commit Notification 2016-06-14 08:19:29 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c3acc06230169f141930945ebbff43b1a88dfdee

Related: tdf#91684 RTF import: fix scaling of group shape children

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Miklos Vajna 2016-06-15 09:26:54 UTC
Scaling is fixed by the above, the flipping still needs fixing.
Comment 7 Luke 2016-06-16 05:44:38 UTC
Verified Fixed. Thanks Miklos!

Do you want me to open a new bug report for the flipping issue?
Comment 8 Commit Notification 2016-06-16 08:33:39 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=63965d7dc571c7dce999980737f9d57a7c5151da

tdf#91684 RTF import: handle fFlipH and fFlipV shape props

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Miklos Vajna 2016-06-16 18:27:20 UTC
Not necessary, the problem was easy enough. :-) I'll backport these to at least libreoffice-5-2, perhaps alto to libreoffice-5-1.
Comment 10 Luke 2016-06-17 02:29:23 UTC
Both issues verified fixed. 

The RTF importer is maturing nicely. Thank you Miklos!
Comment 11 Commit Notification 2016-06-17 17:29:11 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6a10ad7145c0d77a8e9cf2481f2527a5c4d32173&h=libreoffice-5-2

tdf#91684 RTF import: handle fFlipH and fFlipV shape props

It will be available in 5.2.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.