Bug 91687 - FILESAVE: Doc exporter scales up rotated watermarks
Summary: FILESAVE: Doc exporter scales up rotated watermarks
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
5.0.0.0.beta1
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.0.0 target:5.4.0.2
Keywords: filter:doc
Depends on:
Blocks: DOC
  Show dependency treegraph
 
Reported: 2015-05-28 05:08 UTC by Luke
Modified: 2021-11-15 12:03 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample doc to demonstrate the issue (22.50 KB, application/msword)
2015-05-28 05:08 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2015-05-28 05:08:48 UTC
Created attachment 116094 [details]
Sample doc to demonstrate the issue

Steps to reproduce:
1. In Word create a file with an angled / rotated watermark
2. In Writer open the file 
3. Save as .Doc
4. Close and reopen
Comment 1 Buovjaga 2015-06-08 14:00:38 UTC
Reproduced with attachment 116094 [details].

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: be8512f99bc9ab18e55aabe01cc0ab1e6baea9e6
TinderBox: Win-x86@39, Branch:master, Time: 2015-06-08_05:58:40
Locale: fi-FI (fi_FI)
Comment 2 Luke 2015-06-08 17:42:29 UTC
Added Umesh who has fixed the .docx custom Watermark height and width issues in Bug 78301.
Comment 3 Commit Notification 2017-06-28 20:39:30 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d72e0cadceb0b43928a9b4f18d75c9d5d30afdda

Watermark: tdf#91687 correct size in the .doc

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Luke 2017-07-06 04:21:06 UTC
Verified fix in Version: 6.0.0.0.alpha0+ (x64)
Build ID: 14f562b109042ebde90261f93952b4c730e1427d

Thanks you Szymon. This is a nice interoperability improvement. In my experience, watermarks are quite common on company documents.
Comment 5 Commit Notification 2017-07-06 13:03:34 UTC
Szymon Kłos committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bba6e442b0d8a4adae1b4e64a7fa7246130e300e&h=libreoffice-5-4

Watermark: tdf#91687 correct size in the .doc

It will be available in 5.4.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 poxole 2021-11-01 12:32:37 UTC
Filseave is a free tool for rapidly testing if your document will look good when it’s exported to PDF. It’s extremely useful because it’s quick and easy to use, and you can test it on a number of different file types. Also you can visit https://www.brillassignment.co.uk/buy-assignment/ to get better ideas. You can use it to quickly test rotated watermarks, font sizes, and more. It’s a great way to get a sense for how your document will look in different formats.
Comment 7 Jacklin Albert 2021-11-12 11:26:46 UTC
Really helpful. I was looking for something related to this a long time ago, but I couldn't find it. However, the website valley helps you in many ways. If you are stuck in these things, go check it. Now I'm able to handle the watermark problem. Also, it will help you if you can't find a solution.