Bug 91734 - Bookmarks not sorted alphabetically
Summary: Bookmarks not sorted alphabetically
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.3.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-05-30 01:07 UTC by JOHN DECOULOS
Modified: 2015-06-09 08:46 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
BOOKMARKS NOT ALPHABETIZED AFTER 8 ENTRIE (170.58 KB, application/vnd.oasis.opendocument.text)
2015-05-30 01:07 UTC, JOHN DECOULOS
Details

Note You need to log in before you can comment on or make changes to this bug.
Description JOHN DECOULOS 2015-05-30 01:07:02 UTC
Created attachment 116164 [details]
BOOKMARKS NOT ALPHABETIZED AFTER 8 ENTRIE

AFTER INSERTING 8 BOOKMARKS, ADDITIONAL BOOKMARKS ARE NO LONGER ALPHABETIZED,
IN VERSION 4.4.3.2
Comment 1 raal 2015-05-31 19:40:00 UTC
Hello,
is it duplicate of bug 90415 ?
Comment 2 JOHN DECOULOS 2015-05-31 22:07:03 UTC
NO, IT IS NOT  A DUPLICATE
Comment 3 Buovjaga 2015-06-08 18:22:38 UTC
(In reply to JOHN DECOULOS from comment #2)
> NO, IT IS NOT  A DUPLICATE

The example document attachment 116164 [details] shows the bookmarks in alphabetical order in the navigator.
The bookmarks are shown in another order when right-clicking the page number in the status bar.

In my own tests the order of the list that appears after right-clicking the page number is always "by creation".

Are you saying that you did not create the bookmarks in the order they appear when right-clicking the page number?
Can you tell us the first created bookmark(s)?

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the information.
Comment 4 Buovjaga 2015-06-09 04:47:30 UTC
All right, John has informed me that the first added bookmark was DEP, so there seems to be something fishy going on.

Unfortunately, I get completely different results myself, when creating bookmarks from scratch: from the very first they do not appear alphabetized in the right-click list.

I have to ping the devs more furiously about this one and bug 90415.
Comment 5 Buovjaga 2015-06-09 08:46:02 UTC
I don't know why I started talking about bookmarks being sorted "by creation" when right-clicking the page number. They are sorted by the order they appear in the document. This has been the way since at least 3.3.0.

So the right-click view shows:
BOXFORD
CALC 98
CINVERT ODT TO PDF

While the navigator shows the correct alphabetical order:
BOXFORD
CALC 98
CARLSON

I'm closing this as invalid as there was no error.