Download it now!
Bug 91815 - Suggestion : Possibility to marked a file to retain a certain order in the file opening menu
Summary: Suggestion : Possibility to marked a file to retain a certain order in the fi...
Status: RESOLVED DUPLICATE of bug 38742
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: ux-advise (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevEval
Depends on:
Blocks:
 
Reported: 2015-06-02 15:10 UTC by Bernard Morin
Modified: 2016-01-08 13:27 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bernard Morin 2015-06-02 15:10:26 UTC
I would like to be able to mark a file with a certain rank in the opening files menu. Opening a file « push » the previous opened file in the order.
I should be able to mark a file to remain first in the order.
Comment 1 Buovjaga 2015-06-08 18:41:57 UTC
Are you referring to the "Recent documents" menu?
Comment 2 QA Administrators 2015-12-27 20:31:57 UTC Comment hidden (obsolete)
Comment 3 Bernard Morin 2016-01-06 18:16:31 UTC
(In reply to Beluga from comment #1)
> Are you referring to the "Recent documents" menu?

I would say yes to your question !.

Sometimes a file I need to use frequently gets « bump » outside the « Recent documents » menu. My request is :

When saving a file, I should be able (optional) to assign a « rank/position » to the tumbnail of my file in the « Recent documents » menu.
For example, « Options » would be :

1. First thumbnail shown (keep it at the top of the windows and at the left of the first row).

2. Show this new thumbnail at the right/next of my previous selected thumbnail (in the case I would already have other selected thumbnail files.

3. Keep the tumbnail showing in the « Recent documents » menu (meaning the thumbnail would be « push » to the left of a new created file but would still be visible in the « recent documents » menu. Previous last file would be erase from the « Recent documents » menu when my preferred/selected thumbnail would get to the bottom of the windows.
Comment 4 Buovjaga 2016-01-06 18:35:53 UTC
Ok, I will ask the UX folks, if they have any ideas on the implementation.
Comment 5 Heiko Tietze 2016-01-07 23:27:48 UTC
Let's call it a favorit function for documents. And of course, those favorits should be the first in the menus.

Although I understand your wish, it sounds to me a little bit like messing with the operating system. And as a lot of work for not much benefit. The UI is easily done: I'd just add a checkbox to the properties dialog and an icon next to the file menu entry to indicate that the document is a favorit. But storing this flag needs to be done in the ODF, and sorting the list might be not so easy.

-> needsDevEval (maybe I'm wrong and it is an easyhack)
Comment 6 Bernard Morin 2016-01-08 13:17:30 UTC
(In reply to Heiko Tietze from comment #5)
I understand your evaluation ! O.K., let me suggest another way to implement my request. Why not create/designed an upper section/line in the « Recent documents » where I would « manually » slide my preferred files. It could contain six (maybe less) boxes. Maybe this would prevent a major change to the code.
Comment 7 V Stuart Foote 2016-01-08 13:27:42 UTC
OP is referring to the StartCenter handling of the Most Recently Used list which is recorded per user into their LibreOffice profile, embedding thumbnails if not suppressed.

As laid out in META bug 61174 this is a duplicate of bug 38742

*** This bug has been marked as a duplicate of bug 38742 ***