Bug 91826 - android: Even internal links are treated as hyperlinks
Summary: android: Even internal links are treated as hyperlinks
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Android Viewer (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL: https://drive.google.com/open?id=0B0m...
Whiteboard:
Keywords:
Depends on:
Blocks: mabAndroid
  Show dependency treegraph
 
Reported: 2015-06-03 11:59 UTC by Jan Holesovsky
Modified: 2020-04-08 09:33 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
I have created an application in which there are two links 1)external which will get open in web browser 2)internal which will open in the app itself. It is correcting the bug found (8.18 MB, patch)
2016-03-24 10:02 UTC, Owais Kazi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Holesovsky 2015-06-03 11:59:28 UTC
Internal links to a table are opened in the web browser, instead of just jumping to the specified position.
Comment 1 Owais Kazi 2016-03-24 10:02:51 UTC
Created attachment 123805 [details]
I have created an application in which there are two links 1)external which will get open in web browser 2)internal which will open in the app itself. It is correcting the bug found

Open the app and see the links one is external and other is internal and both are working differently
Comment 2 Owais Kazi 2016-03-27 12:48:10 UTC
I am have submitted the link of the solution for the bug
Comment 3 Jan Holesovsky 2016-03-30 14:07:13 UTC
Owais: Can you please push the patch via gerrit?

https://wiki.documentfoundation.org/Development/gerrit

I've also CC'd JanI who can help you when you get in trouble.
Comment 4 jani 2016-03-30 14:09:24 UTC
(In reply to Jan Holesovsky from comment #3)
> Owais: Can you please push the patch via gerrit?
> 
> https://wiki.documentfoundation.org/Development/gerrit
> 
> I've also CC'd JanI who can help you when you get in trouble.

The more general introduction to how you can/should work is here:
https://wiki.documentfoundation.org/Get_Involved

have fun.
jan i.
Comment 5 Xisco Faulí 2017-09-11 08:44:38 UTC
Dear developer,
This bug has been in ASSIGNED status for more than 3 months without any
activity. Resetting it to NEW.
Please assigned it back to yourself if you're still working on this.
Comment 6 QA Administrators 2018-09-12 02:37:55 UTC Comment hidden (obsolete)
Comment 7 Michael Weghorn 2020-04-08 09:33:38 UTC
By now, internal hyperlinks are treated as such, but there's still tdf#131548 which describes that the view does not move to the link target position.

Anyway, let's close this bug as WORKSFORME, since the original issue described here no longer appears.