Bug 91849 - i18n: add Tigrigna (Ethiopia) [ti-ET] locale data
Summary: i18n: add Tigrigna (Ethiopia) [ti-ET] locale data
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Eike Rathke
QA Contact:
URL:
Whiteboard: target:5.1.0 target:5.0.0.0.beta2
Keywords:
: 91813 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-06-04 04:08 UTC by kinfe
Modified: 2016-10-25 19:24 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
this file is xml format locale file for Tigrigna-Ethiopia language. (13.29 KB, text/xml)
2015-06-04 04:08 UTC, kinfe
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kinfe 2015-06-04 04:08:49 UTC
Created attachment 116270 [details]
this file is xml format locale file for Tigrigna-Ethiopia language.

this file is my langauge(Tigrigna -Ethiopia) locale file.
Comment 1 Eike Rathke 2015-06-05 10:31:45 UTC
Thanks. Test compiling it gave some usual warnings for pitfalls, see https://wiki.documentfoundation.org/LibreOffice_Localization_Guide/How_To_Submit_New_Locale_Data#Pitfalls

Warning: FormatCode formatindex="12" for currency uses parentheses for negative amounts, which probably is not correct for locales not based on en_US.
Warning: FormatCode formatindex="13" for currency uses parentheses for negative amounts, which probably is not correct for locales not based on en_US.
Warning: FormatCode formatindex="14" for currency uses parentheses for negative amounts, which probably is not correct for locales not based on en_US.
Warning: FormatCode formatindex="15" for currency uses parentheses for negative amounts, which probably is not correct for locales not based on en_US.
Warning: FormatCode formatindex="17" for currency uses parentheses for negative amounts, which probably is not correct for locales not based on en_US.

I'll change those to
      <FormatCode>[CURRENCY]#,##0.00;-[CURRENCY]#,##0.00</FormatCode>
and related.
Comment 2 Eike Rathke 2015-06-05 10:50:34 UTC
Btw, the numeric LangID suffix after the currency symbol is to be specified without leading zero, otherwise nearly identical formats without the zero are generated and listed in the number formats dialog, so [$ብር-473]
Comment 3 Commit Notification 2015-06-05 10:50:43 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=286fa4cec2cfb1c600bfd696fb0f1b2eb361b8f0

tdf#91849 add Tigrigna (Ethiopia) [ti-ET] locale data

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2015-06-05 11:03:18 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0945699b161ffd1338041d447f64d90e8a5c0efa&h=libreoffice-5-0

tdf#91849 add Tigrigna (Ethiopia) [ti-ET] locale data

It will be available in 5.0.0.0.beta2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Adolfo Jayme 2015-06-06 15:43:15 UTC
*** Bug 91813 has been marked as a duplicate of this bug. ***