Bug 91862 - Format changes in DOC files are not displayed as tracked changes
Summary: Format changes in DOC files are not displayed as tracked changes
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 105821 (view as bug list)
Depends on:
Blocks: Track-Changes DOC
  Show dependency treegraph
 
Reported: 2015-06-04 17:16 UTC by Pedro
Modified: 2019-10-17 16:25 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
DOC text document with tracked changes (23.50 KB, application/msword)
2015-06-04 17:16 UTC, Pedro
Details
PNG image with screenshot of MS Word 2010 showing the highlighted changes (78.73 KB, image/png)
2015-06-04 17:18 UTC, Pedro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pedro 2015-06-04 17:16:38 UTC
Created attachment 116286 [details]
DOC text document with tracked changes

When opening a DOC file with track changes only text changes are displayed as modified.
This is particularly bad if users are exchanging revisions of a document.

Steps to reproduce:
1) Open the attached document in LibreOffice

Observed: only two words are marked as modified

Expected: format changes (including change to non-italic) are also marked. See attached image.

This should be considered data loss because information that should be passed between authors is lost (just happened to me on a paper to be submitted)

NOTE: I tested opening this document with LibreOffice 4.4.4, 4.3.6, 4.2.8 and 3.6.7 with the same result so I'm marking 3.6.7 as the oldest earliest affected (but maybe this occurs in all earlier releases).
Comment 1 Pedro 2015-06-04 17:18:43 UTC
Created attachment 116287 [details]
PNG image with screenshot of MS Word 2010 showing the highlighted changes
Comment 2 A (Andy) 2015-06-06 21:39:35 UTC
Reproducible with LO 4.4.3.2, Win 8.1.
MSO shows (as shown in the attachment) also the formatting changes.
Comment 3 QA Administrators 2016-09-20 09:46:06 UTC Comment hidden (obsolete)
Comment 4 Pedro 2016-09-29 14:57:21 UTC Comment hidden (obsolete)
Comment 5 Xisco Faulí 2017-02-10 11:55:56 UTC
*** Bug 105821 has been marked as a duplicate of this bug. ***
Comment 6 QA Administrators 2018-02-11 03:33:00 UTC Comment hidden (obsolete)
Comment 7 Pedro 2018-02-12 15:25:04 UTC Comment hidden (obsolete)
Comment 8 QA Administrators 2019-10-16 02:29:50 UTC Comment hidden (obsolete)
Comment 9 Pedro 2019-10-16 11:00:27 UTC
The Bug still occurs in LibreOffice version 6.2.8.1

It also occurs in AOO so even though I didn't test LO earlier than 3.6.7 (see Comment#1), I assume this was Inherited from OOo