Bug 91891 - Impress: Edit with external tool does not reload image
Summary: Impress: Edit with external tool does not reload image
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-06 11:21 UTC by Philippe Jung
Modified: 2018-08-24 13:16 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Jung 2015-06-06 11:21:57 UTC
I have an Impress presentation with image inserted from a file and cropped. I want to save space getting rid of the invisible part.
Right click on it -> Edit with external tools
Gimp opens editing image SDG4D0F.png
I select a rectangular area and resize to the selection.
I save the image erasing the previous png
I close Gimp
Back in Impress, I do again Edit with external tools. 

I expect to see only a part of the image (the previously selected rectangular zone) 

I get the full image displayed.
Comment 1 Buovjaga 2015-06-11 12:12:11 UTC
Yeah, in my case it opens Irfanview. I cropped, saved the tmp file to the temp folder. Impress didn't show any change. Edited again, new tmp file with the old uncropped image.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 5fc0cbbc1254223fedf0f78c5e7539219b228697
TinderBox: Win-x86@39, Branch:master, Time: 2015-06-11_04:30:51
Locale: fi-FI (fi_FI)
Comment 2 Buovjaga 2016-11-15 12:18:01 UTC
We got bug 103455, which is nearly similar.
Philippe: does it now work for you with the first image? If it doesn't work, the bugs are different somehow.
Comment 3 QA Administrators 2017-11-16 09:22:59 UTC Comment hidden (obsolete, span)
Comment 4 Justin L 2018-08-24 13:16:14 UTC
This works for me in 6.0.6, and also bug 103455 is fixed, so marking this as WorksForMe (although it should be noted that many external editors are breaking the image now...bug 119479)