Download it now!
Bug 91896 - Can't insert PDF file into Writer document
Summary: Can't insert PDF file into Writer document
Status: RESOLVED DUPLICATE of bug 32249
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.3.7.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-06 12:19 UTC by Patrick Sedgwick
Modified: 2015-07-01 18:06 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
an excerpt from an official UK regulatory document (49.28 KB, application/pdf)
2015-06-06 12:19 UTC, Patrick Sedgwick
Details
An example of a "Writer" document (here, in PDF form) before inserting a PDF in it (43.36 KB, application/pdf)
2015-06-14 09:36 UTC, Patrick Sedgwick
Details
An example of a PDF to be inserted into the Writer document (40.56 KB, application/pdf)
2015-06-14 09:37 UTC, Patrick Sedgwick
Details
How the "Writer" document should look after the PDF has been inserted (57.87 KB, application/pdf)
2015-06-14 09:37 UTC, Patrick Sedgwick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Sedgwick 2015-06-06 12:19:18 UTC
Created attachment 116330 [details]
an excerpt from an official UK regulatory document

1. created Writer doc.

2. Insert > File... > [choose a PDF file]

3. Result: following message box...
   ======================
    LibreOffice 4.3.7.2
    Read-Error.
    Error reading file.
    
    OK
   ======================

Notes: the same PDF file, which LibreOffice cannot insert, can be opened by: LibreOffice itself; Acrobat Reader; and Serif PagePlus X8.

I'm attaching an example PDF, but the bug is not limited to this single PDF. It occurs for any PDF I try to insert into the Writer document.
Comment 1 raal 2015-06-07 19:31:24 UTC
Hello,
is it a bug? See description in help: https://help.libreoffice.org/Writer/Insert_File   : Inserts a text file at the current cursor position.

Maybe you can use Insert > Object > OLE object
Comment 2 Patrick Sedgwick 2015-06-07 21:30:19 UTC
Hi Raal,

Thanks for your suggestion.

My Insert > File... feature works a little differently from the one you pointed to in online help. That online help talks about an "Insert toolbar", but the inbuilt help from my LibreOffice version does not.

Instead, it says (under "Inserting > text documents"):
=====================
To Insert a Text File
1. Place the cursor in the document where you want to insert the file.
2. Choose Insert - File.
3. Locate the text document that you want to insert, and then click OK.
=====================

Maybe I misunderstood the intention of the "Insert > File..." menu option. I thought it meant you can insert any one of a variety of file types.

If the intention is that only *.txt files can be inserted, maybe it would be better to re-write the menu option...
instead of:
    Insert > File...
say:
    Insert > Text (*.txt) file...

And maybe the error message box,
instead of:
    Read-error.
    Error reading file.
could say:
    File insert error.
    Only *.txt files can be inserted.

I tried Insert > Object > OLE object, but it does not work. It just places an image, of part of the first page of the PDF file, into the Writer document.
Comment 3 Jean-Baptiste Faure 2015-06-13 20:22:41 UTC
It is not a bug, it is a not implemented feature.
Please, explain what you expect when inserting a PDF in a text document:
1/ a behaviour like inserting an image?
2/ what about multipage pdf document?
3/ importing the pdf document at the cursor position?
4/ something else?

We have the same behaviour with PS files, inserting postscript files is allowed for encapsulated postscript (.EPS) only, that is for vector images.
 
Setting status to NEEDINFO. Please set it back to UNCONFIRMED once you have provided requested information.

Best regards. JBF
Comment 4 Patrick Sedgwick 2015-06-14 09:36:35 UTC
Created attachment 116524 [details]
An example of a "Writer" document (here, in PDF form) before inserting a PDF in it
Comment 5 Patrick Sedgwick 2015-06-14 09:37:12 UTC
Created attachment 116525 [details]
An example of a PDF to be inserted into the Writer document
Comment 6 Patrick Sedgwick 2015-06-14 09:37:53 UTC
Created attachment 116526 [details]
How the "Writer" document should look after the PDF has been inserted
Comment 7 Patrick Sedgwick 2015-06-14 09:42:21 UTC
Hi Jean-Baptiste,

Thank you for your comments and advice. Thank you too for asking me what I would expect from a “insert PDF file” feature.

LibreOffice Draw can *open* a multipage PDF file. I would like to see the same kind of behaviour, in a Writer document, as an *insert* feature.

Suppose I have a Writer document, with 3 pages of text. I would like to be able to insert a PDF file, anywhere in that document, at the cursor position, so that it adds the pages from the PDF, into that Writer document, after the current page.

Each inserted page should look the same in the Writer document, as it looked in the original PDF.

(And… *ideally*, if the PDF file has a mixture of images and text in it, I would ideally like the text-content to be editable in the Writer document, after the PDF is inserted.)

Maybe this is all asking for too much, but you did ask what I would like!

I’m attaching some sample documents to show the before-and-after situation I envisage.

Thanks for your time in reading this.
Comment 8 Jean-Baptiste Faure 2015-07-01 18:06:35 UTC
Well, this request feature is a duplicate of bug 32249.

Best regards. JBF

*** This bug has been marked as a duplicate of bug 32249 ***