Bug 92011 - slow typing with large numbers of comments when displayed
Summary: slow typing with large numbers of comments when displayed
Status: RESOLVED DUPLICATE of bug 61558
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.3.2 release
Hardware: x86-64 (AMD64) All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace, perf
Depends on:
Blocks: Writer-Comments
  Show dependency treegraph
 
Reported: 2015-06-11 14:44 UTC by daniel.semler
Modified: 2019-06-06 07:34 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
document with comments (508.23 KB, application/vnd.oasis.opendocument.text)
2015-08-17 18:42 UTC, David
Details
testcase (22.04 KB, application/vnd.oasis.opendocument.text)
2016-09-02 07:42 UTC, Dieter Praas
Details
Callgrind output from master (1.09 MB, application/x-xz)
2019-02-14 11:43 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description daniel.semler 2015-06-11 14:44:27 UTC
I have a document of 49000 words (269000 chars) in Ancient Greek and English. It has a lot of Comments in various places. I can only estimate the number but I would say a few hundred ( I don't know how to get a count of them ). If I check the View -> Comments box then typing is very very slow. If I turn off the check box typing is fine. I, of course, need the comments so the only workaround I have is to continue the work in a separate file.

BTW, the version above says 4.4.3.2rc but in fact the version report by LO is 4.4.3.2.

Producing a testcase should be a simple matter of creating a large enough document with a bunch of comments in it. I don't believe I can share the document I hit this on, so hopefully it's easy to repro. Let me know if not and I'll see if I can produce a document I can upload.
Comment 1 Buovjaga 2015-06-13 12:37:02 UTC
Unfortunately we can't find & replace text in comments, otherwise this would be enough to provide a testcase: https://wiki.documentfoundation.org/QA/Bugzilla/Sanitizing_Files_Before_Submission#Sanitize_file_text

Now you would have to unzip the .odt and find & replace inside the content.xml and zip again..
Comment 2 tommy27 2015-08-17 14:01:50 UTC
status NEEDINFO until valid test case is provided.
Comment 3 David 2015-08-17 18:42:57 UTC
Created attachment 117980 [details]
document with comments

See attached comments.odt document.  If slow-down is not noticeable then perform Tools | Update | Page format.  You should then notice a significant slow-down in scrolling speed.  Trying to enter text in a comment box makes LibreOffice unuseably slow (see editable comment box on 2nd page).
Comment 4 tommy27 2015-08-18 13:35:03 UTC
I confirm issue using LibO 4.4.5.1 under Win8.1 x64
Comment 5 Dieter Praas 2016-08-29 08:12:34 UTC
I confirm it with LO 5.1
Version: 5.1.5.2 (x64)
Build-ID: 7a864d8825610a8c07cfc3bc01dd4fce6a9447e5
CPU-Threads: 4; BS-Version: Windows 6.19; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE); Calc: CL
Comment 6 Dieter Praas 2016-09-02 07:42:31 UTC
Created attachment 127115 [details]
testcase
Comment 7 Buovjaga 2019-02-14 11:43:18 UTC
Created attachment 149294 [details]
Callgrind output from master

Just took it from typing

Arch Linux 64-bit
Version: 6.3.0.0.alpha0+
Build ID: a2a762a9b6cad4ab0bb1b71b99aebc8c047c94d0
CPU threads: 8; OS: Linux 4.20; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 14 February 2019
Comment 8 Telesto 2019-02-15 15:15:53 UTC

*** This bug has been marked as a duplicate of bug 61558 ***