Bug Hunting Session
Bug 92013 - When opening an RTF file, footnote formatting loses tab between number and footnote text
Summary: When opening an RTF file, footnote formatting loses tab between number and fo...
Status: RESOLVED DUPLICATE of bug 105095
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:rtf
Depends on:
Blocks: RTF RTF-Opening Footnote-Endnote
  Show dependency treegraph
 
Reported: 2015-06-11 18:39 UTC by Bernard Moreton
Modified: 2018-03-31 12:05 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample file to show tabs forced, and single tab failure (1.54 KB, application/rtf)
2015-06-11 18:39 UTC, Bernard Moreton
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bernard Moreton 2015-06-11 18:39:15 UTC
Created attachment 116470 [details]
Sample file to show tabs forced, and single tab failure

In order to get a tab separator to show, it has to be entered twice (\tab \tab ).
If a writer file is saved as Rtf, then only a single \tab is written, but on re-opening, that is lost.
Comment 1 Gordo 2015-06-12 13:12:26 UTC
I can confirm.  I even set two tab stops in the paragraph style and used both of them and only the first was displayed.

MS Word Viewer displays the extra tabs so it is a fileopen issue.

Version: 4.4.3.2
Build ID: 88805f81e9fe61362df02b9941de8e38a9b5fd16

Version: 5.1.0.0.alpha1+
Build ID: 5fc0cbbc1254223fedf0f78c5e7539219b228697
TinderBox: Win-x86@39, Branch:master, Time: 2015-06-11_04:30:51

4.2.8.2

4.1.6.2 displays the extra tabs.

Adding Miklós to CC.
Comment 2 Bernard Moreton 2015-09-11 09:43:28 UTC
But when opening as a sub-document from a master (in 5.0.1.2), the tab is nonoured, so any second tab added to force the spacing (see previous comment) is also honoured, and too much space results!
Comment 3 QA Administrators 2016-09-20 10:28:22 UTC Comment hidden (obsolete)
Comment 4 Bernard Moreton 2016-09-20 13:46:30 UTC
The bug is still present in 5.2.1.2, on Ubuntu 16.04 (r-1)
Comment 5 Justin L 2018-03-31 04:46:57 UTC
Fixed - likely by the fix for bug 105095 and thus fixed in 5.4.0.

(There are a few other bugs that really mangle this document on repeated round-trips though. Lost page breaks, header text moves into footnote.)

*** This bug has been marked as a duplicate of bug 105095 ***
Comment 6 Justin L 2018-03-31 04:51:09 UTC
(In reply to Bernard Moreton from comment #2)
> But when opening as a sub-document from a master (in 5.0.1.2), the tab is
> honoured, so any second tab added to force the spacing (see previous
> comment) is also honoured, and too much space results!

This part should be fixed in 6.1 (bug 106062)
Comment 7 Bernard Moreton 2018-03-31 09:17:18 UTC
Good, thank you!
Justin - following your references to other bugs (#5), are you taking ownership of those?
Comment 8 Justin L 2018-03-31 12:05:27 UTC
(In reply to Bernard Moreton from comment #7)
> Justin - are you taking ownership of those?
No. If those issues are important to you, please create new, separate reports for each bug.