Download it now!
Bug 92077 - FILESAVE: Rotated shapes double rotated when exported to OOXML
Summary: FILESAVE: Rotated shapes double rotated when exported to OOXML
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.1.1
Keywords: filter:docx, filter:pptx, filter:xlsx
Depends on:
Blocks:
 
Reported: 2015-06-15 03:15 UTC by Luke
Modified: 2016-10-25 19:17 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample drawing to illustrate the problem (10.85 KB, application/vnd.oasis.opendocument.presentation)
2015-06-15 03:15 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2015-06-15 03:15:21 UTC
Created attachment 116542 [details]
Sample drawing to illustrate the problem

Steps to reproduce:
1. In Impress, Draw, or Writer draw a shape
2. Rotate the shape
3. Save as PPTX or DOCX
4. Open in Impress/Powerpoint or Word/Writer

Instead of saving the original shape + a rotation angle, it looks like impress is saving a rotated version of the original shape + a rotation angle.
Comment 1 Buovjaga 2015-06-17 08:34:47 UTC
Repro with attachment 116542 [details]. It even looked skewed a bit after saving to pptx.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 80ec99db4325a439a8a3f1d420d0a80f8bf9c439
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-16_00:00:20
Locale: fi-FI (fi_FI)
Comment 2 Luke 2016-02-04 01:54:51 UTC
This was fixed recently, most likely by:
http://cgit.freedesktop.org/libreoffice/core/commit/?id=bd36889b2caa4a74d647e18fc52e455f83529be9

Thank you Andras! Native files are now exporting correctly. Do you have any idea why round-tripped files are still getting double-rotated in MSO but not LibreOffice as in Bug 91850?
Comment 3 Commit Notification 2016-02-05 10:52:02 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c756fb14769373b700fd41d4f64e8e902480645b&h=libreoffice-5-1

tdf#92077 Improve DrawingML export of rotated/flipped customshapes

It will be available in 5.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.