Bug Hunting Session
Bug 92093 - FORMATTING: Header Border and Background dialogue not synced with Header More in Page dialogue
Summary: FORMATTING: Header Border and Background dialogue not synced with Header Mor...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.4.2 rc
Hardware: x86-64 (AMD64) Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Header-Footer Writer-Styles-Page
  Show dependency treegraph
 
Reported: 2015-06-15 19:04 UTC by Gordo
Modified: 2018-03-13 14:59 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gordo 2015-06-15 19:04:41 UTC
First Bug:
1. New Text Document.
2. Insert → Header → Default Style.
3. Click in header to get blue popover and click on it.
4. Select Format Header.
5. On Header tab click on More button.
6. On Area tab, select Colour and Grey 4, OK, and OK.
Result:
No background colour in header.

The Area tab was already set to Colour when it was first opened up.  On the first time, if you select None and OK and then go back in and pick a colour then it will work.

Second Bug:
7. Select Format Header from blue popover.
8. On Header tab click on More button.
9. On Area tab, select Colour and Grey 4, OK, and OK.
Result:
We have a background colour.  Notice how when you selected Colour that Grey 4 was already selected.
10. Select Border and Background from blue popover.
11. Select a border around the whole header with Set All Four Borders and OK.
Result:
We have a border but we have lost our background colour.

This happens because the Background tab of Border and Background is set to No Fill.  It does not sync with the other dialogue.  If you set a border with Header More then that border will appear in the Border and Background dialogue.  Also, the only options in Border and Background are Colour and Graphic.

Windows Vista 64
Version: 4.4.4.2
Build ID: f784c932ccfd756d01b70b6bb5e09ff62e1b3285

There is a crash with 5.1 that I will put in another report.

Version: 5.1.0.0.alpha1+
Build ID: 46564fd97308ce070248482ad65a311a329a2b76
TinderBox: Win-x86@39, Branch:master, Time: 2015-06-15_00:08:53
Comment 1 Gordo 2015-06-15 19:09:15 UTC
The crash had the same backtrace as bug 91789.
Comment 2 Buovjaga 2015-06-17 08:22:48 UTC
Reproduced.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 80ec99db4325a439a8a3f1d420d0a80f8bf9c439
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-16_00:00:20
Locale: fi-FI (fi_FI)
Comment 3 QA Administrators 2016-09-20 10:01:39 UTC Comment hidden (obsolete)
Comment 4 Thomas Lendo 2018-03-13 14:16:30 UTC
Gordo, Buovjaga, I can't reproduce both issues.

Second bug: The Background tab of 'Border and Background' is set to No Fill, but it hasn't any effect in my test. (Also 'Border and Background' shows another dialog than the More button at the Header/Footer tab in the Page Sstyle dialog. I'll file a fresh bug for this.)

Version: 6.1.0.0.alpha0+ (x64)
Build ID: cab04bc39b5164ea74216cd849c3af5f5b298f79
CPU threads: 8; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-03-12_00:50:50
Locale: de-AT (de_AT); Calc: CL
Comment 5 Buovjaga 2018-03-13 14:59:26 UTC
Yep, let's close.

Version: 6.1.0.0.alpha0+
Build ID: 5b87abe06da35ca3a11628674af23460349b439a
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-03-12_23:45:38
Locale: fi-FI (fi_FI); Calc: group