Bug Hunting Session
Bug 92154 - UI: Long style names affect the width of dialogues
Summary: UI: Long style names affect the width of dialogues
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.4.2 rc
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Roman Kuznetsov
URL:
Whiteboard: target:6.3.0
Keywords: needsDevEval, topicUI
: 114415 (view as bug list)
Depends on:
Blocks: Paragraph-Dialog
  Show dependency treegraph
 
Reported: 2015-06-18 12:44 UTC by Gordo
Modified: 2019-01-25 07:26 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
table of dialogues (14.72 KB, application/vnd.oasis.opendocument.text)
2015-06-18 12:44 UTC, Gordo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gordo 2015-06-18 12:44:33 UTC
Created attachment 116622 [details]
table of dialogues

1. New Text Document.
2. Sidebar → Styles and Formatting → Character Styles.
3. Right click on empty space → New.
4. On Organiser tab, in Name type “reallylongcharacterstylenamewithlettersandnumbersbecausethatshowitsdone111111111111111111111111111111” and OK.
5. Right click on any character style except the one that was just created and Modify.
Result:
Character Style dialogue has changed size (slightly) because of the Inherit from dropdown list.
6. Cancel out of that and go to Paragraph Styles.
7. Right click on any style and Modify.
Result:
The Paragraph Style dialogue is wider than it normally is because of the Character Style dropdown list on the Drop Caps tab.
8. Cancel out of that and go to List Styles.
9. Right click on any style and Modify.
Result:
The List Style dialogue is wider than it normally is because of the Character style dropdown list on the Options tab.

The character style name also affects the Bullets and Numbering, Outline Numbering, Line Numbering, Footnotes/Endnotes, and Indexes and Tables (Entries tab).  It also affects the Character dialogue (Hyperlink tab).

If a list style has a very long name then this will affect the Paragraph Style dialogue because of the Numbering style dropdown list on the Outline and Numbering tab.

If a paragraph style has a very long name then this will affect the Paragraph Style dialogue when creating new styles.  It sometimes does it when modifying existing ones (Text Body).  It will affect:  the Page Style dialogue because of the Register-true Reference Style dropdown list; the Outline Numbering dialogue because of the paragraph style dropdown list; and the Footnotes/Endnotes dialogue if the paragraph style is special.  Indexes and Tables (Styles tab) is also affected.

If a page style has a very long name and this is applied to a page then this will affect the Columns dialogue because of the Apply to Page Style dropdown list.  It will also affect the Footnotes/Endnotes dialogue.

Windows Vista 64
Version: 4.4.4.2
Build ID: f784c932ccfd756d01b70b6bb5e09ff62e1b3285

Version: 5.1.0.0.alpha1+
Build ID: 46564fd97308ce070248482ad65a311a329a2b76
TinderBox: Win-x86@39, Branch:master, Time: 2015-06-15_00:08:53
Comment 1 Robinson Tryon (qubit) 2015-12-14 06:15:50 UTC Comment hidden (obsolete)
Comment 2 Björn Michaelsen 2016-01-26 17:31:26 UTC
removing skillHIG keyword. There is no such thing at https://wiki.documentfoundation.org/Development/Easy_Hacks/lists/by_Required_Skill and having a "skill*" keyword makes the easyHack not even appear on that page even in "uncategorized".
Comment 3 QA Administrators 2017-03-06 14:15:19 UTC Comment hidden (obsolete)
Comment 4 XTR 2017-12-12 12:45:10 UTC
*** Bug 114415 has been marked as a duplicate of this bug. ***
Comment 5 XTR 2017-12-12 12:47:16 UTC
Repro with
Version: 6.0.0.0.beta2 (x64)
Build ID: 13edaaa12f25de343fce136064e27da66c1c4fa4
CPU threads: 2; OS: Windows 6.1; UI render: default; 
Locale: ru-RU (ru_RU); Calc: group threaded
Comment 6 QA Administrators 2018-12-13 03:50:39 UTC Comment hidden (obsolete)
Comment 7 Roman Kuznetsov 2019-01-18 07:45:44 UTC
repro in

Version: 6.3.0.0.alpha0+
Build ID: 6b4ea2d8ddd681fec98773d7e0bbec9657a1fc08
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded
Comment 8 Commit Notification 2019-01-25 07:26:41 UTC
Roman Kuznetsov committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/b8c725cf871b56f74a74dc5d9b193331f98b3f4a%5E%21

tdf#92154 limit comboBOX_TEMPLATE length

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.