Bug 92183 - LOCALHELP: write help pages for document EVENTS (to bind to macros)
Summary: LOCALHELP: write help pages for document EVENTS (to bind to macros)
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.1.0
Keywords:
Depends on:
Blocks: HelpGaps-NewFeatures
  Show dependency treegraph
 
Reported: 2015-06-19 13:25 UTC by Olivier Hallot
Modified: 2021-05-26 18:11 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
embryo of events timeline (35.33 KB, image/png)
2020-09-05 15:33 UTC, Alain Romedenne
Details
A macro-enabled document to help establish - doc event - timelines or sequence diagrams (19.63 KB, application/vnd.oasis.opendocument.spreadsheet)
2020-09-05 16:09 UTC, Alain Romedenne
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Hallot 2015-06-19 13:25:41 UTC
The list of events for a document is not or is badly documented.

The list is at Tools - Customize - Events tab.

This list has been enhanced long time ago and not every event is correctly documented. I miss the exact meaning and the time when the event is triggered.

The help page refers to events associcated to internal objects (OLE objects, drawinfg objects, images, etc...) not the document itself.
Comment 1 Buovjaga 2015-06-21 15:17:33 UTC
NEW
Comment 2 QA Administrators 2016-09-20 10:11:23 UTC Comment hidden (obsolete)
Comment 3 Olivier Hallot 2018-11-30 10:59:12 UTC
Page to touch

sbasic/shared/01040000.xhp

Make event nomenclature compatible too:

'Start Application' instead of 'Program Start', etc...
Comment 4 Xisco Faulí 2019-06-26 09:53:34 UTC
Dear LibreOfficiant,
This bug has been in ASSIGNED status for more than 3 months without any
activity. Resetting it to NEW.
Please assigned it back to yourself if you're still working on this.
Comment 5 Alain Romedenne 2020-09-05 15:20:28 UTC
I've managed to match event names with Tools-Customize-Events dialog
Refer to https://wiki.documentfoundation.org/User:LibreOfficiant/Events#Events for description and source code references
Comment 6 Alain Romedenne 2020-09-05 15:33:37 UTC
Created attachment 165183 [details]
embryo of events timeline

event description is WiP
Comment 7 Alain Romedenne 2020-09-05 16:09:11 UTC
Created attachment 165184 [details]
A macro-enabled document to help establish - doc event - timelines or sequence diagrams

Happy Python !
Comment 8 Alain Romedenne 2020-09-05 16:10:54 UTC
Comment on attachment 165184 [details]
A macro-enabled document to help establish - doc event - timelines or sequence diagrams

requires libO 6.1 due to IiF() regression on recenter versions
Comment 9 Commit Notification 2020-09-17 22:47:06 UTC
Alain Romedenne committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/5c93f0a8c1233c584aac64be9dc77d49bf074ade

tdf#92183 Documents events refresher
Comment 10 Commit Notification 2020-10-09 16:32:51 UTC
Alain Romedenne committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/8968f31fbb6dedd29d37bfb296b9d857c6d6bc5a

tdf#92183 Database form events refresher