Bug 92190 - PRINTs landscape despite configured as portrait (Mac OS)
Summary: PRINTs landscape despite configured as portrait (Mac OS)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.4.1.2 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:6.0.0 target:5.4.4
Keywords:
: 94093 95453 96388 107898 110461 112200 112899 113728 113870 113963 114037 114053 114054 114186 114294 114298 114707 115028 115115 (view as bug list)
Depends on:
Blocks: Print-Dialog
  Show dependency treegraph
 
Reported: 2015-06-19 17:54 UTC by MJHauan
Modified: 2018-01-19 18:44 UTC (History)
40 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of LO print dialog (91.51 KB, image/png)
2017-10-04 04:53 UTC, Ovid S
Details

Note You need to log in before you can comment on or make changes to this bug.
Description MJHauan 2015-06-19 17:54:45 UTC
Brand new install via Apple App Store of LibreOffice Vanilla (6/19/2015).  Created a new text document.  Set the Format->Page to portrait. Attempted to print.  In the print dialog window, the image at far left shows document in landscape form but rotated 90 degrees (text runs top to bottom).  The Preview window shows it in portrait aspect.  When actually printed, it comes out in landscape aspect.  

Specs follow:

LibreOffice:
Version: 4.4.4.2
Build ID: 323549d66ffd3888c6a5058f7f6c9f0a279e0d3f
Locale: en.UTF-8

MacBook Pro
  Model Identifier:	MacBookPro11,3
  Processor Name:	Intel Core i7
  Processor Speed:	2.5 GHz
  Number of Processors:	1
  Total Number of Cores:	4
  L2 Cache (per Core):	256 KB
  L3 Cache:	6 MB
  Memory:	16 GB
  Boot ROM Version:	MBP112.0138.B14
  SMC Version (system):	2.19f12

System Version:	OS X 10.10.3 (14D136)
  Kernel Version:	Darwin 14.3.0
  Boot Volume:	Macintosh HD
  Boot Mode:	Normal

EPSON WF-4630 Series:
  Status:	Idle
  Print Server:	Local
  Driver Version:	2.0
  Default:	Yes
  System Printer Sharing:	No
  Shared:	No
  URI:	dnssd://EPSON%20WF-4630%20Series._ipps._tcp.local./ipp/print?uuid=cfe92100-67c4-11d4-a45f-ac18262b1f85
  PPD:	EPSON WF-4630 Series-AirPrint
  PPD File Version:	2.0
  PostScript Version:	(3010.000) 0
  CUPS Version:	2.0.0 (cups-408.2)
  Scanning support:	Yes
  Scanning app (bundleID path):	-
  Scanning app version:	-
  Scanner UUID:	53435759-0313-3297-0000-000000000000
  Printer Commands:	none 
  CUPS filters:
  image/urf:	processed in printer
  image/jpeg:	processed in printer
  Fax support:	No
  PDEs:
Comment 1 steve -_- 2015-06-25 10:03:11 UTC
Hi, are you able to reproduce this problem with the latest nightly as well?
http://dev-builds.libreoffice.org/daily/master/MacOSX-x86_64@49-TDF/
Comment 2 MJHauan 2015-06-25 19:10:14 UTC
Yes.  I just installed

Version: 5.1.0.0.alpha1+
Build ID: 0e2db2dd3413d760afaa4cfab4c7c224222b949a
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2015-06-25_06:30:25
Locale: en-US (en.UTF-8)

and on attempting to print, the same behavior occurs.
Comment 3 Alex Thurgood 2015-06-26 09:16:45 UTC
@MJHauan :

I can not confirm on either stock TDF LO 4432 or 

Version: 5.1.0.0.alpha1+
Build ID: cbe60f979590615f61d914f1c937c69e89c58880
Locale : fr-FR (fr.UTF-8)

OSX 10.10.3

What doe syour document contain ? It would be more helpful if you could provide a minimalist sample document where the problem is present so that we can test.

Setting to NEEDINFO, pending requested information / document.

Please set back to UNCONFIRMED when you have provided the requested information.
Comment 4 MJHauan 2015-06-27 01:24:39 UTC
Start the program.  Create a new Writer, Calc, or whatever document.  Add some random characters.  Then print.  The following print dialog shows two conflicting images -- one (on the left) with the print running top to bottom as if in landscape aspect, the other appearing apparently normal in portrait aspect.  On actual printing, the landscape version shows up on the paper.
Comment 5 Alex Thurgood 2015-06-27 09:13:53 UTC
(In reply to MJHauan from comment #4)
> Start the program.  Create a new Writer, Calc, or whatever document.  Add
> some random characters.  Then print.  The following print dialog shows two
> conflicting images -- one (on the left) with the print running top to bottom
> as if in landscape aspect, the other appearing apparently normal in portrait
> aspect.  On actual printing, the landscape version shows up on the paper.

This is exactly what I did, on stock TDF LibreOffice and I don't have a problem printing, or even in the printing preview in the CUPS dialogue. This would lead me to believe that the problem is specific to the version provided in the AppStore, or else a configuration problem.

Have you tried deleting your LO user profile (without LO running) and then retrying ?
Comment 6 Mark Judman 2015-06-29 14:10:58 UTC
I've had the same problem, using the new LO Vanilla ( v 4.4.4.2) Writer doc on Mac OS X  10.10.3, but not the older (non-Vanilla v 4.3.7.2).  Moving the .../Application Support/LibreOffice folder had no effect on the problem.  Format > Page shows the orientation as Portrait.
Comment 7 Mark Judman 2015-07-12 20:30:55 UTC
Using the new LibreOffice Vanilla v. 4.4.4.4 version newly created text and spreadsheet documents are forced to print in landscape, even though Print Preview shows portrait.  Interestingly pre-existing .odt and .ods documents print correctly in portrait.
Comment 8 Alex Thurgood 2015-09-11 05:52:41 UTC
*** Bug 94093 has been marked as a duplicate of this bug. ***
Comment 9 a2jc4life@gmail.com 2015-09-28 03:54:33 UTC
I am having the same problem.  LibreOffice for Windows, with the same printer, works fine.

Got a new Mac, installed LibreOffice, and it prints in landscape; however, does not reconfigure the page, just rotates it 90 degrees (which also cuts off the bottom).  Result is the same whether I print to the printer or print to PDF.

Every other program on my computer prints fine; only LibreOffice has an issue.
Comment 10 Andras Timar 2015-10-05 13:25:30 UTC
(In reply to a2jc4life@gmail.com from comment #9)
> Got a new Mac, installed LibreOffice, 

Did you install LibreOffice Vanilla from the App Store, or normal Libreoffice from TDF?
Comment 11 Alex Thurgood 2015-11-02 10:26:20 UTC
*** Bug 95453 has been marked as a duplicate of this bug. ***
Comment 12 PJ Houser 2015-11-26 22:28:31 UTC
I was using LibreOffice 4.4.2, and had the same problem - it printed landscape when I told it portrait. 

I uninstalled Libre and deleted the Library file (possibly unnecessarily), and then I installed LibreOffice 5.0.3 for Mac OS X x86_64 on my computer with OS Yosemite. The problem is currently fixed for me - it prints portrait when I say portrait.
Comment 13 Alex Thurgood 2015-12-10 15:05:35 UTC
*** Bug 96388 has been marked as a duplicate of this bug. ***
Comment 14 Andras Timar 2016-12-05 07:42:25 UTC
Workaround 1: export to PDF, and print PDF. 

Workaround 2: printing works, if you reduce the page size a little bit, e.g. to 8.49" or 10.99".
Comment 15 Telesto 2017-08-08 07:29:56 UTC
*** Bug 110460 has been marked as a duplicate of this bug. ***
Comment 16 shannon 2017-08-11 22:09:13 UTC
I can confirm the bug. My installation is LibreOffice 5.4.0.3 running on macOS 10.12.6
Comment 17 shannon 2017-08-15 05:07:13 UTC
(In reply to shannon from comment #16)
> I can confirm the bug. My installation is LibreOffice 5.4.0.3 running on
> macOS 10.12.6

Bug occurs both in Writer and Calc.
Comment 18 bunkem 2017-08-15 21:13:32 UTC
I can confirm that the problem exists in LO 5.4.0.3 on OSX 10.10.5 too.

Workarounds:
1) You can export to PDF. This will produce a PDF in portrait that can be printed correctly.

or

2) You can change the dimensions in the portrait page in the Format:Page:Page:Paper Format.  I use 8.49" x 10.99" and the print job stays portrait.

Note to the bug hunters.  This problem exists (existed) on the Windows platform a while back.  There is another bug listed for windows.

Please fix as this is frustrating and increasing time in my workflows.

Thanks in advance.
Comment 19 bunkem 2017-08-15 21:14:55 UTC
Oh my.  I see the work arounds have already been posted at comment 14.

Apologies for the duplicate.
Comment 20 Buovjaga 2017-08-16 05:37:04 UTC
(In reply to bunkem from comment #18)
> Note to the bug hunters.  This problem exists (existed) on the Windows
> platform a while back.  There is another bug listed for windows.

Can you point to this bug? Thanks.
Comment 21 bunkem 2017-08-16 12:13:05 UTC
Sorry I forgot to save the link.  

But a Google finds this problem comes and goes from version to version on all platforms.  

It appears the workarounds work for all platforms.  

An additional work around is to remove the user folder from the Library/Application/Support.  

I just tested this work around and it fixed the issue.  So it would tend to indicate that there is a preference setting, maybe this "paper size from printer" that is screwing things up??

More fodder for the mill:
Present release but platform unspecified:
https://ask.libreoffice.org/en/question/121393/libreoffice-540-writer-portrait-document-prints-as-landscape/

Mac issue again:
https://bugs.documentfoundation.org/show_bug.cgi?id=35132
Numerous times on Mac if you do a search.

On Linux (older versions):
https://bugzilla.redhat.com/show_bug.cgi?id=740496
https://bugs.documentfoundation.org/show_bug.cgi?id=52308
https://bugs.documentfoundation.org/show_bug.cgi?id=44664

On Windows/similar but not exactly the same issue on older version:
https://ask.libreoffice.org/en/question/49518/printing-a-landscape-portrait-writer-document-that-doesnt-switch-back-to-portrait/
https://bugs.documentfoundation.org/show_bug.cgi?id=85094
Comment 22 T.L. 2017-08-18 05:20:07 UTC
This issue seems to have spontaneously arisen for us with LO 5.3.5.2 (TDF download) on MacOS X 10.11.6. I don't think it occurred in conjunction with an app update.
Trashing the /Library/Application Support/LibreOffice had no improvement.

Using the workaround of:  Format -> Page -> Page: Paper Format, Width: 8.52"

The issue seems to affect printing of most (but not all) existing Writer documents.
Comment 23 Wes 2017-08-19 04:07:40 UTC
I can confirm that this still happens on 10.12.6, LO:

Version: 5.4.0.3
Build ID: 7556cbc6811c9d992f4064ab9287069087d7f62c
CPU threads: 8; OS: Mac OS X 10.12.6; UI render: default; 
Locale: en-US (en_US.UTF-8); Calc: group

And that both the workarounds (PDF and reducing the margins by 1/100) work.

This was fine on the 5.3 series I was using a few hours ago.

Using a Brother MFC-L2700DW.
Comment 24 ambimom 2017-08-31 14:17:27 UTC
I have MacOS Sierra...brand new computer.  Canon MG5420.  LibreOffice 5.3.6 only prints landscape.  Print preview in Libre is correct but printer only prints landscape.  No way to change to portrait.
Comment 25 bunkem 2017-08-31 18:07:07 UTC
@ambimom

Did you try either of the workarounds?

ie.
1) print/export to PDF then print using Preview or Acrobat
2) change the portrait page size by adding/subracting 0.01" in to the legal size width
Comment 26 nealt 2017-09-01 00:57:11 UTC
Yes the 10.9 fix works but it is a pain. Besides Print orientation should work properly.
Comment 27 nealt 2017-09-01 00:57:35 UTC Comment hidden (obsolete)
Comment 28 nealt 2017-09-01 00:57:49 UTC Comment hidden (obsolete)
Comment 29 nealt 2017-09-01 00:58:01 UTC Comment hidden (obsolete)
Comment 30 bunkem 2017-09-01 01:23:43 UTC
(In reply to nealt from comment #26)
> Yes the 10.9 fix works but it is a pain. Besides Print orientation should
> work properly.

I think everyone agrees.  They appear to be having problems figuring it out.
Comment 31 vince.medlock 2017-09-02 03:39:17 UTC
I can also confirm having this issue today with LO 5.4.1.2 on MacOS 10.11.6 El Capitan.  It appears to be fixed by changing the "More" settings to "Back Side" then "Front Side."  This seems to force a re-draw of the dialog box (and possibly sends the document to the printing system again?).  I don't have a printer connected at the moment, so I can't confirm that it actually prints as expected.
Comment 32 Alex Thurgood 2017-09-05 08:08:31 UTC
*** Bug 112200 has been marked as a duplicate of this bug. ***
Comment 33 Alex Thurgood 2017-09-05 08:09:33 UTC
Removing whiteboard tag as problem occurs also in stock LibreOffice release
Comment 34 vince.medlock 2017-09-05 14:29:54 UTC
I can now confirm that running through all the page orientations on the printer dialog does force the document to print in portrait mode.  This is a fairly massive inconvenience, obviously.  When can we expect a fix?

Details:
LibreOffice:
Version: 5.4.1.2
Build ID: ea7cb86e6eeb2bf3a5af73a8f7777ac570321527
CPU threads: 2
OS: Mac OS X 10.11.6
UI render: default
Locale: en-US (en.UTF-8)
Calc: group

Computer:
  Model Name:	MacBook
  Model Identifier:	MacBook5,1
  Processor Name:	Intel Core 2 Duo
  Processor Speed:	2 GHz
  Number of Processors:	1
  Total Number of Cores:	2
  L2 Cache:	3 MB
  Memory:	8 GB
  Bus Speed:	1.07 GHz
  Boot ROM Version:	MB51.007D.B03
  SMC Version (system):	1.40f2

  System Version:	OS X 10.11.6 (15G1611)
  Kernel Version:	Darwin 15.6.0
  Boot Mode:	Normal
  Secure Virtual Memory:	Enabled
  System Integrity Protection:	Disabled
Comment 35 Alex Thurgood 2017-09-05 15:32:35 UTC
*** Bug 112234 has been marked as a duplicate of this bug. ***
Comment 36 Yvan Rose 2017-09-05 17:23:26 UTC
Just FYI (if it's important): The earliest affected version was 5.3. I am using version 5.2.7 at the moment (not upgrading because of this bug) and everything is OK there, as it was in all the prior versions I used.
Comment 37 haim kilov 2017-09-12 00:47:24 UTC
This is a very unpleasant bug. Creating a PDF file and printing it works for me, though.
LO 5.4.1.2, Mac OS 10.9.
Comment 38 Telesto 2017-09-12 06:32:32 UTC
*** Bug 112339 has been marked as a duplicate of this bug. ***
Comment 39 Telesto 2017-09-12 06:38:10 UTC
*** Bug 111445 has been marked as a duplicate of this bug. ***
Comment 40 Telesto 2017-09-12 06:38:17 UTC
*** Bug 110461 has been marked as a duplicate of this bug. ***
Comment 41 Telesto 2017-09-12 06:38:29 UTC
*** Bug 107898 has been marked as a duplicate of this bug. ***
Comment 42 Alex Thurgood 2017-09-13 08:36:45 UTC
*** Bug 112361 has been marked as a duplicate of this bug. ***
Comment 43 Xisco Faulí 2017-09-17 09:56:04 UTC
*** Bug 112432 has been marked as a duplicate of this bug. ***
Comment 44 cecinestpasmoi 2017-09-17 16:28:32 UTC
Found a walkaround: only happens with letter size. If change to user format by .3 mm it doesn't do it, and it doesn't do it with any other format (ex:A4.) So changed default template to a user one just less than 1 mm different from letter size and the bug doesn't happen.
Comment 45 cecinestpasmoi 2017-09-17 16:33:31 UTC
(In reply to T.L. from comment #22)
> This issue seems to have spontaneously arisen for us with LO 5.3.5.2 (TDF
> download) on MacOS X 10.11.6. I don't think it occurred in conjunction with
> an app update.
> Trashing the /Library/Application Support/LibreOffice had no improvement.
> 
> Using the workaround of:  Format -> Page -> Page: Paper Format, Width: 8.52"
> 
> The issue seems to affect printing of most (but not all) existing Writer
> documents.


It did the same for me: it happened only after update from 5.2 to 5.3.6
Comment 46 ambimom 2017-09-21 13:25:53 UTC
This is also true versions LO3.6.5; 5.3.6; 5.4.  Recently switched to MacOS Sierra which will not load Java runtime.  Prints only landscape.  Funnily enough Open Office for Mac will print portrait though basically the same program.  

On a related matter Base doesn't work at all.  I'll file another bug on that one.
Comment 47 boukman 2017-09-23 13:37:11 UTC
For what it's worth, on my Mac OS X 10.8.5 system, LO version 5.3.4.2 prints fine, whereas versions 5.3.5.1 and 5.3.6.1 exhibit the print in landscape bug.

This bug happened before and was fixed.  As far as I'm concerned, it was somehow reintroduced in 5.3.5.1.
Comment 48 Jaymesslade 2017-09-25 09:01:54 UTC
It is printing portrait and sideways for me two…. and cutting off pertinent info….

Quite annoying on my MacBook Pro…

As of right now I can't trust Libre Office.
Comment 49 Alex Thurgood 2017-09-26 06:55:52 UTC
*** Bug 112600 has been marked as a duplicate of this bug. ***
Comment 50 Rally de Leon 2017-10-04 00:22:50 UTC
For LO 5.4.1.2 on my macOS 10.12.6 and osx10.10, 
I've experienced the same bug with "Letter size (8.5"x11") on Portrait Mode". 
Did not have that issue using Long Bond (8.5"x13") on Portrait mode.

For LO 5.3.4.2 on macOS 10.12.6, osx10.10 and Windows10, 
no issue with 'letter size on portrait mode but printed on landscape.'

It seems that said bug affects only "Letter size" on LO 5.4.x on macOS Sierra & Yosemite (as tested). 

Windows' LibreOffice versions seems ok.
Comment 51 haim kilov 2017-10-04 01:15:34 UTC
It affects Mac 10.9.5 Mavericks as well (LO 5.4.1.2). Changing the pagesize (even a little bit) helps, but this is hardly a good bugfix.
Comment 52 Ovid S 2017-10-04 04:53:13 UTC
Created attachment 136748 [details]
Screenshot of LO print dialog

LO 5.3.6.1 on macOS High Sierra 10.13 (17A365)

Checking and the unchecking the "Brochure" option causes the orientation to revert back to the [proper] portrait mode.

Once the preview shows the document in portrait mode, it will also print correctly.

This behavior is repeatable, and provides a relatively painless crutch.

Hopefully, this observation is of some help to the LO team.

Warm regards,
Comment 53 James 2017-10-05 18:07:42 UTC
Hello there. I'm using LibreOffice Version: 5.4.1.2 on a Mac running macOS 10.13 and am having trouble in Writer with text in a document showing up as sideways when attempting to print to numerous printers.

Changing the page to landscape just changes the page border not the text oreientation. Any ideas? Nothing in the printer settings effects the orientation of the printed text to get it back to normal.

This happens with a newly created Writer doc as well.

----

I have tried the change the doc size to a bit smaller and it works but having to do this to every document in our workflow is a deal breaker. Hoping it is fixed soon. Best of luck.
Comment 54 James 2017-10-05 18:59:28 UTC
Same issue as above not showing up in OpenOffice 4.1.3 fyi.
Comment 55 cecinestpasmoi 2017-10-05 21:46:58 UTC
Realized that the bug doesn't happen when you open a document that was created before the update, even if you modify and save the document. Is it an issue about the template for letter size?
Comment 56 Geoffrey Wagner 2017-10-05 21:49:39 UTC
Re #55.  That's not the case for me.  Older documents are still susceptible to this bug for me.
Comment 57 Mike Kaganski 2017-10-06 05:56:44 UTC
Another workaround was mentioned on AskLibO (https://ask.libreoffice.org/en/question/76753; cannot test it myself; posting it here in hope that it will both help someone workaround, and also help devs finding the issue):

> 1. Call up the print dialog for a "Letter" text document by the usual method, namely "File" -> "Print" 
> 2. If necessary, select the menu item "LibreOffice" (other choices in this menu include "Layout", etc.) 
> 3. Two tabs will be visible now: namely "LibreOffice Writer" and "More"; select the tab "More" 
> 4. Now a menu will be visible, whose choices include "All Pages".
> 5. (Here's the "magic") select ANY menu item OTHER than "All Pages" ... then reselect "All Pages".
> 
> The net effect SHOULD be nil ... but instead, this sequence will trigger a refresh of the entire dialog box ...
> and the refreshed box will display a now-correct "Portrait" mode.
Comment 58 Alex Thurgood 2017-10-06 09:35:35 UTC
*** Bug 112899 has been marked as a duplicate of this bug. ***
Comment 59 Alex Thurgood 2017-10-06 09:36:51 UTC
Increasing importance given large number of duplicates
Comment 60 Jim Erwin 2017-10-07 17:07:25 UTC
I agree with this screenshot. I see the same thing. I am using Macbook Pro OS High Sierra with an HP LaserJet M1217nfw MFP. Only happened with tne new updated LibreOffice. Previous editions of LibreOffice did not have this bug.
Comment 61 Mike Kaganski 2017-10-07 19:56:57 UTC
(In reply to Jim Erwin from comment #60)
> I agree with this screenshot. ... Only happened with tne new
> updated LibreOffice. Previous editions of LibreOffice did not have this bug.

Interesting, what do people think about, when they take a bug filed by someone having the problem in 2015, and hijack it asserting that it only started recently?

If you feel that there's a problem that wasn't there in a previous release, than it must be a new problem, and should be tracked in a new issue #. However, most probably, it is some specific property of your system that prevented this bug from appearing in previous versions; if the symptoms and workarounds match your experience, then just assume it's the same, but don't change fields to a version that you guess.
Comment 62 Al Maloney 2017-10-09 16:19:38 UTC
(In reply to Mike Kaganski from comment #61)
> (In reply to Jim Erwin from comment #60)
> > I agree with this screenshot. ... Only happened with tne new
> > updated LibreOffice. Previous editions of LibreOffice did not have this bug.
> 
> Interesting, what do people think about, when they take a bug filed by
> someone having the problem in 2015, and hijack it asserting that it only
> started recently?
> 
> If you feel that there's a problem that wasn't there in a previous release,
> than it must be a new problem, and should be tracked in a new issue #.
> However, most probably, it is some specific property of your system that
> prevented this bug from appearing in previous versions; if the symptoms and
> workarounds match your experience, then just assume it's the same, but don't
> change fields to a version that you guess.

Mike
see my report Bug 86838 of 2014.11.29
The persistence of this bug is disconcerting to those of us who are forced to use the US Letter size.
1) Is anyone trying to solve the problem?
2) What can I, a non-programmer, do to help at this point?
Comment 63 Telesto 2017-10-09 18:05:20 UTC
(In reply to Mike Kaganski from comment #61)
I will split this bug in two. I'm moving the printer issues after LibO 5.3.4.2 to bug 110460. There is probably a regression between LibO 5.3.4.2 and 5.3.5.1.
Comment 64 bunkem 2017-10-09 18:51:40 UTC
(In reply to Telesto from comment #63)
> (In reply to Mike Kaganski from comment #61)
> I will split this bug in two. I'm moving the printer issues after LibO
> 5.3.4.2 to bug 110460. There is probably a regression between LibO 5.3.4.2
> and 5.3.5.1.

Telesto,
I'm sorry but I don't understand why you are splitting this bug report.  

This bug ("PRINTs landscape despite configured as portrait (Mac OS)") is about an ongoing print issue with the Mac version of LO.  Bug 110460 is entitled "Print Bug" which is essentially the same thing.  The description sounds the same.

Could you explain why a bit better?  If we're dealing with 2 bugs then I would understand but on the surface it looks like the same issue.

It would be a shame to split the effort on a bug that should be tackled and fixed asap.
Comment 65 landi 2017-10-16 18:27:55 UTC Comment hidden (me-too)
Comment 66 landi 2017-10-16 21:51:17 UTC Comment hidden (me-too)
Comment 67 Jacob 2017-10-17 17:37:57 UTC Comment hidden (me-too)
Comment 68 rayseto 2017-10-24 19:34:11 UTC
I am using version 5.4.2.2 and this bug is still present when printing Letter-sized documents in Portrait mode.  Will this be fixed?  Thanks for the workaround in the meantime.  :)
Comment 69 Alfred Ayache 2017-10-26 22:15:30 UTC
With the workaround where you slightly resize the page, it won't print double-sided. This is on macOS Sierra (10.12.6), LO 5.3.6.1, and Brother HL-2270DW, using Calc.

Please, please, please, someone look into this and fix it.

Thanks for all you do.
Comment 70 Alfred Ayache 2017-10-26 22:26:49 UTC
Reverted to LO 5.2.7, and landscape issue has gone away, but still not printing double-sided in Calc.
Comment 71 Geoffrey Wagner 2017-10-26 22:52:55 UTC
I'm using 5.3.4.2 because of this print issue.  I'm able to duplex print from Calc.
Comment 72 Mike Kaganski 2017-10-28 08:47:27 UTC
Based on workarounds available, it looks like the Letter is the default (maybe on macOS). And if the (un)configured size is equal to default, then some "refresh" isn't performed in macOS printing code.

Posted this in hope that this would encourage people with macOS to look into the code and find a relatively easy hack.
Comment 73 Jon R Kibler 2017-11-06 08:48:15 UTC
Experimenting, a few additional details I hope clarify the issue:

1) The issue appears strictly related to the U.S. Letter (8.5 x 11 inches) paper size. All other sizes print properly.

2) The issue only occurs on new documents.

3) Both physically printing U.S. Letter size document or any PDF operation from the MacOS print menu create landscape orientation; bug is printer independent.

4) Taking an existing document (pre-bug) and using it as the template to create a new document works properly.

5) Changing paper size from U.S. Letter to anything else works, but changing it back to U.S. Letter reverts to landscape orientation.

6) Formatting page as landscape, prints properly. Changing format back to portrait again resumes landscape orientation for printing.

7) Changing any single page dimension (width or height) in Format Page by 0.01 fixes the problem. That is, 8.49x11.00, 8.50x11.01, 8.51x11.00, and 8.50x11.01 all print in the correct orientation.

8) Print preview always shows correct orientation.

9) Changing preferences to not load printer settings with document has no effect on problem.
Comment 74 j-beda 2017-11-06 16:12:02 UTC
I have a client who is seeing this issue, but I couldn't recreate it using Mac OS X 10.12.6 on my work machine until I realized I was using an older version:

not present in Libreoffice Version: 5.2.6.2
Build ID: a3100ed2409ebf1c212f5048fbe377c281438fdc
CPU Threads: 4; OS Version: Mac OS X 10.12.6; UI Render: default; 
Locale: en-CA (en_CA.UTF-8); Calc: group

present in Version: 5.4.2.2
Build ID: 22b09f6418e8c2d508a9eaf86b2399209b0990f4
CPU threads: 4; OS: Mac OS X 10.12.6; UI render: default; 
Locale: en-CA (en_CA.UTF-8); Calc: group

present in Version: 5.3.7.2
Build ID: 6b8ed514a9f8b44d37a1b96673cbbdd077e24059
CPU Threads: 4; OS Version: Mac OS X 10.12.6; UI Render: default; Layout Engine: new; 
Locale: en-CA (en_CA.UTF-8); Calc: group

Old odt files (like from years ago) seem to print fine in all verstions, and all files in 5.2.6.2 print fine, but a new file created in 5.2.6.2 when opened in 5.4.2.2 or 5.3.7.2 prints only in landscape. Any new files created by 5.4.2.2 or 5.3.7.2 prints only in landscape.
Comment 75 Mike Kaganski 2017-11-09 05:29:27 UTC
*** Bug 113728 has been marked as a duplicate of this bug. ***
Comment 76 Telesto 2017-11-09 16:07:30 UTC
@Mike
The issue started after LibO 5.3.4.2 with the release builds. However, I'm noticing the same issue in my own LODE LibO 5.3.4.2 build.

The issue is resolved by removing the "+ 0.5" from https://opengrok.libreoffice.org/xref/core/i18nutil/source/utility/paper.cxx#55

or defining the page size in MM instead of of INCH in 
https://opengrok.libreoffice.org/xref/core/i18nutil/source/utility/paper.cxx#74

So instead of IN2MM100( 8.5 ), IN2MM100( 11 ) -->  MM2MM100 (215.9) MM2MM100 ( 279.4 )
Comment 77 Paul Hubert 2017-11-10 02:20:00 UTC Comment hidden (no-value)
Comment 78 Mike Kaganski 2017-11-10 05:45:46 UTC
(In reply to Telesto from comment #76)

Unfortunately both your proposals are based on tricking LO to believe that its Letter size is different from some other size in process of checking for necessary adjustments. This kind of fix would mask this for Letter to bite again in a different place. The proper fix would be finding the faulty code, and fix it to do necessary adjustments when they need to be done. But I don't own a Mac, so I cannot work on this.
Comment 79 Paul Hubert 2017-11-10 06:19:25 UTC Comment hidden (no-value)
Comment 80 Mike Kaganski 2017-11-10 06:26:04 UTC
(In reply to Paul Hubert from comment #79)

Please din't spam the issue by irrelevant comments. Especially if you don't understand the comment you reply to. Comment 76 was proposing *changes in code*, which didn't introduce *any* change in inch support in software, just did a small changes in in-built predefined size (so that subsequent code would detect it and choose a different code path). It's not a correct approach, but not because of what you think about it.
Comment 81 Mike Kaganski 2017-11-10 06:29:05 UTC
... and BTW, comment 76 might be of value as a tool for one who would work on this further and compare following program's code flow.
Comment 82 Tor Lillqvist 2017-11-10 09:49:08 UTC
Telesto, you seem to be based in the Netherlands? Are you sure you can reproduce the problem (and verify your simple fix, that of removing the +0.5 from the IN2MM100 macro), your printer presumably does not use Letter paper, right?

Also, could you attach the patch to avoid confusion what it exactly looks like?

Anyway, as far as I see, for Letter size (8.5 in x 11 in), both the current version of IN2MM100 and one without the +0.5 produce exactly the same number of hundredths of millimetres for width and height:

IN2MM100(8.5)=21590, IN2MM100UNROUNDED(8.5)=21590
IN2MM100(11)=27940, IN2MM100UNROUNDED(11)=27940

or is the SAL_DEBUG not showing some very small difference in floating-point values here?

that is with
+#define IN2MM100UNROUNDED( v ) \
+    ((long)(((v) * 2540)))
+
Comment 83 Tor Lillqvist 2017-11-10 11:24:47 UTC
For what is't worth, the same (?) symptom has been reported in 2013 for OpenOffice.org 3.3.0 on Mac OSX 10.8.2... https://forum.openoffice.org/en/forum/viewtopic.php?t=58499

Could be another bug with the same symptom, of course.
Comment 84 Tor Lillqvist 2017-11-10 13:34:09 UTC
Has anybody in "ISO Land" (where printers use A4 paper) been able to reproduce this? Is there a way to set up some virtual or fake printer on macOS that would seem to LO as a real honest-to-god printer that indeed uses Letter paper? And then check what would get printed to it? Is it so that it is the printer vendor specific software ("driver") that does the rotation that this bug report is about? What brands and models of printers do people who can reproduce this bug have? (Personally I have a HP 1010 laser, which isn't even attached directly to my development Mac, but another Mac.)
Comment 85 landi 2017-11-10 14:09:00 UTC
As far as I can tell, this is printer-independent. I've used multiple printers. I'm in the U.S. and use letter-size. I'm never directly connected to a printer; it's always through a LAN or wireless. Laser, inkjet, copy machine -- they all have the same issue. I'm not a programmer, but I don't think the printer driver is the issue.
Comment 86 Jacob 2017-11-10 14:30:48 UTC
This issue is printer-independent. When you open the print dialog there is a thumbnail print preview that shows the page printing landscape instead of portrait.

This preview does not change as you flip through available printers. It will even output the page landscape if you choose to save as a PDF from the print dialog box.
Comment 87 bunkem 2017-11-13 19:09:23 UTC
The issue is still present in LO 5.4.3.2 on OSX 10.11.6.
Comment 88 Buovjaga 2017-11-16 13:38:43 UTC
*** Bug 113870 has been marked as a duplicate of this bug. ***
Comment 89 Frank Griswold 2017-11-20 00:09:04 UTC
> Is it so that it
> is the printer vendor specific software ("driver") that does the rotation
> that this bug report is about?

It is independent of the printer (for my Brother and two Canon printers). One sometimes hack here:
https://ask.libreoffice.org/en/question/58177/libreoffice-5-for-mac-will-only-print-landscape-please-help/?answer=136599#post-id-136599
Nearby (comment to the main question) is this hack:
convert letter size to user-format (8.5" x 10.99") or (8.49"x11"), which don't have noticeable effect on the margins.
Comment 90 Mike Kaganski 2017-11-21 06:26:23 UTC
*** Bug 113963 has been marked as a duplicate of this bug. ***
Comment 91 Telesto 2017-11-21 15:28:27 UTC
Is there a volunteer to check if the issue also exists in LibreOffice 6 daily.. 
http://dev-builds.libreoffice.org/daily/master/MacOSX-x86_64@49-TDF/current/
Comment 92 landi 2017-11-21 16:06:52 UTC
I downloaded and installed 6.0 alpha and tested. I don't see the bug present in this version. I tried both Writer and Calc documents, printing to different network printers and it worked correctly. From this limited test, it appears the bug is fixed.

Version: 6.0.0.0.alpha1+
Build ID: 7c1577ae16cd7ae402d1f61d831232c783bb9df6
CPU threads: 8; OS: Mac OS X 10.13.1; UI render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2017-11-21_11:55:00
Locale: en-US (en_US.UTF-8); Calc: group threaded

Macbook Pro mid-2014
High Sierra 10.13.1
Old HP Laserjet printer
Fancy Ricoh network copier/printer
Comment 93 Jacob 2017-11-21 16:16:10 UTC
I just downloaded the dev version 6 to test. I am no longer seeing the issue in this version. I am on OSX 10.10.5


Version: 6.0.0.0.alpha1+
Build ID: 7c1577ae16cd7ae402d1f61d831232c783bb9df6
CPU threads: 4; OS: Mac OS X 10.10.5; UI render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2017-11-21_11:55:00
Locale: en-US (en.UTF-8); Calc: group threaded
Comment 94 Telesto 2017-11-21 16:22:55 UTC
(In reply to Jacob from comment #93)
> I just downloaded the dev version 6 to test. I am no longer seeing the issue
> in this version. I am on OSX 10.10.5

@Tor
A backport to 5.4 would be nice :-)
Comment 95 Tor Lillqvist 2017-11-21 16:27:56 UTC
Already done as 9f8429d81c08cc40d5b1210cb6e4b383316cdc75 .
Comment 96 bunkem 2017-11-21 16:30:43 UTC
I've also downloaded 6.0 dev to test.

I'm on OSX 10.11.6

I tested on existing documents that have the problem and see that the preview is now correct.  Test printing looks OK too.

It looks like the bug is gone.

Thanks!
Comment 97 Telesto 2017-11-21 18:26:16 UTC
*** Bug 110461 has been marked as a duplicate of this bug. ***
Comment 99 Telesto 2017-11-25 07:43:03 UTC
*** Bug 114037 has been marked as a duplicate of this bug. ***
Comment 100 V Stuart Foote 2017-11-26 03:11:35 UTC
*** Bug 114054 has been marked as a duplicate of this bug. ***
Comment 101 V Stuart Foote 2017-11-26 03:27:10 UTC
*** Bug 114053 has been marked as a duplicate of this bug. ***
Comment 102 Mike Kaganski 2017-11-30 21:21:19 UTC
*** Bug 114186 has been marked as a duplicate of this bug. ***
Comment 103 Aron Budea 2017-12-06 21:40:01 UTC
*** Bug 114294 has been marked as a duplicate of this bug. ***
Comment 104 Telesto 2017-12-07 07:53:52 UTC
*** Bug 114298 has been marked as a duplicate of this bug. ***
Comment 105 Timur 2017-12-08 07:28:57 UTC
*** Bug 112899 has been marked as a duplicate of this bug. ***
Comment 106 Timur 2017-12-08 07:33:17 UTC
Is this related to Bug 98114?
Comment 107 Tor Lillqvist 2017-12-08 08:50:03 UTC
The change that apparently fixed this bug is for one line of Mac-specific code. It can have no impact on Linux. So if that other bug really is the same bug that affects both Linux and Mac, then no, this can not be related.
Comment 108 Timur 2017-12-27 17:09:58 UTC
*** Bug 114707 has been marked as a duplicate of this bug. ***
Comment 109 DS 2017-12-28 06:47:54 UTC Comment hidden (no-value)
Comment 110 Mike Kaganski 2017-12-28 07:31:20 UTC Comment hidden (no-value)
Comment 111 DS 2017-12-28 22:05:01 UTC
Please forgive me. I saw that it was reported as fixed, but for some reason thought that my version was higher than 5.4.4 but still broken. Extreme apologies! Thank you very much for resolving this. It is greatly appreciated.
Comment 112 Telesto 2018-01-15 19:14:20 UTC
*** Bug 115028 has been marked as a duplicate of this bug. ***
Comment 113 Timur 2018-01-19 18:42:08 UTC
*** Bug 115115 has been marked as a duplicate of this bug. ***