Bug Hunting Session
Bug 92199 - Crash: when Macro Dialogs Edit
Summary: Crash: when Macro Dialogs Edit
Status: RESOLVED DUPLICATE of bug 95021
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
5.0.0.0.beta3
Hardware: Other All
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-20 06:32 UTC by Shinji Enoki
Modified: 2015-11-16 15:28 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
macros dialogs (169.66 KB, image/png)
2015-06-20 06:32 UTC, Shinji Enoki
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Shinji Enoki 2015-06-20 06:32:51 UTC
Created attachment 116670 [details]
macros dialogs

Calc clash when edit Macros Dialogs in Basic Macro Organizer.

Steps to reproduce
1. Start Calc
2. Selest menu Tools > Macros > Organize Dialogs
3. Click "New" button and Click "OK"
4. Click "Edit" button
Clash Calc.

Env.
OS: Debian wheezy
Version: 5.0.0.0.beta3
Build ID: 96345c15d8ab19c49014f055fe41ba8e1f421e5c
Locale: en-US (ja_JP.utf8)
Comment 1 Masataka KONDO 2015-06-20 06:46:34 UTC
I've reproduced this crashing with multiple environments.
- Windows 32bit
- Mac OS X (64bit)
- Linux 64bit (Linux Mint 17.1/MATE)
Comment 2 Marek Dolezel 2015-07-30 22:30:21 UTC
No crash on F22, will have a look at it tomorrow

Version: 4.4.4.3
Build ID: 4.4.4.3-6.fc22
Locale: en_GB.utf8
Comment 3 Marek Dolezel 2015-07-31 12:28:32 UTC
No repro on 
Version: 5.1.0.0.alpha1+
Build ID: f4bdd7989f237e8e90ac94c2798e0ea0fb31af6b
Locale: en-GB (en_GB.utf8)

Fedora 22 Gnome 3
Comment 4 Björn Michaelsen 2015-10-13 11:43:44 UTC
Not reproducable in 50max repo tag latest, not reproducable with 5.0.2 distro release builds on Ubuntu 15.10 either.

Needs a more detailed reproduction scenario => NEEDINFO
Comment 5 baffclan 2015-10-18 02:44:58 UTC
Steps to Reproduce:
> 1. Start Calc
> 2. Selest menu Tools > Macros > Organize Dialogs
> 3. Click "New" button and Click "OK"
> 4. Click "Edit" button
5. appear "My Macros & Dialogs.Standard" dialog
6. click [X] in Title bar
7. appear Fatal Error dialog
   "SEH Exception: ACCESS VIOLATION"
8. click [OK] (Close LibO Window)
9. Restart LibO, appear "Document Recovery" Dialog


Reproduce on Windows 7 Pro:
Version: 5.0.3.1 (x64)
Build ID: fd8cfc22f7f58033351fcb8a83b92acbadb0749e
Locale: ja-JP (ja_JP)

Version: 5.1.0.0.alpha1+ (x64)
Build ID: 09fc6fef2d03ca8558dd6f0eec45d61ceb282cb5
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-09-27_22:33:48
Locale: ja-JP (ja_JP)
Comment 6 baffclan 2015-11-13 12:01:08 UTC
cannot reproduce with newest master.
Fixed by bug 95021?

Windows 7 Pro
Version: 5.1.0.0.alpha1+ (x64)
Build ID: 8c8dab48fc8bf1d8c3f0f5e5139323222a81406e
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-11-12_21:55:11
Locale: ja-JP (ja_JP)
Comment 7 Caolán McNamara 2015-11-16 15:28:01 UTC

*** This bug has been marked as a duplicate of bug 95021 ***