Bug 92242 - UI - StartCenter and Application windows can not be resized diagonally with mouse after initial window size increase and covers OSX Dock
Summary: UI - StartCenter and Application windows can not be resized diagonally with m...
Status: VERIFIED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
5.1.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium major
Assignee: andreas_k
URL:
Whiteboard: target:5.1.0 target:5.0.1
Keywords: notBibisectable, regression
: 104328 (view as bug list)
Depends on:
Blocks: Start-Center
  Show dependency treegraph
 
Reported: 2015-06-22 09:30 UTC by Alex Thurgood
Modified: 2017-06-27 12:42 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot StartCenter LO 5 RC1/RC2 (german) on OSX (111.51 KB, image/png)
2015-06-29 15:24 UTC, Sierk Bornemann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Thurgood 2015-06-22 09:30:20 UTC
As per bug 91971, the default StartCenter window no longer displays all of the document launch icons.

On OSX, if the user attempts to expand the window by dragging a corner with the mouse, the window autoexpands to a size that overlaps with the OSX Dock.

Additionally, this new window size can no longer be reduced by dragging with the mouse from the corner of the window, it can only be reduced in width from the side edge.

This is a regression over 4432.
Comment 1 Sierk Bornemann 2015-06-29 15:24:00 UTC
(In reply to Alex Thurgood from comment #0)
> As per bug 91971, the default StartCenter window no longer displays all of
> the document launch icons.

Issue still existant in 5.0.0.2 german on OSX 10.10.3.

Version: 5.0.0.2
Build-ID: a26d58f11b99b6aeddf7f7884effea188cc6e512
Gebietsschema: de-DE (de.UTF-8)

See attached screenshot.

> On OSX, if the user attempts to expand the window by dragging a corner with
> the mouse, the window autoexpands to a size that overlaps with the OSX Dock.

Cannot confirm this in my installation, works for me.
 
> Additionally, this new window size can no longer be reduced by dragging with
> the mouse from the corner of the window, it can only be reduced in width
> from the side edge.

Cannot confirm this in my installation, works for me.
Comment 2 Sierk Bornemann 2015-06-29 15:24:36 UTC
Created attachment 116930 [details]
Screenshot StartCenter LO 5 RC1/RC2 (german) on OSX
Comment 3 Alex Thurgood 2015-07-24 11:07:01 UTC
The problem of resizing the StartCenter window spreads to the other application windows, so, e.g. Calc window can not be resized diagonally, even if I make the Dock disappear. The only solution I have found to this is to delete the profile and restart LO.
Comment 4 Alex Thurgood 2015-07-24 11:14:48 UTC
How to reproduce:

1) Delete LOdev profile from /Users/myuser/Library/Application Support/

2) Start LOdev

3) Note how StartCenter does not display all launchers.

4) Put mouse cursor at bottom right hand corner of start center window, hover until the diagonal stretch icon is displayed, click and start to drag diagonally outwards and downwards.

5) The StartCenter window automatically expands the window to below the Dock.

There is no way to resize that window once that maximum position has been reached, other than shrinking the width - no diagonal shhrinkage is possible.
Comment 5 Maxim Monastirsky 2015-07-30 19:40:24 UTC
I highly suspect that it's related to the Breeze icon theme, because I'm able to reproduce similar behavior with it under Fedora 22 (64-bit). Would be great to hear from Mac users, whether the problem persists there after changing the icon theme, and restarting LO.
Comment 6 Alex Thurgood 2015-08-06 10:07:17 UTC
(In reply to Maxim Monastirsky from comment #5)
> I highly suspect that it's related to the Breeze icon theme, because I'm
> able to reproduce similar behavior with it under Fedora 22 (64-bit). Would
> be great to hear from Mac users, whether the problem persists there after
> changing the icon theme, and restarting LO.

Hi Maxim,

Confirming that switching to Galaxy icon theme allows for the windows to be resized.
Comment 7 Alex Thurgood 2015-08-14 13:03:29 UTC
It would appear that bug 93064 is a duplicate of this bug.
Comment 8 Alex Thurgood 2015-08-14 13:04:22 UTC
*** Bug 93064 has been marked as a duplicate of this bug. ***
Comment 9 andreas_k 2015-08-16 21:23:37 UTC
I changed the icon size to 32px as recommended. sorry that it took so long. don't go to vacation 3 times in a row.
Comment 10 andreas_k 2015-08-16 21:25:42 UTC
https://gerrit.libreoffice.org/#/c/17787/

now also the "meaning" of the mimetype symbols is the right one. for me it would be ok. I added remote-documents don't know the name of the new icon for 5.1.
Comment 11 Commit Notification 2015-08-18 06:25:32 UTC
andreask committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9eec11735cf929cbb5da72bc500e9ad1735c4bf3

Breeze: StartCenter icon size fixed to 32px tdf#93064 tdf#92242

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Dave Richards 2015-08-18 13:00:47 UTC
Request please this patch also be applied to 5.0.x.  As it stands right now, it's impossible to open LO in 1024x768 with the Breeze theme selected (which is our default theme).
Comment 13 Yousuf Philips (jay) (retired) 2015-08-18 13:42:05 UTC
Cherry picked for 5.0.1 and 5.0.x.

https://gerrit.libreoffice.org/#/c/17838/
https://gerrit.libreoffice.org/#/c/17839/
Comment 14 Commit Notification 2015-08-18 15:11:33 UTC
andreask committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a23d5bc8bb3c43f31d2d66fcac0d28e273d948a8&h=libreoffice-5-0

Breeze: StartCenter icon size fixed to 32px tdf#93064 tdf#92242

It will be available in 5.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 15 Commit Notification 2015-08-21 08:48:09 UTC
andreask committed a patch related to this issue.
It has been pushed to "libreoffice-5-0-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1c66224c161b930427f6ae8544abe08b881ab200&h=libreoffice-5-0-1

Breeze: StartCenter icon size fixed to 32px tdf#93064 tdf#92242

It will be available in 5.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 16 Robinson Tryon (qubit) 2015-12-17 10:59:24 UTC Comment hidden (obsolete)
Comment 17 Telesto 2016-12-02 14:26:17 UTC
*** Bug 104328 has been marked as a duplicate of this bug. ***
Comment 18 Alex Thurgood 2016-12-05 10:14:20 UTC Comment hidden (obsolete)
Comment 19 Alex Thurgood 2016-12-05 10:15:29 UTC
This bug has re-appeared on LO5233 on macOS - re-opening
Comment 20 Alex Thurgood 2017-06-27 10:39:20 UTC
Closing once again as WFM in 

Version: 5.3.4.2
Build ID: f82d347ccc0be322489bf7da61d7e4ad13fe2ff3
Threads CPU : 4; Version de l'OS :Mac OS X 10.12.5; UI Render : par défaut; Moteur de mise en page : nouveau; 
Locale : fr-FR (fr_FR.UTF-8); Calc: group
Comment 21 steve -_- 2017-06-27 12:42:58 UTC
Version: 5.5.0.0.alpha0+
Build ID: 0e6297932252403883a6057feee488e4ee2bc360
CPU threads: 8; OS: Mac OS X 10.12.5; UI render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2017-05-22_23:39:45
Locale: de-DE (de_DE.UTF-8); Calc: group

Verified

Sadly no newer nightly is available so fingers crossed it has not been re-introduced.