Bug Hunting Session
Bug 92266 - when installing korean version, Konkani is also installed as a default langauge
Summary: when installing korean version, Konkani is also installed as a default langauge
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
4.4.3.2 release
Hardware: Other All
: medium normal
Assignee: Andras Timar
URL:
Whiteboard: target:5.3.0
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-23 04:29 UTC by Jihui Choi
Modified: 2016-09-21 21:44 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jihui Choi 2015-06-23 04:29:37 UTC
I installed libreoffice 4.4.3 and 5.0.0,
through custom installation.
in add user interface language, Konkani and Korean are checked.

see this.
https://ci3.googleusercontent.com/proxy/YEzH_WmGXH5fDGEG36ViCoAHKKByt0MNGOg4S9Lm_xrhRg-pH_78U4Z9WTDRY_5wG0ZWb_PF2m79rdN4uzBF0_u6NecwgzrdpsDEDOeQJos=s0-d-e1-ft#http://nabble.documentfoundation.org/file/n4152298/111.png


This might make a problem with korean.
below post said, he had a problem with korean, but after removing Konkani langauge, everything worked fine.
http://blog.daum.net/_blog/BlogTypeView.do?blogid=0SrqB&articleno=173&categoryId=0&regdt=20140227072733
Comment 1 Aron Budea 2016-05-07 11:33:44 UTC
Thank you for the bug report.

I can confirm with 5.1.2 installer that 콘카이어 is selected by default if Control Panel -> Region and Language -> Formats -> Format: is set to Korean (Korea) in Windows 7.

Is that the correct name for Konkani in Korean? Just wondering because googling "콘카이어" only turned up results related to this specific issue.
Comment 2 Aron Budea 2016-09-07 20:14:05 UTC
András, do you have an idea from the top of your head where this might be coming from?
Comment 3 Andras Timar 2016-09-07 21:52:26 UTC
(In reply to Aron Budea from comment #2)
> András, do you have an idea from the top of your head where this might be
> coming from?

Korean is 'ko', Konkani is 'kok'. So it makes sense. ;) Some string comparison error, probably.

Code pointer: setup_native/source/win32/customactions/sellang/sellang.cxx
Comment 5 Andras Timar 2016-09-08 08:38:10 UTC
https://gerrit.libreoffice.org/28744

Untested. I'll test it, then push, if it's OK.
Comment 6 Commit Notification 2016-09-21 21:41:54 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0794fb0edc85bf147e4d199e541efaad578e4b96

tdf#92266 better language selection in Windows installer

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.