Bug 92312 - FILESAVE: Saving to OOXML appends an X to a comment on a hyperlink
Summary: FILESAVE: Saving to OOXML appends an X to a comment on a hyperlink
Status: RESOLVED DUPLICATE of bug 85523
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.3.2 release
Hardware: Other All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Hyperlink DOCX-Comments
  Show dependency treegraph
 
Reported: 2015-06-24 15:03 UTC by Jeff Fortin Tam
Modified: 2018-02-11 22:08 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
simplified sample - docx file generated by libreoffice (43.66 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-06-24 15:07 UTC, Jeff Fortin Tam
Details
Screenshot of the file after save in LO 5.4.4 (144.33 KB, image/png)
2018-02-11 22:06 UTC, Gabor Kelemen (allotropia)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeff Fortin Tam 2015-06-24 15:03:11 UTC
I think I figured out the patterns to some major .docx export bugs regarding comments/notes:

- Clicking the "Save" button in the toolbar after editing a comment will silently insert an uppercase "X" character at the end of the comment (at the cursor position?)

- Clicking the "Save" button will not actually save the changed contents, only the appended X.

- The only way for the changed contents to be recorded in the file is to do a change, click the window manager's close button to exit LibreOffice, and answer "Save" at the confirmation prompt. Then the changes get recorded, along with the "X" character. What the...?
Comment 1 Jeff Fortin Tam 2015-06-24 15:05:28 UTC
Demonstration: http://jeff.ecchi.ca/public/libreoffice-92312.webm
Comment 2 Jeff Fortin Tam 2015-06-24 15:07:16 UTC
Created attachment 116803 [details]
simplified sample - docx file generated by libreoffice
Comment 3 Jeff Fortin Tam 2015-06-24 15:30:30 UTC
Even weirder: if you have two comments, and you edit comment #1, then click Close & confirm "Save" on exit... the X gets appended to the second comment instead of the one you edited!
Comment 4 Gordo 2015-06-25 17:07:44 UTC
I can reproduce the "X" being added to comments on hyperlinks.  The first time the document is reloaded an "X" appears.  If you do not modify the document and close it and open it in MS Word Viewer then there is no "X".  The next time the document is amended then that "X" is saved and is viewable in MS Word Viewer.

I could not reproduce the lose of data.

Windows Vista 64
Version: 4.4.4.3
Build ID: 2c39ebcf046445232b798108aa8a7e7d89552ea8

Version: 5.1.0.0.alpha1+
Build ID: 89b5967658392d27fb3147e85abb2b5c1c34b101
TinderBox: Win-x86@39, Branch:master, Time: 2015-06-24_04:10:17

Does not happen in 4.3.7.2.
Comment 5 Gordo 2015-06-25 18:32:46 UTC
Comments not saving already exists as bug 73221.
Comment 6 QA Administrators 2016-09-20 10:10:44 UTC Comment hidden (obsolete)
Comment 7 Gabor Kelemen (allotropia) 2018-02-11 22:06:51 UTC
Created attachment 139801 [details]
Screenshot of the file after save in LO 5.4.4

The two problems reported are now gone in 5.4.
- The extra X being added was fixed in bug #85523
- The inability to save while editing a comment was fixed in bug #68604
Comment 8 Gabor Kelemen (allotropia) 2018-02-11 22:08:29 UTC
Let's set this as a duplicate.

*** This bug has been marked as a duplicate of bug 85523 ***