Download it now!
Bug 92330 - Awkward navigation for vertical text in table (character formatting)
Summary: Awkward navigation for vertical text in table (character formatting)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.4.2.2 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Vertical-Text
  Show dependency treegraph
 
Reported: 2015-06-25 12:42 UTC by Ramil
Modified: 2019-12-11 11:19 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ramil 2015-06-25 12:42:38 UTC
When use vertical text in the table cell can not use Up and Down arrows. Work only Left and Right arrows. It is annoying when working with more than one strings of text.
Comment 1 Jacques Guilleron 2015-06-25 15:04:23 UTC
Hi ⚡ Thunde® ⚡,

There is another way to get a text vertical in a table where navigation within text is possible with arrows:

right clic in a cell with text > Table Properties... > Text Flow > Text orientation > Vertical

Is it a good way for you?

Jacques
Comment 2 Buovjaga 2015-06-25 16:11:00 UTC
(In reply to Jacques Guilleron from comment #1)
> Hi ⚡ Thunde® ⚡,
> 
> There is another way to get a text vertical in a table where navigation
> within text is possible with arrows:
> 
> right clic in a cell with text > Table Properties... > Text Flow > Text
> orientation > Vertical
> 
> Is it a good way for you?

IMO it is not sufficient, because there is only one orientation choice, not 90 and 270 degrees like in character rotation.

Confirmed the arrow issue.

I see this more as a bug than an enhancement, so changing severity field.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+ (x64)
Build ID: a51ac4d2bb8c4f1ea1d4ea7569863e2fb6535b02
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-06-22_21:37:53
Locale: fi-FI (fi_FI)
Comment 3 Jacques Guilleron 2015-06-25 21:02:09 UTC
OK. To complete, I add an old request to See Also:
Bug 60006 - TABLE: add a left-to-right vertical text direction to Text Flow tab, Table Properties dialog

Jacques
Comment 4 QA Administrators 2016-09-20 10:09:51 UTC Comment hidden (obsolete)
Comment 5 QA Administrators 2019-12-11 03:38:42 UTC Comment hidden (obsolete)
Comment 6 Ramil 2019-12-11 07:45:47 UTC
This bug is no longer relevant. Checked in 6.3.
Comment 7 Buovjaga 2019-12-11 11:19:02 UTC
(In reply to Ramil from comment #6)
> This bug is no longer relevant. Checked in 6.3.

The problem is still present with character formatting, but now table cell vertical orientation has two directions, so I guess it can be seen as irrelevant