Bug Hunting Session
Bug 92358 - SLIDESHOW with custom animations: some animations don't run as expected
Summary: SLIDESHOW with custom animations: some animations don't run as expected
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.4.3.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Custom-Animations
  Show dependency treegraph
 
Reported: 2015-06-26 16:06 UTC by richard_g
Modified: 2019-01-14 18:21 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Sample presentation for testing custom animation with sounds (14.32 KB, application/vnd.oasis.opendocument.presentation)
2015-06-26 16:06 UTC, richard_g
Details

Note You need to log in before you can comment on or make changes to this bug.
Description richard_g 2015-06-26 16:06:43 UTC
Created attachment 116849 [details]
Sample presentation for testing custom animation with sounds

Hello

Some problems with custom animations in slideshow on Linux although they are running fine on Windows. I attach a sample presentation showing two problems.

1. First slide: some text is hidden below two blue rectangles. Click to remove the first rectangle so as the text below becomes visible. The second text should remain hidden. Click again to remove the second rectangle, and the second text becomes visible.

On Windows, all is OK, the second text remains hidden at first click. But on Linux, at first click, the text below the second rectangle comes on top of the rectangle.

2. Second slide: you should hear the "apert" sound from gallery at slide transition. You can hear this sound both on Windows and on Linux. Here again there is a text under a blue rectangle. When you click, the rectangle disappears and you should hear the "falling" sound from gallery. You can hear this second sound on Windows, but not on Linux. Maybe the sound problem is linked to bug 64199?

Note: the sample document has been built on Windows with relative pathnames. When opened on Linux, no sound could be heard, and I had to re-assign sounds from gallery for custom animation and for slide transition (it seems that the relative Windows pathnames are not recognized by Linux?). This sample file is the one with re-assigned sounds on Linux. The slide transition sound can be heard on my two versions of Libre Office installed in parallel (4.0.4 and 4.4.3)
Comment 1 Buovjaga 2015-07-01 16:27:49 UTC
I confirm the text problem in Slide 1 on Linux.
Can't hear *ANY* sound on Win or Linux. It is not some multimedia problem, sounds work otherwise in both OSs.

That said: you should create a new report for the sound issue and let this one be about the first slide (one issue per report -policy). Link the new report here and I will run over and confirm it.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+ (x64)
Build ID: 3a6ec53eeeec71312f5ea890689f9c2ee79c2aac
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-07-01_02:24:40
Locale: fi-FI (fi_FI)

Ubuntu 15.04 64-bit 
Version: 4.4.4.3
Build ID: 40m0(Build:3)
Locale: en_US.UTF-8
Comment 2 richard_g 2015-07-02 10:00:18 UTC
Hello.

I saved the odp on this page without sounds! Sorry for the mistake.

I opened a new bug report for the sound with a new sample odp with sounds:

https://bugs.documentfoundation.org/show_bug.cgi?id=92489

I downloaded the sample from the bug report page and I tested it with LibO444 Linux: sound on transition is OK, but no sound on custom animation.
Comment 3 QA Administrators 2016-09-20 10:14:09 UTC Comment hidden (obsolete)
Comment 4 Timur 2019-01-14 17:01:11 UTC
Looks like fixed long time ago. I couldn't reproduce in slideshow with LO 5.4.
Comment 5 Buovjaga 2019-01-14 18:21:13 UTC
(In reply to Timur from comment #4)
> Looks like fixed long time ago. I couldn't reproduce in slideshow with LO
> 5.4.

True.

Arch Linux 64-bit
Version: 6.3.0.0.alpha0+
Build ID: 6e3c4ae8bca898700cde9caaff43c3a8a61eebc2
CPU threads: 8; OS: Linux 4.20; UI render: default; VCL: gtk3; 
Locale: fi-FI (fi_FI.UTF-8); UI-Language: en-US
Calc: threaded
Built on 13 January 2019