Download it now!
Bug 92385 - Format problem
Summary: Format problem
Status: RESOLVED DUPLICATE of bug 75242
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.4.2 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX
  Show dependency treegraph
 
Reported: 2015-06-27 14:30 UTC by W. Lindsay Wheeler
Modified: 2017-04-18 08:16 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Part of the Book with the bad formatting (7.66 KB, application/zip)
2015-06-29 22:40 UTC, W. Lindsay Wheeler
Details
The 4th Revision The Case of the Barefoot Socrates (313.05 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-06-30 22:40 UTC, W. Lindsay Wheeler
Details
The 5th Revision The Case of the Barefoot Socrates (216.23 KB, application/vnd.oasis.opendocument.text)
2015-06-30 22:47 UTC, W. Lindsay Wheeler
Details
odt file from version 4 (195.42 KB, application/vnd.oasis.opendocument.text)
2015-07-01 17:24 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description W. Lindsay Wheeler 2015-06-27 14:30:09 UTC
I have written a small book using Libre Office Writer. It was 140 some pages. It is now expanded to 562 pages. with 435,786 characters. I am not computer savvy or software savvy or Writer savvy. I don't understand this. And I don't know why it is like this. The first three pages are fine, but thin on the fourth page, there is a couple of lines and then a lot of page.
Comment 1 Julien Nabet 2015-06-28 09:30:06 UTC
On which env are you? Linux, MacOs, Windows?
Which LibreOffice do you use?
Finally, did you make backup of your files to try an older version?
Comment 2 W. Lindsay Wheeler 2015-06-28 19:19:23 UTC
I am on Vista Home premium.  I have Libre Office 4.4. And I don't have an older version. I believe this is my only version.
Comment 3 W. Lindsay Wheeler 2015-06-28 19:21:17 UTC
It has to do with the footnotes. And I don't know how to correct it. It is one footnote per page and where the footnote appears, is the end of the page. I don't know how it got there because I certainly didn't change anything in the drop down menus.

Thanks if you can help me.
Comment 4 Julien Nabet 2015-06-29 20:27:24 UTC
Usually, I would ask to provide the file but since it's your book I expect you won't provide it :-)
Anyway, here are some docs here: http://www.libreoffice.org/get-help/documentation/

There are several 4.4 versions: 4.4.0, 4.4.1, ... last one is 4.4.3 and there'll be very soon 4.4.4. Could you give the precise version you use?
Comment 5 W. Lindsay Wheeler 2015-06-29 22:40:57 UTC
Created attachment 116936 [details]
Part of the Book with the bad formatting

I have attached a part of the book. Should have thought of that earlier. I did not want to send the whole thing. I hope this helps. 

Thanks for your time and expertise.

WLW
Comment 6 Julien Nabet 2015-06-30 16:36:27 UTC
Indeed, on pc Debian x86-64 with master sources (future 5.1.0) updated today, I opened the file and after the fourth page had only blank or almost blank pages.

1) Do you have an odt version (since "odt" is the native format of Writer) of your book? If yes, do you have the same problem?
2) Do you have old backup of the book in docx where you don't encounter this pb?
3) Just for curiosity, with which LibreOffice version did you begin this book?

(BTW, have in mind that any attachment is automatically made public)
Comment 7 W. Lindsay Wheeler 2015-06-30 22:40:23 UTC
Created attachment 116959 [details]
The 4th Revision The Case of the Barefoot Socrates
Comment 8 W. Lindsay Wheeler 2015-06-30 22:47:16 UTC
Created attachment 116960 [details]
The 5th Revision The Case of the Barefoot Socrates

The book is free and online so I don't care who reads it. My rectitude about it is that it is very reactionary in this age of political correctness and so....

Any way I made four revisions of the book and I started my fifth. All I did was I did "save as" on Rev 4 with some changes and later on, I come back to find 567 pages!  If you can correct it and send it back to me, I would be greatly appreciated. 

So I have attached Rev. 4 that does not show the gaping pages and Rev. 5 that does.

The Libre Office for Rev 2 was Version: 4.4.3.2
Build ID: 88805f81e9fe61362df02b9941de8e38a9b5fd16
Locale: en_US

The Libre Office for Rev 5 was Version: 4.4.3.2
Build ID: 88805f81e9fe61362df02b9941de8e38a9b5fd16
Locale: en_US

I don't know if I changed Libre Office mid field.
Comment 9 Julien Nabet 2015-07-01 17:24:26 UTC
Created attachment 116975 [details]
odt file from version 4

On pc Debian x86-64 with LO Debian package 4.4.4, I opened version 4 and saved in odt, 178 pages, so I suppose ok.
To investigate we would need to know exactly what changes you made.

Anyway, depending on how many changes there are between version 4 and 5, if just a few, I'd start from version 4 again.
Then I'd make the changes little by little and would save in odt (since it's the reference format for Writer).

Once you applied all your changes, make a last save, close and reopen the odt file to see if everything is alright.

Then, if you really need docx format, save your odt file in docx.

For next changes, start from your odt version.

Keep us informed! :-)
Comment 10 W. Lindsay Wheeler 2015-07-02 00:12:42 UTC
That is why I came here. I don't remember what changes I made. I added to the text with new information scattered throughout the text. That was three months ago. Now, I have to search line by line?

Did you open the 5th Revision? What about fiddling with the footnote parameters?  Will that fix that? From what I see, it made a page after every footnote!  How did that happen?

Oh vey. Thanks. Yuk. Now, I have to go page by page, thru 563 pages and compare it with version 4. Who has the time for that? I guess I will have to make time.
Comment 11 Julien Nabet 2015-07-02 05:40:21 UTC
Sorry can't help here since I don't know how to reproduce this :-(

Certainly someone may help.
Comment 12 MM 2015-07-02 19:09:15 UTC
(In reply to W. Lindsay Wheeler from comment #7)
> Created attachment 116959 [details]
> The 4th Revision The Case of the Barefoot Socrates

If I open this one and save it directly to docx again (and reload the doc), the pages are expanded to 524 pages. Doesn't happen with ODT though.

Tested with v4.4.4.3 under windows 7 x64 and v4.4.4.3 / 5.0.0.2 under mint 17.1 x64.
Comment 13 W. Lindsay Wheeler 2015-07-02 19:16:33 UTC
(In reply to MM from comment #12)
> (In reply to W. Lindsay Wheeler from comment #7)
> > Created attachment 116959 [details]
> > The 4th Revision The Case of the Barefoot Socrates
> 
> If I open this one and save it directly to docx again (and reload the doc),
> the pages are expanded to 524 pages. Doesn't happen with ODT though.
> 
> Tested with v4.4.4.3 under windows 7 x64 and v4.4.4.3 / 5.0.0.2 under mint
> 17.1 x64.

Okay, we are getting somewhere!  So I was right to report this?  I didn't cause this to happen but somehow during a reload, it automatically expands to 562 pages?  Do I have this right?

Can this be fixed? In Rev 5 I already made changes, but I don't remember where or how many I made. So how do shrink Rev 5 or repair Rev 5? Thank you very much for your time and trouble. I appreciate this.
Comment 14 MM 2015-07-05 19:49:02 UTC
(In reply to W. Lindsay Wheeler from comment #13)

> In Rev 5 I already made changes, but I don't remember
> where or how many I made. So how do shrink Rev 5 or repair Rev 5? Thank you
> very much for your time and trouble. I appreciate this.

You can open the 4th revision, then select 'Edit - Compare Documents' and select the 5th revision. Now you see what you've inserted / deleted.
Comment 15 W. Lindsay Wheeler 2015-07-05 21:25:39 UTC
(In reply to MM from comment #14)
> (In reply to W. Lindsay Wheeler from comment #13)
> 
> > In Rev 5 I already made changes, but I don't remember
> > where or how many I made. So how do shrink Rev 5 or repair Rev 5? Thank you
> > very much for your time and trouble. I appreciate this.
> 
> You can open the 4th revision, then select 'Edit - Compare Documents' and
> select the 5th revision. Now you see what you've inserted / deleted.

Thanks. I will do that. 

WLW
Comment 16 Timur 2015-07-06 13:04:34 UTC
Looks like an extreme case and s duplicate of Bug 75242. 
Note lines/paragraphs already in footnote in attachment 116959 [details].
Comment 17 MM 2015-07-07 18:33:06 UTC
In bug 75242 there's 1 line added the 2nd footnote, not the first. So it must be a very very very extreme case then, going from 180 pages to more than 500 pages.
Comment 18 QA Administrators 2016-09-20 10:21:01 UTC Comment hidden (obsolete)
Comment 19 Timur 2017-04-18 08:16:09 UTC
This bug doesn't make sense to stay open. It's most likely a duplicate of Bug 75242 which was resolved long time ago in 5.1.

*** This bug has been marked as a duplicate of bug 75242 ***