Bug 92394 - CMIS error in version control
Summary: CMIS error in version control
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
(earliest affected) rc
Hardware: All All
: medium normal
Assignee: Not Assigned
: 95653 104274 (view as bug list)
Depends on:
Blocks: File-Versioning
  Show dependency treegraph
Reported: 2015-06-28 06:34 UTC by Thomas Krumbein
Modified: 2022-04-20 06:14 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:

Error message on CMIS (29.48 KB, image/jpeg)
2015-06-28 06:34 UTC, Thomas Krumbein

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Krumbein 2015-06-28 06:34:41 UTC
Created attachment 116880 [details]
Error message on CMIS

Clicking on CMIS button in Version Control (module Formula Editor) the following error-message occurs (see screenshot). 

Version 32 bit build of LibreOffice 

System: Win 8.1 64 bit.
Comment 1 Jan Holesovsky 2015-07-02 13:11:41 UTC
Hi Thomas - can you please be more specific about the reproduction steps?  Like, what server are you accessing, what type of document, from where are you opening that, etc.?

Thank you a lot!
Comment 2 Xisco Faulí 2016-09-10 15:05:44 UTC Comment hidden (obsolete)
Comment 3 Thomas Krumbein 2016-09-11 07:59:40 UTC
Sorry guys, this bug is more then 1 year old. 

Nothing have change since this time.

To reproduce:

- create a new Document (for example a calc-Dokument)
- insert some content.
- store the document (does not matter where - I just use desktop)
- reopen document - call menu entry file -> versions 
- button "CMIS" is active - you can klick on it.
- submittet error message occurs.

Still the same hehaviour: LIBo (64 bit) on Win 10-

I do not use any Server.

so - in my opinion: The error message is not understandable for an typical user.

 Two posibilities:
 - disable CMIS button if CMIS is not used
 - create an readable errormessage something like "Sorry, your CMIS configuration is still not finished"
Comment 4 Buovjaga 2016-10-03 17:47:17 UTC
No CMIS button detected in Versions. Maybe I have to try on Windows.

Arch Linux 64-bit, KDE Plasma 5
Build ID: dc41255dc725dfa912326cc5d9e420bd66471c64
CPU Threads: 8; OS Version: Linux 4.7; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on October 1st 2016

Arch Linux 64-bit, KDE Plasma 5
Build ID: 5.2.2-1
CPU Threads: 8; OS Version: Linux 4.7; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Comment 5 Buovjaga 2016-10-04 11:28:23 UTC
Ok I repro: you have to enable experimental features!!

Win 7 Pro 64-bit Version:
Build ID: 7da2f3ce9f7b049c177a735a146dae84a764d3f7
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-10-04_03:49:06
Locale: fi-FI (fi_FI); Calc: CL
Comment 6 Yousuf Philips (jay) (retired) 2017-04-18 17:30:21 UTC
*** Bug 95653 has been marked as a duplicate of this bug. ***
Comment 7 Yousuf Philips (jay) (retired) 2017-04-18 17:30:33 UTC
*** Bug 104274 has been marked as a duplicate of this bug. ***
Comment 8 QA Administrators 2018-04-19 02:34:44 UTC Comment hidden (obsolete)
Comment 9 QA Administrators 2020-04-19 03:36:19 UTC Comment hidden (obsolete)
Comment 10 QA Administrators 2022-04-20 03:37:35 UTC Comment hidden (obsolete)
Comment 11 Thomas Krumbein 2022-04-20 05:17:44 UTC
CMIS Button is disabled if not used.

Version: (x64)
Build ID: 8349ace3c3162073abd90d81fd06dcfb6b36b994
CPU threads: 8; OS: Windows 10.0 Build 19043; UI render: Skia/Raster; VCL: win
Locale: de-DE (de_DE); UI: de-DE
Calc: CL