Bug Hunting Session
Bug 92412 - KDE3 vclplug is badly broken
Summary: KDE3 vclplug is badly broken
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
4.4.3.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-06-29 00:38 UTC by Ilya Chernykh
Modified: 2015-09-04 10:03 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (250.51 KB, image/png)
2015-06-29 00:38 UTC, Ilya Chernykh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ilya Chernykh 2015-06-29 00:38:19 UTC
Created attachment 116903 [details]
screenshot

LibreOffice integration with KDE3 does not work on openSUSE where KDE3 is still supported. This happens as of openSUSE 13.2 and LibreOffice 4.4.

A screenshot of the garbage reported by users is attached. 

I suspect the Trinity team commits as the cause, particularly this one
https://gerrit.libreoffice.org/#/c/2374/2/shell/inc/shell/tde_headers.h

because under Trinity desktop all works well. I think the commit should be reverted of modified so not to cause any troubles to KDE3 users who does not use Trinity.
Comment 1 Maxim Monastirsky 2015-07-06 13:25:19 UTC
Confirmed under F22 with this build:

Version: 5.1.0.0.alpha1+
Build ID: 3c45bfb0cabf206f6217f1de9eb5cfa12b78e46f
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-07-04_01:25:39

Also confirmed by many people in Bug 89613.

(In reply to Ilya Chernykh from comment #0)
> I suspect the Trinity team commits as the cause, particularly this one
> https://gerrit.libreoffice.org/#/c/2374/2/shell/inc/shell/tde_headers.h
Unlikely.
Comment 2 Maxim Monastirsky 2015-09-04 10:03:56 UTC
KDE3 support is dropped in master.