Bug Hunting Session
Bug 92489 - SLIDESHOW with custom animations: sound is lost with Linux
Summary: SLIDESHOW with custom animations: sound is lost with Linux
Status: RESOLVED DUPLICATE of bug 40780
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.4.4.3 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-02 09:55 UTC by richard_g
Modified: 2016-11-21 19:17 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
sample odp with sounds from gallery (14.35 KB, application/vnd.oasis.opendocument.presentation)
2015-07-02 09:55 UTC, richard_g
Details

Note You need to log in before you can comment on or make changes to this bug.
Description richard_g 2015-07-02 09:55:52 UTC
Created attachment 116990 [details]
sample odp with sounds from gallery

Hello,

As said in https://bugs.documentfoundation.org/show_bug.cgi?id=92358, sound in custom animations is lost on Linux version. The sample odp file on this page was saved without sound, sorry for the mistake.

Here is a new sample odp with sounds from gallery:
- transition to slide 2 with sound "apert"
- blue rectangle on slide 2 with custom animation should disappear on click with sound "falling"

Tested with LibO 4.4.4 on Linux CentOS 6 64 bits

When playing slideshow with Linux version, I hear the transition sound, but not the animation sound.

If you don't hear no sound, please re-assign yourself new sounds from gallery. You should hear transition sounds.
Comment 1 Buovjaga 2015-07-02 10:13:17 UTC
There was no sound for the slide transition. After I assigned apert to it, it worked ok. However, it is lost upon save & reload.

If I right-click the Shape1 custom animation in slide 2 and select Effect options, I can't hear anything in the falling sound preview! All random other sounds I try seem to work.

Win 7 Pro 64-bit, Version: 4.4.4.3
Build ID: 2c39ebcf046445232b798108aa8a7e7d89552ea8
Locale: fi_FI

Version: 5.1.0.0.alpha1+ (x64)
Build ID: 3a6ec53eeeec71312f5ea890689f9c2ee79c2aac
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-07-01_02:24:40
Locale: fi-FI (fi_FI)
Comment 2 richard_g 2015-07-02 12:33:25 UTC
If I download the sample odp from this page and save it with another name on my Linux workstation, I can hear the sound for slide transition.

However, I had the same problem as you had when copying to my Linux workstation a sample odp built with sounds on a Windows computer: on Linux, the transition panel for slide 2 shows "no sound", although it shows the "apert" sound on Windows! The sound selection seems to be lost when copying the document to another computer or OS!

Now, for the custom animation, opening on Linux the odp built on Windows, if I right click the Shape1 custom animation in slide 2 and select Effect options, I see that the "falling" sound is selected, but I can't hear it in the sound preview. Selecting any another sound, I can hear it in the preview. Same thing as you. But if I select again "falling" after having tested other sounds, I can hear it again in the preview. But always no sound in slideshow for this custom animation.
Comment 3 Thomas Hackert 2016-02-01 17:53:12 UTC
Hello Richard, *,
as Beluga in Comment1 reported it, there was no sound in your presentation ... :( But nonetheless, I can reproduce your bug with one from MozTrap (http://manual-test.libreoffice.org/media/attachments/2014/05/24/test40.odp), where I added some test sounds for slide transition, which does not work ... :( With your attached ODP file, LO just crashes after the end of the second slide ... :(

OS: Debian Testing AMD64
LO: Version: 5.1.0.3
Build-ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737
CPU Threads: 4; OS Version: Linux 4.3; UI Render: default; 
Gebietsschema: de-DE (de_DE.UTF-8)

(parallelly installed, following the instructions from https://wiki.documentfoundation.org/Installing_in_parallel/Linux with de_DE-lang as well as helppack)
HTH and have a nice evening
Thomas.
Comment 4 Mike A. Fargo 2016-06-22 12:12:55 UTC
I already filed a bug about losing external soundfiles.

But this issue seems to relate to another bug, I found:
It is not possible to add sound to animated objects,
i.e. they wouldn't play. 

In my case, I choosed "other sounds", and added an mp3 file.

Same procedure works with slide transition.

Workaround: Re-Sample your sound with audacity and add
some seconds of silence ahead. Then you here the
sound effect delayed as intended.
(Only works with fix times).
Comment 5 Buovjaga 2016-11-21 19:17:50 UTC
Did some testing for this problem due to discussions on IRC. I found an older duplicate.

*** This bug has been marked as a duplicate of bug 40780 ***