Bug Hunting Session
Bug 92500 - DOCX created by LibO not opened by other word processing software
Summary: DOCX created by LibO not opened by other word processing software
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.4.3.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-07-02 14:34 UTC by Jonathan Camilleri
Modified: 2016-10-10 11:32 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
attachment (76.62 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-07-02 14:34 UTC, Jonathan Camilleri
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Camilleri 2015-07-02 14:34:44 UTC
Created attachment 116999 [details]
attachment

When I send my CV out to some people it is common that they complain that they cannot open it.

I can open it with LibreOffice Writer v4.4.3.2, however, other people cannot open the attachment, although they do not quite state which software they are using.
Comment 1 Jonathan Camilleri 2015-07-02 14:35:18 UTC
Europass CV information at https://europass.cedefop.europa.eu/pt/documents/curriculum-vitae, this is where I originally downloaded the template.
Comment 2 tommy27 2015-07-03 07:08:36 UTC
please get information about the exact software version they use and which cannot open your CV.

as a workaround, what about sending it as PDF?
Comment 3 tommy27 2015-07-03 07:15:34 UTC
edited summary notes for clarity

check this: http://www.viewdocsonline.com/document/e1eafp

the document can be show on an online viewer site.
I only see some issue with the header.
Comment 4 Buovjaga 2015-07-03 12:40:44 UTC
(In reply to Jonathan Camilleri from comment #0)
> Created attachment 116999 [details]
> attachment

MSO 2013 opens it fine. Even the header image is displayed intact, while in LibO, it has a white rectangle going over it!

As MSO displays it better than LibO, I'm tempted to set this as NOTOURBUG. The software these other people are using is apparently not MSO and is thus evidently lacking in the interoperability department.

I'll set to NEEDINFO, while we wait for the software information.

Win 8.1 32-bit MSO 2013
Version: 5.0.0.2
Build ID: a26d58f11b99b6aeddf7f7884effea188cc6e512
Locale: fi-FI (fi_FI)
Comment 5 tommy27 2015-07-03 12:54:32 UTC
(In reply to Beluga from comment #4)
> (In reply to Jonathan Camilleri from comment #0)
> > Created attachment 116999 [details]
> > attachment
> 
> MSO 2013 opens it fine. Even the header image is displayed intact, while in
> LibO, it has a white rectangle going over it!

we should file a separate bug report about this issue in LibO.
who's gonna do it, me or you beluga?
Comment 6 Buovjaga 2015-07-03 13:21:42 UTC
(In reply to Jonathan Camilleri from comment #1)
> Europass CV information at
> https://europass.cedefop.europa.eu/pt/documents/curriculum-vitae, this is
> where I originally downloaded the template.

I input some test data in Europass and downloaded all those formats.

If I open the .odt file in LibO and save to .docx, I don't get the white rectangle over the header image.

If I open the .doc file in LibO and save to .docx, I get the white rectangle over the header image.

The white rectangle appears to be a highlight in the style for the paragraph.

However, we don't know, what kind of engine Europass uses. Is it actual MSO tech?

I guess I can make a new report for the .doc -> .docx thing.
Comment 7 Buovjaga 2015-07-03 13:37:06 UTC
Bug 92524 added for the highlight issue.
Comment 8 Xisco Faulí 2016-09-10 14:59:50 UTC Comment hidden (obsolete)
Comment 9 Xisco Faulí 2016-10-10 11:32:59 UTC
Dear Bug Submitter,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INSUFFICIENTDATA due to inactivity and
a lack of information which is needed in order to accurately
reproduce and confirm the problem. We encourage you to retest
your bug against the latest release. If the issue is still
present in the latest stable release, we need the following
information (please ignore any that you've already provided):

a) Provide details of your system including your operating
   system and the latest version of LibreOffice that you have
   confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED
and we will attempt to reproduce the issue. Please do not:

a) respond via email 

b) update the version field in the bug or any of the other details
   on the top section of our bug tracker

Warm Regards,
QA Team

MassPing-NeedInfo-20161010